nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVidia, Tyan k8w, xorg and acpi. (http://www.nvnews.net/vbulletin/showthread.php?t=30324)

drumz 06-19-04 01:33 PM

NVidia, Tyan k8w, xorg and acpi.
3 Attachment(s)
Problem: Enabling ACPI causes the screen to shrink to about 1" in height with diagonal lines. You can still connect remotely via ssh and find that the X process is consuming 100% of the CPU.

Enabling ACPI is needed so my machine properly powers off when performing a shutdown. Otherwise I have to hit the power button. Other people, using different brand video cards, are not experiencing this problem. Everything during boot is fine, until it's time for the nvidia drivers to kick in it seems. Disabling gui login so I just get a text console works perfectly fine, of course until you issue a 'startx' command.

If I add 'acpi=off' to kernel boot parameters all is well except for ability to power off.

OS: Gentoo as total AMD64 64bit environment
Drivers: as emerged from Gentoo (emerge nvidia-kernel; emerge nvidia-glx)
nvidia-kernel: 1.0.5332-r1
nvidia-glx: 1.0.5332-r2
kernel: gentoo-dev-sources v2.6.5-r1
MB: Tyan Thunder K8W (S2885)
BIOS: latest (2.0.2)
Video: NVidia GeForce 5700
Xorg: xorg-x11-6.7.0-r1
Logs: I've attached the Xorg.problem.txt as xorg log file when the problem happens.
Logs: I've attached the Xorg.acpidisabled.txt as xorg log file when acpi is disabled.
Logs: I've attached a gdb backtrace (using commands found here in forum)

lspci output:
05:00.0 VGA compatible controller: nVidia Corporation NV 36 [GeForce 5700] (rev a1)

Hope this leads to a solution for everyone that may be experiencing the same problem......

I'll be happy to provide additional information, just tell me what you need (and either point me to commands or provide necessary commands to make sure you get what you want unless it's really obvious ;-) )



alien999999999 06-19-04 02:46 PM

Re: NVidia, Tyan k8w, xorg and acpi.
maybe the monitor frequencies are higher, because with ACPI nvidia can probe the monitors frequencies, which could fail?

something with ingnoreEDID or something similar...

try looking in the /var/log/messages and follow a bootup sequence and look for clues to do with ACPI...

drumz 06-19-04 05:00 PM

Re: NVidia, Tyan k8w, xorg and acpi.
I looked through /var/log/messages but there's no indications of problems or errors.

ScofieldKid 08-30-04 04:27 PM

Re: NVidia, Tyan k8w, xorg and acpi.
Yeah, getting killed here as well.

It appears that triggering the 3D functions brings on death.

So for example, I can say: glxgears, and whamo. Instant reboot.

Linux Kernel:
acpi=off pci=noacpi
K8W bios is 2.02 I think, upgraded from 1.02.
Card is: 5900XT

I had thought this was a 3ware conflict, but no such luck.
I am using the 32-bit slot on a Promise SATA TX2-150 to
eliminate the onboard SATA as an issue. So... so far, it really
looks like possibly a glx.o entry point is exercising this bug.

Really sad. Sometimes it happens, sometimes it doesnt.
But if it is going to happen, just running glxgears is enough
to make it happen.

Too bad. It will be nice to see if *TYAN* or *NVIDIA* come up
with a solution for this nightmare. NOTE: I have removed rivafb
and agpgart, per the NVIDIA instructions. Nothing left to try on
this one...

zander 09-01-04 07:24 AM

Re: NVidia, Tyan k8w, xorg and acpi.
These bits of information might help: http://www.tyan.com/support/html/newsletter15.html (last news item).

ScofieldKid 09-01-04 05:15 PM

Re: NVidia, Tyan k8w, xorg and acpi.
Thanks for the pointer Zander.

I'm also going to give the 202b beta bios a try. The ERRATA 109 or 111 fixes from AMD might be doing something here.

Nice to see that they are looking at the problem.

drumz 09-01-04 08:02 PM

Re: NVidia, Tyan k8w, xorg and acpi.
I find it interesting too, however that newsletter is all the way from Feb. Are they done, or are they all still working together?

I've made a bug report and inquired as to how responive Nvidia is to bug reports, etc., only to hear nothing. Yet there are many people reporting the same issues (black screen on X start) with no resolution, no errors, no nothing....

In response to your post, I'd definitely update to the 202 bios. It made a world of difference for me - I can now at least turn ACPI on so I can fully shutdown, but if I try to use any AGP (nvidia built in or kernel) I get a black screen on startx. Instead, if I let it 'fail over' to PCI mode everything works (albeit not as effeciently or for what I paid for). But at least it works and is stable. This in conjunction with the driver version prior to 6111. 6111 made no difference for me for the AGP issue.

A coworker has the same exact setup I do, except the video card is a 5700ultra instead of 5700. Works fine for him. Others with the plain 5700 like me have the same problem - switching to another card with the EXACT SAME xorg config file works perfectly. <sigh>

zander 09-02-04 04:45 AM

Re: NVidia, Tyan k8w, xorg and acpi.
@drumz: have you tried your coworker's card in your system (and/or your card in his system)? Do you have links to reports from other users who're experiencing AGP problems with GeForceFX 5700 cards and the Tyan K8W?

drumz 09-02-04 06:21 AM

Re: NVidia, Tyan k8w, xorg and acpi.
I haven't swapped cards with my co-worker yet. Another co-worker is also building the same system with the same 5700Ultra card. As soon as his comes in we're going to try swapping my card out and see if it works with an Ultra.

If it doesn't happen soon, I may just try the swap with the other co-worker since his machine is up and running already (latest Suse under 32bit OS, not 64bit like I'm running - however I have tried it under 32bit with the same black screen results on a fresh clean install).

There were a few other posts about the 5700, on the Gentoo forums. A quick search on my name will probably pick up the threads. If I remember right, the person had the 5700, then swapped in a 5200 and it worked fine.

It's just a shame that the majority of people saying/agreeing they have the black screen on startx don't post all of their hardware specs so it can be seen if there is some type of common thread.

But the big issue is the fact that there are no errors anywhere to be found. X just goes off and chews up 100% CPU. Turning on debugging info etc. reveals nothing -> comparing the results to when it works fine under PCI mode shows all the same output (excluding the fail over to PCI mode). There has to be someone somewhere that knows the magical commands to get the right info to track this down.

drumz 09-02-04 06:31 AM

Re: NVidia, Tyan k8w, xorg and acpi.
Ok, I can't seem to find the thread.......I've searched these forums and gentoo.......maybe my memory (wetware) is going bad since I've been on this issue for such a long time ;-)

zander 09-02-04 07:05 AM

Re: NVidia, Tyan k8w, xorg and acpi.
Yes, the lack of details in many me-too posts makes it difficult to determine commonalities; at the same time, however, it's understandable that users believe themselves affected by what appears to be a well-known/common problem: a large number of distinct failure cases exhibit identical symptoms (at least on the surface), e.g. "blank screen on X startup", "X spins at 100% CPU time".

ScofieldKid 09-02-04 07:09 AM

Re: NVidia, Tyan k8w, xorg and acpi.
OK. I'm running the Tyan K8W 202b (that is the beta).

On bootup, of course it reset the clock to crap time.
But the weird thing was that disk discovery took a long time.
On my next reboot, things look fairly normal. Seems like the boot process isn't quite as quick as it was. But I did change a few settings so...

Bottom line: no hard lockups when initiating GLX. Tried about 6 times.
I'll post back here if it starts to lockup again.

All times are GMT -5. The time now is 11:56 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.