nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVreg_EnableVia4x and 6106 (http://www.nvnews.net/vbulletin/showthread.php?t=30999)

syncomm 06-30-04 09:16 PM

NVreg_EnableVia4x and 6106
 
I have a Gigabyte 6vxd7 motherboard with the Via Apollo PRO133x chipset. This is a PIII SMP system. I have always used NVreg_EnableVia4x with no issues in the past however with the latest driver I can't get the option to work. :-(

I did the following (which works fine with 5336):

./NVIDIA-Linux-x86-1.0-6106-pkg1.run --extract-only
cd NVIDIA-Linux-x86-1.0-6106-pkg1
[edit os-registry.c and set NVreg_EnableVia4x to 1]
rm usr/src/nv/precompiled/*
./nvidia-installer
[tell it not to download precompiled binaries]

with 6106 I get the following:

cat /proc/driver/nvidia/agp/host-bridge
Host Bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x]
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 2x 1x
Registers: 0x1f000203:0x00000302

and a nice loss of framerate :(

strings /lib/modules/2.4.22-1.2188.nptlsmp/kernel/drivers/video/nvidia.o | grep EnableVia4x
EnableVia4x
parm_NVreg_EnableVia4x=i
EnableVia4x

Please help!

Thanks,

Greg
-

ripperda 07-01-04 12:26 AM

Re: NVreg_EnableVia4x and 6106
 
unfortunately this registry key workaround is broken in the current driver. there is no known way around this. we should have this fixed by the next release.

syncomm 08-14-04 07:57 PM

Re: NVreg_EnableVia4x and 6106
 
I tried again with 6111 and still have the same issue? Is this still broken??


All times are GMT -5. The time now is 01:15 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.