nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Red Hat 8.0 and (Possible) nForce Problems (http://www.nvnews.net/vbulletin/showthread.php?t=3147)

ceb 10-22-02 02:30 PM

Red Hat 8.0 and (Possible) nForce Problems
 
I've installed 8.0 on my 60GB hard drive. First 6GB is for XP, next 10GB is for Linux (~100MB /boot, ~8.8GB /, ~1GB swap), and the rest is NTFS storage.

It won't boot :(

If I try to boot from the hd in Grub, I get this:

Booting 'Red Hat Linux (2.4.18-14)'
root (hd0, 1)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.4.18-14 ro root=LABEL=/ hdd=ide-scsi
[Linux-bzImage, setup=0x1400, size=0x10ea0d]

Error 28: Selected item cannot fit into memory



If I boot off the boot floppy, it starts to load, then seems to hang on "Looking for module dependencies:" (IIRC; I let it sit for about 3 minutes, no hdd activity)

I have an Athlon XP 2000+
512MB RAM
Asus A7N-266C nForce Mainboard
Abit Siluro GeForce4Ti4200/64MB

Any info would be greatly appreciated.

Cheshiremackat 10-23-02 01:24 AM

similar problem unger 7.3
 
Hello... I am a total noob BUT when I tried to install Rh 7.3 with an nforce chipset and GRUB it would not work...same error

I had to use lilo... but it works...

Also I (we) are not alone, others had this problem under RH7.3...see the graphics forum (Rh7.3 success story thread)


-C

ceb 10-24-02 04:49 PM

Thanks for the reply!

I gave up and reinstalled using LiLo, and it booted, but freezes at "Finding module dependencies"

So I gave up on Red Hat, and installed Mandrake 9.0.

Same thing, stops on "Finding module dependencies".

Gonna give up on Linux for the time being I guess, unless anyone thinks a different distro would be different? (isn't Mandrake built off of Red Hat?)

DaMaxx 10-25-02 01:26 AM

I cant even get the nforce drivers to compile using the source rpms. I have tried to install the rpm's with no luck and I have tried the tarball. the tarball went in and now I can see nvnet in my network settings but i cant activate it. The sound is the same It shows its there but I get nothing but an error saying i dont have permission to use it(I am root). any ideas?

Why hasn't nVidia come out with a new version to fix all these issues? RH8 has been out for almost three weeks now. I had emailed them and was told that the new nForce drivers would be out within the first week.

I must say though that the video drivers for my Ti4200 compiled and installed without a hitch. Kudos for that one.

icemanjer 11-02-02 01:22 AM

instead of using GRUB as your book manager, try using just LILO instead. I've heard many many stories about errors just like your's, and all of them got fixed as soon as they switched over to LILO.

ikarus 12-24-02 12:09 PM

Hangs
 
Well, being a n00b to linux entirely.. you may want to take my advice with a grain of salt.

Firstly, I ran into the same problem with grub boot selection, regarding not fitting into memory so I hear it has to do with where the boot-partition is on the hardrive (physiscally). Lilo however works fine.

I've been running my mouse using a usb -> ps2 adapter due to the fact I'm beta testing a couple things which have problems with usb currently. So, recently I decided to switch back to usb.

Poof, system hang on boot when "detecting module dependencies"... unplug the mouse and it cruises by just fine, same as always.

Just figured I'd add an observation, as I don't really want to switch my mouse back to ps2 I'm still stumbling along trying to find a solution.

I'm using the asus a7n266-c

If anyone figures anything out regarding the problem, please let me know.

-ikarus

smoke 01-02-03 09:01 AM

HEY CEB!!!
I also had the same problems ...
but you should not blame nForce for your Boot hassles..

To get R.H8.0 grub work,
Install R.HL8.0, ***with a boot floppy***.
goto gnu's site, download latest grub(3.0 i believe),

boot in to Linux with boot floppy
copy the downloaded rpm to some dir of your machine,

update existing grub

rpm -U grub-whatever_latest_version.rpm

Now, assuming your boot parition lies on the HDD partition
/dev/hdb2,

grub-install /dev/hdb2

reboot, it should work

vladabas 01-08-03 08:07 AM

for DaMaxx:
I think you should install kernel headers.
Install pakage : kernel develop from your RH CD


All times are GMT -5. The time now is 01:58 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.