nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   redhat 8 no audio for the nforce i810 (http://www.nvnews.net/vbulletin/showthread.php?t=3407)

okdokay 10-29-02 07:58 AM

redhat 8 no audio for the nforce i810
 
Hi,
I have redhat 8 installed on a MSI K7N420. I have downloaded all the nvidia src drivers. I installed the video drivers and have my nvidia card working (not the integrated one) I downloaded the nforce unified src drivers made them and then did a make make install. Afterwhich it kuzu found my integrated nic (the integrated sound and usb was found prior to these drivers) However I am not getting any sound. Redhat has
Vendor: nVidia Corporation
Model: nForce Audio
Module: i810_audio
However any program i run that makes sound i get either a sound device not configured or check that another application isn't using it. All generic errors. Any ideas on what I could do or where to check?
Thanks in advance.

Klaus-P 10-29-02 10:02 AM

Check your /etc/modules.conf (or config.modules)

about the line

alias sound-slot-1 i810_audio

then try a "depmode -a" and then
"modprobe i810_audio"

or at first a "insmod i810_audio"

okdokay 10-29-02 11:18 AM

not working but i may be doing it wrong
 
when i add those lines to my modules.conf

alias parport_lowlevel parport_pc
alias usb-controller usb-ohci
alias sound-slot-1 i810_audio
post-install sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias eth0 3c59x
alias char-major-195 NVdriver
alias eth1 nvnet

I get errors on lines i add your suggestions
also when i manually do an insmod i810_audio i get:
[root@localhost jgreenaw]# /sbin/insmod i810_audio
Using /lib/modules/2.4.18-17.8.0/kernel/drivers/sound/i810_audio.o
/lib/modules/2.4.18-17.8.0/kernel/drivers/sound/i810_audio.o: unresolved symbol
ac97_probe_codec_R84601c2b
/lib/modules/2.4.18-17.8.0/kernel/drivers/sound/i810_audio.o: unresolved symbol
ac97_set_adc_rate_R5307368c
/lib/modules/2.4.18-17.8.0/kernel/drivers/sound/i810_audio.o: unresolved symbol
ac97_set_dac_rate_R42924aaa

any ideas?
Thanks in advance.

Klaus-P 10-29-02 12:14 PM

ac97_codec is a mixer module, you need it.

check your gcc compiler version "gcc -v" and that compiler version which
has been used to compile your system kernel and other loadable moduls via a
"cat /proc/version ".

Try also a "/sbin/insmod -f i810_audio" and then start the mixer, if sound is
working, fine. If not, try to download the respective nforce package
rpm with PRE-COMPILED drivers for Redhat 8.0.

okdokay 10-29-02 01:11 PM

the wierd thing
 
i did a:
[root@localhost jgreenaw]# /sbin/depmod -v | grep ac97
user function /lib/modules/2.4.18-17.8.0/kernel/drivers/sound/ac97.o
user function /lib/modules/2.4.18-17.8.0/kernel/drivers/sound/ac97_codec.o
/lib/modules/2.4.18-17.8.0/kernel/drivers/sound/ac97.o
/lib/modules/2.4.18-17.8.0/kernel/drivers/sound/ac97_codec.o

so i have them,
I also did a:
[root@localhost jgreenaw]# gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --host=i386-redhat-linux --with-system-zlib --enable-__cxa_atexit
Thread model: posix
gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)
[root@localhost jgreenaw]# cat /proc/version
Linux version 2.4.18-17.8.0 (bhcompile@porky.devel.redhat.com) (gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #1 Tue Oct 8 11:48:09 EDT 2002

so those are the same.
Additionally what I don't get is that there isn't any errors when redhat installs or configures the device, in fact it doesn't look like there should be anything wrong with it.
(for anyone worrying i tried all plugs, there is power, and the speakers are new)
Is there any service that could grabbing it? i checked esd, i didn't see it running.
Are there any configuration displays that i could provide that would help debug?
thanks in advance.

Klaus-P 10-29-02 02:25 PM

Ohh, this all seems to be really a bit strange.
And the module 'soundcore' (lsmod should show it) is also running?

Well, let's check whether or not
you can hear at least a bit of a cuckoo cry in your headphone or speaker:
I attach you a very small wav.file with a big frequency change in sound.

run "cat /dev/dsp0 > <this file>" and/or
"cat /dev/audio0 > <this file>"

as root and listen. I've named it "test.txt".

Klaus-P 10-29-02 02:26 PM

1 Attachment(s)
Here the attachment

Klaus-P 10-29-02 03:13 PM

run "cat /dev/dsp0 > <this file>" and/or
"cat /dev/audio0 > <this file>"

Oh , sorry, my apologize...

i mean

"cat <this file> > /dev/dsp0" etc,...

okdokay 10-29-02 03:16 PM

will do... in the meantime
 
here is my lsmod listing
Module Size Used by Tainted: P
i810_audio 25224 0 (unused)
ac97_codec 13416 0 [i810_audio]
sr_mod 18168 0 (autoclean)
soundcore 6500 2 (autoclean) [i810_audio]
NVdriver 1149152 10 (autoclean)
autofs 13348 0 (autoclean) (unused)
3c59x 30608 1
iptable_filter 2412 0 (autoclean) (unused)
ip_tables 14840 1 [iptable_filter]
ide-scsi 10512 0
scsi_mod 107240 2 [sr_mod ide-scsi]
ide-cd 33608 0
cdrom 33696 0 [sr_mod ide-cd]
mousedev 5524 2
keybdev 2976 0 (unused)
hid 22244 0 (unused)
input 5920 0 [mousedev keybdev hid]
usb-ohci 21288 0 (unused)
usbcore 77056 1 [hid usb-ohci]
ext3 70400 2
jbd 52212 2 [ext3]

I am at work right now so I am going to try your sound bit in about a half hour. (i am ssh'ing into my machines from work)
Thanks again for your help.
joe

okdokay 10-29-02 03:53 PM

the cat didn't work...
 
but something i did from work did it, and what ever it was i got from you so thanks, when i reboot we'll see if it stays if not i'll just go through this again.
Thanks again.
it might have been the modprobe i810_audio
joe

okdokay 10-29-02 04:10 PM

game
 
i have soldier of fortune and I am not getting any sound now, the driver it is using is alsound, i am not sure what that is but does this conflict with my setting?
thanks
joe

okdokay 10-29-02 04:13 PM

sorry
 
the driver it is using is openAL, i don't know what this is.


All times are GMT -5. The time now is 01:36 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.