nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Dell SB Live! and SB Audigy LS to gain Linux support (http://www.nvnews.net/vbulletin/showthread.php?t=34178)

zero0w 08-07-04 12:32 AM

Dell SB Live! and SB Audigy LS to gain Linux support
 
According to the Creative Open source page:

http://opensource.creative.com/soundcard.html

New driver support on both

1. Dell model of SB Live! (snd-emu10k1x)
2. SB Audigy LS (snd-audigyls)

is coming with ALSA 1.0.6.

You can try the experimental ALSA 1.0.6rc1 now available at the ALSA official page:

http://www.alsa-project.org/

Notice each of them has its own module name.
Do not use 'snd-emu10k1' module with these soundcard models.

After this driver update, the whole range of Creative soundcards can be considered Linux compatible (TM) .

Leech 08-09-04 09:35 PM

Re: Dell SB Live! and SB Audigy LS to gain Linux support
 
This brings up something I've been wondering for a while..... since kernel 2.6.x includes ALSA drivers with it, is there a way to update just the sound drivers in your kernel to a newer version of ALSA? Never tried it (nor really needed to) just curious.

Leech

zero0w 08-09-04 11:59 PM

Re: Dell SB Live! and SB Audigy LS to gain Linux support
 
Upgrade to a newer Kernel version will be the most direct approach.
I believe either Kernel 2.6.8 or 2.6.9 will incorporate those changes.

blueworm 08-10-04 01:52 PM

Re: Dell SB Live! and SB Audigy LS to gain Linux support
 
You can also build the 2.6 kernel without the alsa drivers and then compile alsa drivers as you would a 2.4 kernel.

zero0w 08-11-04 02:25 AM

Re: Dell SB Live! and SB Audigy LS to gain Linux support
 
Yes, compiling ALSA separately should work:

http://alsa.opensrc.org/index.php?page=AlsaBuild2.6


All times are GMT -5. The time now is 03:58 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.