nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Black screen when X starts (http://www.nvnews.net/vbulletin/showthread.php?t=34272)

mhenn 08-08-04 06:36 AM

Black screen when X starts
 
2 Attachment(s)
Hello,

I have a problem using the nvidia drivers (6111). Upon starting x the screen will go black and the system will become unresponsive. CTRL-ALT-DEL and CTRL-ALT-BACKSPACE do nothing, and a hard reset is required.

X works perfectly with the open-source 'nv' driver, but trying to start with driver 'nvidia' always results in this problem.

I installed the 6106 driver, but the problem remains. (I also tried to install 5336, but the kernel module refused to compile against my 2.6.7 kernel.)

I have tried changing the resolution and Option "NvAGP" "0", but that doesn't have any effect.

Some information on my system:

Gentoo system running with a manually compiled vanilla 2.6.7 kernel.
Athlon processor and nForce2 based motherboard (GA-7N400E-L)
Graphics card is a Leadtek A360TDH (GeForce FX5700)
X.org server

I have attached my Xorg.conf file and /var/log/Xorg.0.log at verbosity 5

Any ideas?

Thanks,
Mark.

whig 08-08-04 07:38 PM

Re: Black screen when X starts
 
Is the nvidia-glx package installed? Have you run opengl-update?

mhenn 08-10-04 03:03 AM

Re: Black screen when X starts
 
I have been using the driver from nviida, not the gentoo ebuilds, so no. :) some people seem to think this is a bad idea, but i have yet to have a reason why. The only problem I can see is a minor difficulty when trying to update X through portage.

I have just solved the problem, if anyone is interested, by disabling 4k stacks and recompiling the kernel.

Thanks for the suggestions, in any case.

can|s|_ycan 08-10-04 06:02 AM

Re: Black screen when X starts
 
Ooooo, yeah, that's your problem right there >>> Graphics card is a Leadtek A360TDH (GeForce FX5700)

FX5700 was giving me some major migraines and burnt several weeks of my loser life trying to fix the hard-lock thing...bugs in X or driver dunno...Finally, I just stuck a 5200 card in and issues go by-by. (I stuck the 5700 card in a win box and it works fine over 'there')


All times are GMT -5. The time now is 04:53 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.