nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   glx module is crashing x server (http://www.nvnews.net/vbulletin/showthread.php?t=34677)

abethebrewer 08-13-04 05:41 PM

glx module is crashing x server
 
1 Attachment(s)
Hi,

I am trying to activate the extension as per NVidia's instructions in my XF86Config-4 file, but it seems to cause my x server to crash. My best guess is that the glx module is not compiled for my version of X... where would I find a different version of the glx module?

I have attached a sample XFree86.0.log

LordMorgul 08-18-04 05:49 PM

Re: glx module is crashing x server
 
XFree86 4.3.0 should work. Please attach your current config file.

throughput 09-08-04 01:06 PM

Re: glx module is crashing x server
 
2 Attachment(s)
I am having the same problem with all of the 6xxx drivers on My stock Redhat 9 system at work. I have to use the 6XXX drivers with the new 6800 Ultra card else I would continue to use the 5336 drivers.

(ack)

LordMorgul 09-08-04 06:15 PM

Re: glx module is crashing x server
 
Your monitor setup slightly confuses me.. could you describe what the intention is?

Is the kernel module 'nvidia' loading cleanly? Try loading it manually to be sure, prior to attempting the X start. If you need to, boot to runlevel 3 first, then load the module, and switch to runlevel 5.
modprobe nvidia then telinit 5

It looks to me like the kernel module may be the issue, but if not then perhaps start looking at libraries.
The readme posted describes where the libraries are installed, and how they should be linked to each other. Verify that the libraries in /usr/lib/*GL* are linking as they should.. and not picking up libraries from the XFree86-Mesa-libGL package. On RH9 I regularly just removed that package to avoid conflict. Alternatively, you might try installing using rpm packages from atrpms which relocate the nvidia libs to avoid conflict: http://atrpms.net/dist/rh9/nvidia-graphics/
(to switch to the rpms, you should uninstall the nvidia driver, reinstall / freshen the XFree86-Mesa-libGL package if you have it installed, then install the rpms)

throughput 09-14-04 12:43 PM

Re: glx module is crashing x server
 
I have now have the nvidia-6111 drivers working after updated glibc. The glx drivers load and all appears well. When running a glstudio application I experience a lock-up 98% of the time. This problem is only with the 6800 Ultra card. The GL apps work fine on a MX 440 with 6111 drivers. I am working hard not to downgrade to our previous card ( 5950 ) it worked fine with the 5336 drivers. I will let you know how it goes and also try the atrpm suggestion.

triclone 10-14-04 10:48 PM

Re: glx module is crashing x server
 
It looks like there is a bug in RH 9 that makes the 5200 and up crash. XFree Log:Client 4 or 3 or whatever rejected by local host. I have not found anybody with an answer about that, I meant an answer with the real means of answering. In my opinion, it is a bug that will not be fixed (RH9 support is gone) Mandrake or Knoppix hard disk install should work fine with the driver. If you don't want to try a different distro, you can try the MX200 or MX400 cards, I haven't had any crashes with those.

throughput 10-16-04 09:19 AM

Re: glx module is crashing x server
 
You may have discovered something about the 5200. Last week I had three NVIDIA PCI Quadro 280 cards in a six head configuration. I needed to keep the stock Red Hat 9 install so I did not install the 6111 drivers. I installed the 5336 NVIDIA drivers and XFree would randomly crash. Someone suggested that I downgrade to the NVIDIA 4??? driver and everything worked. We wanted a little more speed so we installed three PCI 5200 cards. The 5200 cards display lots of garbage with the 4??? drivers and the 5336 drivers. Currently we are determining what we will have to do to get the 5200 cards to work.

Also in one of my previos posts to this thread I described my troubles with a 6800 Ultra card. We replaced the PNY 6800 Ultra with a Gainward 6800 Ultra and it works fine.


All times are GMT -5. The time now is 10:22 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.