nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   problems with custom kernel (http://www.nvnews.net/vbulletin/showthread.php?t=35463)

slack---line 08-24-04 01:04 PM

problems with custom kernel

I have a custom kernel and am trying to install latest nVidia drivers (6111) using the automatic installer. I've read the manual and the advanced options and the installer is still having trouble finding the kernel sources, despite what the advanced options state....

--kernel-source-path=[KERNEL SOURCE PATH]
The directory containing the kernel source files that should be
used when compiling the NVIDIA kernel module. When not
specified, the installer will use '/lib/modules/`uname
-r`/build', if that directory exists. Otherwise, it will use

So the options I'm using to run the installer are....

sh NVIDIA-Linux-x86-1.0-6111-pkg1.run --kernel-source-path=/usr/src/linux-2.4.26/ -a

(I've also tried --kernel-source-path=/usr/src/linux/ with the same result, but then thats not surprsing given...

$ ls -l /usr/src/
total 2
lrwxrwxrwx 1 root root 12 Jul 13 20:02 linux -> linux-2.4.26/
drwxr-xr-x 15 573 573 608 Aug 9 16:24 linux-2.4.26/

(There sources do actually exists, its not just an empty folder ;-))

and as a result I end up with the following in /var/log/nvidia-installer.log

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Tue Aug 24 18:47:02 2004

option status:
license pre-accepted : true
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel source path : /usr/src/linux-2.4.26/
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted by command line option.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Using the kernel source path '/usr/src/linux-2.4.26/' as specified by the
'--kernel-source-path' commandline option.
-> Kernel source path: '/usr/src/linux-2.4.26/'
-> Performing cc_version_check with CC="cc".
ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the appropriate nvidia-installer command line option.

Output of uname -r is 2.4.26 so I'm using the correct sources. If its of any relevance I'm using a recenlty updated slackware 10 (used swaret to upgrade from 9.1).

One thought was that it may be a different versions of gcc currently installed than that which was used to compile the kernel, but I can't remember what date I did the upgrade (before or after recompiling the kernel).

Any suggestions or advice would be greatly appreciated.



P.S. - Beyond take the casing off is there anyway of determining what card I have (I lost the details of what I bought ages ago)

slack---line 08-25-04 01:42 PM

Re: problems with custom kernel
can anyone suggest courses of action I might take, I'm pretty sure I've followed the instructions with the t's crossed and i's dotted and am at a loss.

chrisis 08-26-04 06:56 AM

Re: problems with custom kernel
Try sh NVIDIA-Linux-x86_64-1.0-6111-pkg2.run -K
after booting with the custom kernel. Worked for me but I can't explain why.


slack---line 08-26-04 07:38 AM

Re: problems with custom kernel
Hmm, can't think why that might make a difference, whilst I do have several different kernels installed (still ironing out alsa/2.6 problems, but thats not relevant to here), I'm trying to get it working with just one kernel.

The -K option.....

-K, --kernel-module-only
Install a kernel module only, and don't uninstall the exisiting
drive. This is intended to be used to install kernel modules
for additional kernels (in cases where you might boot between
several different kernels). To use this option you must
already have a driver installed, and the version of the
installed drive must match the version of this kernel module.

I'll give it a go, but I'm not holding out much hope.

Thanks for the suggestion though and I shall post with the results when I get home this evening.


All times are GMT -5. The time now is 06:55 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.