nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   no sound with latest nforce drivers (1.0-0283) (http://www.nvnews.net/vbulletin/showthread.php?t=35564)

brblueser 08-25-04 08:49 PM

no sound with latest nforce drivers (1.0-0283)
Hi all,

I have FC2 running here with the latest kernel (2.6.8-1.521custom), and I just installed latest nforce drivers. nvnet is running just fine, but I can't seem to be able to use sound.

Sound card is properly detected:

Aug 25 22:34:25 localhost kernel: Nvsound: Nvidia Audio Init Module, 22:29:39 Au
g 25 2004 version 1.0-0
Aug 25 22:34:25 localhost kernel: Nvsound: NVIDIA nForce2 Controller found at M
em 0xea000000 and IRQ b
Aug 25 22:34:25 localhost kernel: Nvsound: NVIDIA nForce2 Audio found at IO 0xec
00 and 0xe800, IRQ 9
Aug 25 22:34:25 localhost kernel: Nvsound: Aci_device 21f21400 Apu_device 21f218
Aug 25 22:34:25 localhost kernel: Nvsound: DEV MIXER 0 DEV AUDIO 3

However, trying to use mpg123 yields errors:

High Performance MPEG 1.0/2.0/2.5 Audio Player for Layer 1, 2, and 3.
Version 0.59q (2002/03/23). Written and copyrights by Joe Drew.
Uses code from various people. See 'README' for more!

Playing MPEG stream from sweethome.mp3 ...
MPEG 1.0 layer III, 128 kbit/s, 44100 Hz stereo
ALSA lib pcm_dmix.c:868:(snd_pcm_dmix_open) unable to open slave
ALSA snd_pcm_open error: No such device

[1:37] Decoding of sweethome.mp3 finished.

ALSA drivers are indeed being loaded as modules, which seems weird:

# lsmod
Module Size Used by
snd_mixer_oss 14208 0
snd 40804 1 snd_mixer_oss
nvsound 1534956 3

Does this make sense? When it comes to sound, I only have this on my /etc/modprobe.conf:

alias sound-slot-0 nvsound

Should there be anything else?



jacen 08-26-04 12:59 PM

Re: no sound with latest nforce drivers (1.0-0283)
Those are not the alsa modules. If you see, there are OSS modules. OSS is an alternative kind of sound modules.

May be the problem is that you did not select the OSS suport in your custom kernel. I have the same problem in MDK10 with a custom kernel. The module was loaded but I coud play no sound (xmms and mpg123 chrashed). So I installed a newer kernel with OSS suport and now it sounds great!!! (obviously, I had to reinstall the driver).


brblueser 08-28-04 01:03 PM

Re: no sound with latest nforce drivers (1.0-0283)
Hi Jocen,

you're right, they're OSS modules. However, they're not listed anywhere on my /etc/modprobe.conf, which makes me wonder why they're being loaded. I don't know if this is the cause for nvsound not working, but it surely seems strange.

Anyone could share a working copy of /etc/modprobe.conf? (no need to post it all, only the sound-related part) Better yet, if anyone could tell me which modules need to be configured/removed on a 2.6.x kernel compilation so that nvsound can work, I'd be most grateful...



jacen 08-29-04 01:38 PM

Re: no sound with latest nforce drivers (1.0-0283)
Well, all you have to do is what the documentations says, i.e., you have to read de ReleaseNotes.html file :D.

My modprobe.conf file is this:

#Modprobe.conf file
alias net-pf-4 ipx
alias autofs autofs4
alias eth0 3c59x
alias sound-slot-0 nvsound
alias ieee1394-controller ohci1394
alias eth1 nvnet
install usb-interface /sbin/modprobe usb-ohci; /sbin/modprobe ehci-hcd; /bin/true
alias /dev/nvidia* nvidia

#End of modprobe.conf file

As you can see, you have to replace the entries of sound by writing nvsound. Do the same with the net module if you want to compile it.


brblueser 08-29-04 02:53 PM

Re: no sound with latest nforce drivers (1.0-0283)
Hi Jacen,

yeah, I know -- I did read the release notes ;) What I don't get is: I only had "alias sound-slot-0 nvsound", as you had, and nonetheless snd, snd_mixer_oss and other OSS modules were being loaded. So, what I am trying to understand is:

1. is it ok for these OSS modules to get loaded along with nvsound?
2. did I have to do anything special during kernel configuration? (ALSA and OSS support are enabled as modules whenever possible)
3. is there any additional modules configuration I should implement? (I _don't_ have any other sound modules enabled besides nvsound)

Thks again,


pbwest 08-30-04 10:48 AM

Re: no sound with latest nforce drivers (1.0-0283)
Before 1.0-0283, I was getting no sound at all with Fedora 2. After my initial excitement at getting any sound at all with the 0283 driver, I ran into the same problem. The sound drivers don't seem to work with any other sound drivers on the system. E.g.
aplay -l
aplay: device_list:194: no soundcards found...

I noticed the oss modules, so I recompiled the kernel with alsa support disabled and oss enabled. That didn't work either. Is anyone from nV listening? How is the 0283 nvsound driver supposed to iteract with the operating system sound faciities?

The_Cheese 09-01-04 05:23 PM

Re: no sound with latest nforce drivers (1.0-0283)
I'm getting the same problem as you as well. Have tried compiling the kernel with and without alsa support and OSS.

I read somewhere that alsa support can be left enabled in the kernel as long as three oss emulation related options are turned off:
OSS PCM (digital audio) API
OSS Sequencer API

once these have been turned off all the is left to do is enable OSS by compiling in :
Open Sound System (DEPRECATED)
as a module.

Tried this but still no luck, everything seems to have been installed fine. Indeed when I open up xmms to play a mp3 (after installing the correct mp3 rpm :) ) and select the audio output as using the OSS it will tryn and play the mp3 for a few seconds then stops, producing no audio in that short space of time.

However uncommenting the snd-intel8x0 and returning to the old alsa drivers and rebooting the sounds works again for the analogue, but the nvidia drivers no longer seem to function correctly (all options in the information page ofthe nvmixer are blank).

Getting quite annoying now, just need somebode who has got these drivers working to post what exactly they have compiled in there kernel as to oss and alsa support (and potentially if they are modules or built into the kernel). And also what they have in thier modprobe.conf, i.e what have they enabled and disabled.

anyhow sorry for the long post, first one as well so hope i'm not jumping in at the deep end.

as a note I'm running fc2 and the latest kernel; 2.6.8-1.521 with a asus a7n8x-e deluxe mobo

brblueser 09-01-04 05:38 PM

Re: no sound with latest nforce drivers (1.0-0283)
Hi The_Cheese,

you described my situation _precisely_ -- I also experience "mute mp3 playing" with xmms, distro (FC2) and kernel were the same, and we have the exact same mobo (A7N8X-E).

I do believe nvidia should be more clear on their documentation about which kernel modules should be compiled/enabled in order to fully experience nvsound modules...

The_Cheese 09-01-04 05:55 PM

Re: no sound with latest nforce drivers (1.0-0283)
I have done a lot of searching on this subject both on here and on nforcershq. An interesting thread is (http://www.nforcershq.com/forum/viewtopic.php?t=51343) i have followed some of the advice on thier (including the stuff about the kernel that i posted above) but still to no avail. I even searched nvnews and nforcershq with the keywords 1.0-0283 and stored all information in a txt file and printed it out and tried each piece individually but still no luck. Beginning to run out of ideas, there must be some small thing I/we are doing wrond somewhere but I can't see what. :/

(ps: if posting links to other boards is a no no apologies)

prego 09-01-04 06:13 PM

Re: no sound with latest nforce drivers (1.0-0283)

what you describe is right for me, too. Compiled OSS as module and nothing else.

I also tried to use ACPI=off and APIC=off as kerneloptions.
Didn't help!

As I am on Debian, I also tried it with a 2.6.8 Stock Kernel (2.6.8-1-k7). Using this Kernel locks the box up, when modprobing nvsound.
This works on my self-compiled kernel, but i had to do a BIOS update to 1008.

I've also done lots of searching, but all answers point in sentences like:
"Use the i8x0 module... blabla"

But thats not what I want. First is, that my box is hooked up an DolbyDigitalAmplifier and I want to use it. Second, I want the same features as on other OSes, like WinXP, namely use analog and digital output simultaniusly.
I had Digital and Analog output working with the alsa drivers. But I want to have both at the same time. (i.e. Only use the amplifier if i want to have the "big" sound, otherwise use headphones/etc.)

Hope that somebody could give us all a hint.

Current config.
Asus A7N8X-Deluxe (nforce2)
Debian unstable Kernel (selfmade)

so long, greetz p

brblueser 09-01-04 06:16 PM

Re: no sound with latest nforce drivers (1.0-0283)
Nice cross-reference to nforcershq, forgot to check it out there too.

... yeah, it seems this is still sort of beta, lots of problems reported. Better wait for a next version.

The_Cheese 09-01-04 06:24 PM

Re: no sound with latest nforce drivers (1.0-0283)
screaming kid/ But i don't wanna /screaming kid

.. but seriously, i'm not a hardcore linux person, but i do want to use it as an alternative to windows. The major problem for me so far is being able to use the spdif, have never got it to work before and I finally hoped nvidia had created a driver to sort this so I could finally use linux full time. I still hope this is the case, as this driver does seem to work for some people. Just need those people to look at these thread and post some answers !! :POKE:

I have also tried disabling apic, lapic and acpi in ther kernel and the bootloader, neither seemed to help, and they don;t seem to affect me even when they are enabled. Ho hum, guess we just wait for those lucky people who have it working to see this and help us.

All times are GMT -5. The time now is 11:35 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.