nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   screen corruption 1.0-6111 and k8t800 (http://www.nvnews.net/vbulletin/showthread.php?t=35584)

bani 08-26-04 01:48 AM

screen corruption 1.0-6111 and k8t800
 
Geforce 6800 (non ultra, non gt) 128mb
Asus SK8V
Opteron 140
1gb PC2100 reg ecc
ecc+scrub enabled in bios
Redhat 7.3
Kernel 2.6.8.1
XFree86 4.2.1
Everything is running in 32bit mode. Not 64bit mode.

All 3d is fine, no problems or lockups at all with opengl games.

Most 2d is fine too, except when I do something in an xterm/kterm/rxvt which scrolls a window really fast. If there's more than a few seconds of (really high speed) scrolling, the window starts corrupting, and I end up with something like this.

I got this display by doing 'hexdump /dev/urandom' in an xterm.

If I cancel it quickly enough, I can usually recover.

But if it keeps running too long, eventually the whole X server will lock up. All X will freeze, but I can still move the mousepointer around o_O

I'm using NvAGP 1, but it happens even with native linux kernel agp.

$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86 NVIDIA Kernel Module 1.0-6111 Tue Jul 27 07:55:38 PDT 2004
GCC version: gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-113)
$ cat /proc/driver/nvidia/agp/*
Fast Writes: Supported
SBA: Supported
AGP Rates: 8x 4x
Registers: 0xff000e1b:0x1f000302
Host Bridge: PCI device 1106:3188
Fast Writes: Supported
SBA: Supported
AGP Rates: 8x
Registers: 0x1f000a1a:0x00000b02
Status: Disabled
$ cat /proc/driver/nvidia/cards/0
Model: GeForce 6800
IRQ: 16
Video BIOS: 05.40.02.12.01
Card Type: AGP

zander 08-26-04 03:35 AM

Re: screen corruption 1.0-6111 and k8t800
 
Judging from the posted /proc/driver/nvidia/agp/status, AGP is currently disabled. Does the problem reproduce in this configuration, i.e. with NvAGP disabled? A number of users have reported stability problems with amd64 that went away after updating the SBIOS, have you checked for updates?

bani 08-26-04 03:48 AM

Re: screen corruption 1.0-6111 and k8t800
 
Quote:

Originally Posted by zander
Judging from the posted /proc/driver/nvidia/agp/status, AGP is currently disabled. Does the problem reproduce in this configuration, i.e. with NvAGP disabled? A number of users have reported stability problems with amd64 that went away after updating the SBIOS, have you checked for updates?

Quote:

Originally Posted by bani
I'm using NvAGP 1, but it happens even with native linux kernel agp.

according to the status, agp is disabled.

and yes, i've checked for BIOS updates.

bani 08-27-04 04:52 PM

Re: screen corruption 1.0-6111 and k8t800
 
ok i tried

agp disabled (nvagp 0)
nvidia agp (nvagp 1)
kernel agpgart (nvagp 2) (and i confirmed 100% it was enabled and working)

all 3 of them produce the corruption and lockups in 2d.

everything is perfectly fine in 3d.

next thing i will try is the xfree86 "nv" driver. but if that works without corruption then it will point the finger squarely at an nvidia 6111 driver bug.


All times are GMT -5. The time now is 02:04 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.