nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem with 6111 and RedHat 8 2.4.20: unresolved symbol init_mm (and more) (http://www.nvnews.net/vbulletin/showthread.php?t=35663)

Tinker 08-27-04 05:50 AM

Problem with 6111 and RedHat 8 2.4.20: unresolved symbol init_mm (and more)
 
I'm running Redhat 8.0 2.4.20-28.8.

Since 6111 run-file does not have a precompiled kernel interface I have installed the kernel-source for 2.4.20-28.8.

When I run then nVidia installer I get the following in then var/log/nvidia-installer.log:
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.o'. This is most likely
because the kernel module was built using the wrong kernel source files.
Please make sure you have installed the kernel source files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel source
files are installed, you may specify the kernel source path with the
'--kernel-source-path' commandline option.
-> Kernel module load error:
./usr/src/nv/nvidia.o: unresolved symbol init_mm_Rf8067280
./usr/src/nv/nvidia.o: unresolved symbol create_proc_entry_Rd24acb90
./usr/src/nv/nvidia.o: unresolved symbol proc_root_driver_R88757e22
./usr/src/nv/nvidia.o: unresolved symbol mem_map_Rd35a6afd
./usr/src/nv/nvidia.o: unresolved symbol __pollwait_R2b9b890e
./usr/src/nv/nvidia.o: unresolved symbol register_chrdev_R2cc549a7
./usr/src/nv/nvidia.o: unresolved symbol remove_proc_entry_R12a0afd4
./usr/src/nv/nvidia.o: unresolved symbol change_page_attr_R399e0232
./usr/src/nv/nvidia.o: unresolved symbol irq_stat_R255bba3f
./usr/src/nv/nvidia.o: unresolved symbol remap_page_range_R8ebd1531
./usr/src/nv/nvidia.o: unresolved symbol zone_table_R54c82ffb


Anyone who knows what to do to solve this problem?

Thanks

kmare 08-27-04 07:21 PM

Re: Problem with 6111 and RedHat 8 2.4.20: unresolved symbol init_mm (and more)
 
IF you have your kernel sources installed, try giving the parameter kernel-source-path /path/to/your/kernel/sources when running the installer... it might help...

Tinker 08-28-04 09:11 AM

Re: Problem with 6111 and RedHat 8 2.4.20: unresolved symbol init_mm (and more)
 
I have tryed that but the same problem.

Tinker 09-07-04 11:24 AM

Re: Problem with 6111 and RedHat 8 2.4.20: unresolved symbol init_mm (and more)
 
After searching “http://www.linuxquestions.org/” I fund a solution. The problem was that installing the kernel source was not enought. I had to do this as well:
1. cd /usr/src/linux-<kernel_you_are_using>
2. make mrproper
3. cp /boot/config-<kernel_you_are_using> .config
4. make oldconfig
5. make dep
6. edit include/linux/version.h and remove “custom” from
#define UTS_RELEASE "2.4.20-28.8custom"

After this nVidias installer worked fine!


All times are GMT -5. The time now is 09:27 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.