nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Debian 3.0 / NVidia 2960 (http://www.nvnews.net/vbulletin/showthread.php?t=360)

rakerzZz 08-03-02 03:49 PM

Debian 3.0 / NVidia 2960
 
I've recently installed Debian 3.0 and I'm now trying ot get the 3d Accellerated NVidia drivers to install. I downloaded the tarballs, extracted them, and when I try to "make" inside the NVIDIA_kernel folder, I get a "nv.c:22: linux/modversions.h: No such file or directory" message. Before when I got this, I tried installing the kernel sources. This fixed this error, but brought up another. (I reinstalled last night.) I'm wondering if there is a way to get this to work hopefully without recompiling my kernel. Thanks in advance for help.

Thunderbird 08-03-02 03:54 PM

Find out what kernel version you are using, using: uname -r.

Then download the kernel headers: apt-get install kernel-headers-(kernel version)

Then in the end make a symlink /usr/src/linux pointing to /usr/src/kernel-headers-(kernel-version) after that compile the module and it will work fine.

rakerzZz 08-03-02 05:29 PM

Im using kernel 2.4.18 I installed the kernel source. Is the kernel source different then the kernel headers?

vforge37 08-03-02 05:59 PM

Yep, big difference
 
The kernel source package is the linux kernel sources for your distribution, AND the precompiled binaries for your kernel


What this does is that when you go to compile a linux hardware driver, it uses those binaries to correctly build your driver for your specific kernel.

The headers on the other hand are just a collection of *.h files that are also needed to compile drivers. Those header files give information to the compiler when compiling your binaries.

So yeah, make sure you have both installed on your system, and that the package version of both the kernel sources and headers are the same as your kernel version.

rakerzZz 08-03-02 08:47 PM

I'm getting the same error now as I did last time (after I recompiled my kernel last time). I installed the headers, and it found the file it was missing before. But now I get:

----------

depmod: *** Unresolved symbols in /lib/modules/2.2.18-bf2.4/kernel/drivers/video/NVdriver

make: *** [package-install] Error 1

-----------

:(

vforge37 08-04-02 12:51 AM

Quote:

Originally posted by rakerzZz
depmod: *** Unresolved symbols in /lib/modules/2.2.18-bf2.4/kernel/drivers/video/NVdriver


Wooooo... hold on a second... you seem to have another kernel (2.2.18-bf2.4) running. Are you sure you're running 2.4.18 here? check to see in lilo.conf if you're booting into a 2.4.18 image, and not an old 2.2.18 kernel.

The Nvidia drivers are built using the 2.4.18 headers and sources, but then you're trying to install them to the running kernel, which is a much older series.

I think that what's happening is that you are running a 2.2.18 kernel, but you've got the kernel-sources and headers for a 2.4.x kernel, so it's not building properly.

Check out your lilo.conf file, and post it if necessary, to find out which kernel you're running!

- Fred

rakerzZz 08-04-02 01:33 AM

er, no... sorry, I made a typo.

I'm positive I'm running 2.4.18 (the bf version)

rakerzZz 08-04-02 02:40 AM

Ok, I finally got it! Thank you all for trying to help! :)

vforge37 08-04-02 10:18 PM

Just out of curiosity...
 
Could you let us all know how you fixed it... it could help any one else searching for answers on this forum :).

Thanks and Good Luck,

Fred Hernandez

rakerzZz 08-08-02 12:00 AM

I installed the kernel headers for my kernel (apt-get install kernel-headers-2.4.18-bf2.4) and then made a symlink to them in /usr/src (ln -s /usr/src/kernel-headers-2.4.18-bf2.4 /usr/src/linux)


All times are GMT -5. The time now is 05:10 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.