nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   works under root but not under normal users (http://www.nvnews.net/vbulletin/showthread.php?t=36271)

wazawaza 09-05-04 08:45 PM

works under root but not under normal users
 
hi

i've installed nvidia package drivers... it works correctly... but under root only

when i want to log under other user i've a black screen and it fastly return to the loging window...

i can imagine it's a question of rights... but on which file?

i would like to ask here what to do to have 3d hardware acceleration under my linux under a single user session????

many thanx to all helpers...

DrGamut 09-05-04 10:51 PM

Re: works under root but not under normal users
 
If it crashes it must leave error messages in the console, if you could paste them it would be of help.

wazawaza 09-06-04 02:13 AM

Re: works under root but not under normal users
 
i don't enter at all when trying to connect under a normal user... so i don't have any message... really anything i can see... maybe there is a log somewhere... but i don't know where...

comag 09-06-04 10:11 AM

Re: works under root but not under normal users
 
cat /var/log/Xorg.0.log
or
tail /var/log/messages

wazawaza 09-06-04 12:00 PM

Re: works under root but not under normal users
 
i don't have a Xorg.0.log on my system, only a XFree86.0.log... but very long, i think too long to paste it here... i've had a glance at that, and i didn't see any error... which section approximatively do you want me to show you?

here's the result of tail /var/log/messages:

Sep 6 18:55:00 waza CROND[23849]: (root) CMD ( /usr/share/msec/promisc_check.sh)
Sep 6 18:56:00 waza CROND[23872]: (root) CMD ( /usr/share/msec/promisc_check.sh)
Sep 6 18:57:00 waza CROND[23910]: (root) CMD ( /usr/share/msec/promisc_check.sh)
Sep 6 18:58:00 waza CROND[23938]: (root) CMD ( /usr/share/msec/promisc_check.sh)
Sep 6 18:59:00 waza CROND[23987]: (root) CMD ( /usr/share/msec/promisc_check.sh)
Sep 6 19:00:00 waza CROND[24083]: (root) CMD ( /usr/share/msec/promisc_check.sh)
Sep 6 19:01:00 waza CROND[24115]: (root) CMD (nice -n 19 run-parts /etc/cron.hourly)
Sep 6 19:01:00 waza CROND[24117]: (root) CMD ( /usr/share/msec/promisc_check.sh)
Sep 6 19:02:00 waza CROND[24145]: (root) CMD ( /usr/share/msec/promisc_check.sh)
Sep 6 19:03:00 waza CROND[24192]: (root) CMD ( /usr/share/msec/promisc_check.sh)


thanx

LordMorgul 09-06-04 03:57 PM

Re: works under root but not under normal users
 
Under the post entry box there is 'Additional Options' where you can attach your log, rather than post the contents (that allows users to read it only when they need).

Often this problem is caused by permissions being incorrect on the files /dev/nvidia*, so check them.
ls -al /dev/nvidia*

Your user should own them and have read/write permission if PAM is managing the file perms for those devices (as soon as you log in they should be set this way), if it is not or the files only have root access change them and see if that fixes the problem. Ideally this is not how perms should be managed.. but it might make it work for you.

chmod o+rw /dev/nvidia*

pam is black magic, if its broken and managing permissions incorrectly I probably can't help fix it right

wazawaza 09-06-04 06:33 PM

Re: works under root but not under normal users
 
ok i've changed the permissions as you said, but it still not works... sic
dp you want i post my config files?


All times are GMT -5. The time now is 09:17 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.