nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   system lockups w/ nforce&nvidia graphics (http://www.nvnews.net/vbulletin/showthread.php?t=36530)

cyco 09-09-04 03:56 PM

system lockups w/ nforce&nvidia graphics
Hi everyone,

I've problems running Fedora Core 2 with these components:
- Abit NF7 mainboard w/ nforce2 chipset
- Terratec graphic card w/ geforce4 ti 4200 chipset

formerly, I had an asus a7a-266e board and kernel 2.4.22-1.2188.nptl running, worked fine with nvidia drivers (up to 1.0-6106), but I replaced the asus board with the abit. That's where the trouble began.

First of all, the system freezed (booting the good old 2.4.22) when the usb-ohci module was loaded (reproducible). Next freeze was while loading the fresh-compiled nvnet module (latest version from nvidia.com), which was reproducible, too.

So I switched to a 2.6 kernel: 2.6.8-1.521 (precompiled fedora kernel). Now the usb module runs pretty fine, nvnet and nvsound modules, too.

But now I get system lockups when starting X (x.org 6.7.0-2). I got the rescent nvidia driver (1.0-6111) and I even tried linuxant.com's 2.6.8-1.521.stk16 kernel, nothing helps: screen gets blank, may show weird dots and lines, system freezes.
One time I saw a kernel panic in gdm-binary flickering over the screen, but "normally" the system locks up so I cannot even access the kernel via sysrq.

Anyone got a clue on this?

Kind regards,


Thoreau 09-09-04 05:50 PM

Re: system lockups w/ nforce&nvidia graphics
I have the same issue with a different configuration.

Asus A7N8X-X with Asus V9950(5900) Geforce FX. The motherboard also has an nforce 2 chipset. Running Suse 9.1 with kernel 2.6.8. It does load up X fine since I removed AGPGART and the Riva Framebuffer Module from the kernel, but in 3D it freezes after about 30 minutes. It's a hard kernel lock where everything goes dark. No network, no keyboard, no ctrl-alt-F1.. nothing. If I wasn't running reiserfs, I'd be totally screwed.

I don't know what's going on, but the 6106 drivers- which is the same as 6111 when you extract it, are just smoking my system left and right. i really don't know what to do any more. I've tried all the tricks, and nothing is working. It just doesn't like the kernel. :lame:

cyco 09-09-04 06:02 PM

Re: system lockups w/ nforce&nvidia graphics
I think I got the solution.. seems to be an agp issue.
I added a line Option "NvAGP" "1" to my xorg.conf, now I can use the accelerated driver :)

#> glxgears
16186 frames in 5.0 seconds = 3237.200 FPS
16198 frames in 5.0 seconds = 3239.600 FPS
16192 frames in 5.0 seconds = 3238.400 FPS

Thoreau 09-09-04 10:17 PM

Re: system lockups w/ nforce&nvidia graphics
I've done that. The driver is loading properly. I removed all the other drivers in the kernel so it has no choice in fact. The problem is freezing in 3D when using it.

I'm going to move back to 5336 for the time being. Maybe that will help.

cyco 09-10-04 10:59 AM

Re: system lockups w/ nforce&nvidia graphics
Hum.. well.. still got a problem.

The performance is poor. very poor. glxgears shows 3237 fps but running torcs (the open racing car simulator) I get about 5 or 10 fps - it seems the whole job is done by cpu, not by my geforce4.
Formerly, I had an Athlon XP 2000+ on an ASUS A7A266-E (as described in my first post), using kernel 2.4 and nvidia-1.0-6106, torcs was running fine, cars moved very smoothly, framerate about 90 fps or even more. Now, with nvidia-1.0-6111, kernel 2.6, Athlon XP-M 2500+ on an Abit NF7 (v2.0), torcs got unplayable.

Any clues?

edit: I just looked around and found the following:

#> cat /proc/driver/nvidia/agp/status
Status:          Disabled

AGP initialization failed, please check the ouput
of the 'dmesg' command and/or your system log file
for additional information on this problem.
#> dmesg
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected NVIDIA nForce2 chipset
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: AGP aperture is 64M @ 0xe0000000
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module  1.0-6111  Tue Jul 27
07:55:38 PDT 2004
NVRM: not using NVAGP, AGPGART is loaded!!
NVRM: not using NVAGP, AGPGART is loaded!!

Gee, that's strange. This board has an nvidia nforce2 chipset, it should be supported, or am I wrong?

cyco 09-10-04 05:08 PM

Re: system lockups w/ nforce&nvidia graphics [solved]
Okay, problem solved. I recompiled the kernel and removed agpgart. On next boot, nvidia agp was used and now I have about 110 fps in torcs, running in a 1024x768 window w/ full details.

cyco 09-11-04 09:36 AM

Re: system lockups w/ nforce&nvidia graphics
Now there's another problem.
Everything works fine (and performance is pretty good) until I exit my desktop environment. I'm using gdm, so when I exit kde, X is being restarted. This is the point where the system freezes - shutting down and starting X kills my system.
Anyone got an idea on this?

All times are GMT -5. The time now is 11:05 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.