nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Module does not load on Boot (http://www.nvnews.net/vbulletin/showthread.php?t=36634)

Pirf2 09-11-04 06:04 PM

Module does not load on Boot
 
I did the mistake to update my Mandrake from 10.0 to 10.1(rc1) from CD. After some bigger problems, I got to reinstall my Nvidia-driver. Module compiled correctly, no errors.
But on system-boot the nvidia-module is not loaded (lsmod), and X does not start. I can get it up easily by "modprobe nvidia", "init 3" + "init 5" back again.
I tried some things with modules.conf and so on, but I didn't get it loaded on boot-time. If I could, I think it should work?
On the other hand, does it have to be loaded by module loader anyway? Should not the X system get its modules by itself? But my XConfig is unchanged since before upgrade, with the proper 'Driver "nvidia"' line, and the other things.

Thanks,
Pirf2

whig 09-11-04 06:43 PM

Re: Module does not load on Boot
 
Put nvidia in the text file /etc/modprobe.preload (2.6 kernel)

Pirf2 09-12-04 10:24 AM

Re: Module does not load on Boot
 
Yes, it works. Now the X-Server is started correctly on boot. The only thing that still doesn't work (but of course thats nothing todo with the graphics driver), is the autologon. The setting ist still set to autologon of my default user after kde start, as it worked well before system update, but now it doesn't work anymore. It also didn't with the manual-modprobe+change runtime-level, but there I don't know if it ever did then.

But for now I can live with that. Thanks.
Pirf2


All times are GMT -5. The time now is 12:31 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.