nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Hardware OpenGL doesn't work (http://www.nvnews.net/vbulletin/showthread.php?t=36667)

crppryl 09-12-04 06:12 AM

Hardware OpenGL doesn't work
 
I've been trying for a while to get OpenGL to work correctly.

First, the reason I believe that hardware rendering is not working:

When I run glxgears I get ~300 fps in a 300x300 window, which drops to <20 at 1600x1200. Also, glxgears eats 99% CPU. The machine is quite old: 1.3GHz T-bird with Geforce 2 MX, but I believe performance should be better than this.

I recently installed driver version 6111, and I have checked that the library files are nvidia's:

/usr/lib/libGL.*
/usr/lib/libGLcore.*
/usr/X11R6/lib/modules/extensions/libglx.*

Old versions of these files are not present anywhere.

/etc/X11/XF86Config-4 contains:

Section "Module"
Load "dbe"
Load "glx"
Load "bitmap"
Load "freetype"
Load "speedo"
Load "type1"
EndSection

Section "Device"
Identifier "Geforce2 MX"
Driver "nvidia"
Option "NvAgp" "2"
EndSection

I have tried NvAgp both 1 and 2.

glxinfo shows:

[...]
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
[...]
client glx vendor string: NVIDIA Corporation
[...]
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce2 MX/AGP/3DNOW!
OpenGL version string: 1.5.1 NVIDIA 61.11

The X log file shows:

(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"

and

(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"

The only lines I believe could be problematic are these:

(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture

$ cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

The card doesn't have support for SBA. Fast writes is enabled in BIOS, but I believe I have to tell the kernel driver to use it. I don't think it's a big deal, though.

I'm thankful for any help.

energyman76b 09-12-04 04:47 PM

Re: Hardware OpenGL doesn't work
 
Hi,

glxgears is more a cpu than a gpu benchmark.

you should check 'glxinfo'
If you see something like this:
glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:

everything should be fine.


All times are GMT -5. The time now is 05:23 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.