nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Mandrake 10 (2.6.3-16 kernel), 6111 and GForce4 (http://www.nvnews.net/vbulletin/showthread.php?t=36878)

von_klatka 09-16-04 03:32 AM

Mandrake 10 (2.6.3-16 kernel), 6111 and GForce4
 
:ORDER:

For all newbies like me here is a simple method for installing the new 6111 drivers (I have Mandrake 10.0 Community, kernel 2.6.3-16 (with source installed) and a GForce4 MX:

Step 0. you DO NOT need to change the nv.c file, patch things or download mysterious kernel builds.

Step 1. start Linux console mode (initlevel 3, cf inittab)

Step 2. run the 6111 package with the option --add-this-kernel:

[./NVIDIA-Linux-x86-2.0-6111-pkg1.run --add-this-kernel]

wich creates (after long stressful minutes) a "custom" package

Step 3. run the custom package with NO options (just run the package):

./NVIDIA-Linux-x86-2.0-6111-pkg1-custom.run

Step 5. Edit your XF86Config-4 file according to a) the README file (like Driver "nvidia" and Load "glx"... since I am a newbie I don't really know what all that stuff means but it looks important and b) your needs (like Twinview and Tv-out).

Step 6. (vi-edit your inittab to initlevel 5 if you like it that way) and reboot (I don't know if it's necessary but I did it anyway)

Step 7. DONE!!!! You can now watch your dvds on your tv with your new driver!!!

Hope it works for all of you non-expert Linux users.

Note: since I was having the "rivafb problem" I NO-ed the rivafb modules from the kernel and did a "make all". I don't actually know if leaving the rivafb modules "on" is important or not.

QOAC 09-16-04 07:23 AM

Re: Mandrake 10 (2.6.3-16 kernel), 6111 and GForce4
 
This doesnt work with the 2.6.8.1-10mdk kernel the only way I have been able to successfully get drivers installed with this kernel has been to modify the nv.c file.
Trying the --add-this-kernel option fails, dont know why this is.
And I had to revert to the 5336 drivers as making the modofications to the 6111 drivers didnt resolve the compile issue.

zander 09-16-04 08:17 AM

Re: Mandrake 10 (2.6.3-16 kernel), 6111 and GForce4
 
Note that there's two distinct problems (that aren't strictly specific to Mandrake): a) the 1.0-6111 installer incompatibility with certain Mandrake kernels and b) source level incompatibilities introduced with recent Linux 2.6 kernels; the former can be worked around with --add-this-kernel, the latter requires modifications to the driver's glue code (i.e. replacing PM_SAVE_STATE with PM_SUSPEND_MEM (and PM_RESUME with PM_SUSPEND_ON)).


All times are GMT -5. The time now is 06:03 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.