nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Rh7.3 & Nforce (http://www.nvnews.net/vbulletin/showthread.php?t=369)

k0fcc 08-03-02 08:52 PM

Rh7.3 & Nforce
 
Howdy!

I seem to have a small problem with the i820 and the nvaudio driver. It doesn't work in RH7.3. I suspect the PCI values are wrong. When I use sndconfig, it find the card but doesn't find a driver. I get no errors during startup (I used the nforce tar (make, make install)) except "can't open /dev/mixer". It looks like the pci value may not be right in the patched i820 module. modules.conf is correclty configured. Anyone have any ideas? I tried substituting the RH7.3 version of the i820 c code but the module has changed so much that I wasn't sure if I should try to manually key in the patches. I probably still won't work.

Anyone else had this problem?

Joey
linux@stan4d.net

etr 08-04-02 03:11 AM

Questions
 
As it happens, I finally upgarded to an Abit NV7-133R a couple of weeks ago, and got the Linux drivers installed under RH7.3this weekend. At this point, I am up and running with the nVidia drivers.

Have you installed the sound module?

When you have completed the "make install", you can manually load the module using "modprobe nvaudio". Once you do this, try to play some a sound file or .mp3.

You proabably can and should ignore the error concerning /dev/mixer. If my memory servers me, this is a MIDI device. Though I haven't had a chance to check yet, I would bet that the nForce does not yet support MIDI under linux. If this is the case, they are not much different than anyone else; last time I check, the Creative cards didn't either. (Really, neither card has hardware support for MIDI; the windows drivers for both include a software synthesizer.)

There are more things to look at later, but this is a good start.

(NOTE: The "make modules_install" for the kernel clears out the prior set of modules, so you need to restore the nVidia models each time you refresh the modules included with the kernel.)

Thunderbird 08-04-02 08:52 AM

I don't have an nforce board myself but for sound you can use the default i810 drivers included with rh 7.3. Months ago the nvidia pci ids were added to the i810 drivers so the drivers work on nvidia stuff too. RH sets up the drivers itself (I know others without problems). Try to use sndconfig (if installed on rh).

I don't think the problem you have is related to the nvidia audio driver itself. I think you don't have permissions to access /dev/mixer. Try a mixer tool as a different user (root) and see if it works for that user. If it works for root you need to change the permissions on /dev/mixer. (I think rh has a tool for it ..., likely there's a group mixer to which you don't belong)

k0fcc 08-04-02 12:30 PM

Hi!

Yeah, I've had and tried both of those suggestions myself. sndconfig says that the i810 isn't the correct card even when I tell it not to probe.

I've also changed the permissions on the mixer, using root, to 777 and still it doesn't work. I have yet to get sound. :-( I happen to have the spif add-in card. I wonder if that could be contributing to the problem.

Interestingly enough, I haven't tried to use sndconfig with a fresh install. I get no errors so I'm assuming the normal install process probes for a sound card and installs it. This tells me that it can't find a recognized card and therefore doesn't install the drivers.

Bummer...

A most likely unrelated problem: eth0 won't receive data using dhcp (even though my entire command center, minus my print server, uses DHCP), it will only work when I statically assign an IP. Hmpf.

Thanks for all your thoughts...

Joey

etr 08-04-02 11:16 PM

Well, RedHat does not seem to load the sound module at boot time unless it needs a permanent DMA buffer, by my reading of /etc/rc.sysinit on my system. In short, unless you set this permanent DMA option in /etc/modules.conf (and it does NOT seem to be the default), you may need to load the sound module manually using modprobe ("modprobe nvaudio").

Before testing the sound, you may also consider checking to make sure that the module is loaded using "/sbin/lsmod". If you don't see nvaudio in the resulting list, the module is not loaded. If the module is not loaded, it won't be possible to open device files like /dev/mixer for it.

You might also consider checking if esound is running using "ps -ef | grep esd". I've not used sndconfig, but esd may have some of the sound device files open when you run sndconfig. I doubt that esd is locking /dev/mixer, but this might also be worth checking.

The only way sndconfig would be locked out would be if (1) sndconfig did not try to access the audio hardware through esd if it could not do so itself (likely), esd had /dev/mixer open (I doubt this), and the nvaudio module does not support more than one open (likely). Still, it is one more variable you could check.

mlauritsen 08-07-02 06:54 AM

A quick data point:

I've got an Asus A7N266-VM, and in my case the audio seems to have been detected using the standard drivers as well.

I have the same problem with DHCP not working as mentioned previously in the thread, so any suggestions before I start hacking will be much appreciated :)

Regards,

k0fcc 08-07-02 11:27 AM

SOLVED!
 
After trying many permutations of the official install instructions and the instructions listed here, I was able to get everything working on my MSI Nforce board.

I'll provide the steps for reference if anyone else happens to have this problem.

A few findings: [list=1][*]INSMOD will not load the nvaudio driver, I had to use MODPROBE. This was due to a licensing error in nvaudio[*]NVAUDIO is not loaded at boot time as you would expect it to be[*]Installing the 2.4.18-5 kernel via up2date BREAKS DHCP using NVNET[*]NVMASTER does NOT work (corrupt or something)[/list=1]

So, here is what I did, in order, to get my system working:
  • Install RH7.3
  • Install the Nvidia Nforce SOURCE RPM (it creates tar files in /usr/src/redhat/SOURCES/ )
  • unzip and untar NVNET *** ONLY ***
  • Make sure you have the kernel source installed in /usr/src, if not, load it from RH7.3 CD 2
  • go to /usr/src/redhat/SOURCES/nforce/nvnet and issue 'make' and 'make install' (you shouldn't get any errors at this point)
  • reboot
  • At this point, eth0 (aka nvnet) will come up normally using DHCP. We'll tinker with non-DHCP settings under the new kernel.
  • Run rhn_register and then up2date. Suck down the new kernel & kernel source. If you don't use XIMIAN, suck down the rest as well.
  • reboot
  • eth0 will error during boot....ignore it
  • go back to the SOURCES directory and unzip and untar NVAUDIO
  • go into nvnet, make and install
  • go into nvaudio, make and install
  • run /usr/sbin/redhat-network-config, select eth0/nvnet and configure for a static ip (you can choose to reboot to see if it works as DHCP first, if not, just configure it for static here), then activate it.
  • go into /etc/rc.d/rc.local and add "modprobe nvaudio" as the last line. This loads the nvaudio driver, with a fleeting error message, at boot time. (it's actually the last thing loaded during startup)
  • reboot (optional)
  • Install Ximian if so inclined and update per normal
  • Turn on sound in Gnome (probably is alread on in KDE)

Hope this helps for folks...

Joey

tandlj 08-07-02 10:24 PM

Huuugh sigh of relief and max gratitude for what looks like THE solution for all my recent sleepless nights (caused by the combination of RH7.3 and my mobo MSI K7N420Pro with nForce420D on AMD XP1700) ...

- followed immediately by hightened anxiety: will I be able to do it ...

... 'cause I am such an ignorant newie still - but don't want to give up on Linux (yet).

k0fcc/Joey:
Can I email /ICQ you privately with questions that I may have when I try to do it (eg about which nVidia file exactly, or which commands to use to achieve what you summarise)?

Joseph
<tandlj@pcug.org.au>
ICQ 21316951
GMT+10 (Australian Eastern Standard Time)

k0fcc 08-07-02 11:00 PM

sure!
 
Sure! I'll email you with my details

pps111 08-11-02 05:29 PM

Hi,

Thankx man,

I got sound working on my asus a7n266vm

But the sound is too jerky & stressy !!!!

Any possible solutions ???

Bye.

matlogik 08-11-02 07:10 PM

Re: Questions
 
Hello

I need to install the NV7-133R and i don't know how i can use the RAID hardware on it. I know i can enable the ethernet and the sound device with the RPM on the nvidia.com site but how can i use the RAID 1 mode? I can use RedHat 7.2 or 7.3.

Thank you for your help

Mat

Quote:

Originally posted by etr
As it happens, I finally upgarded to an Abit NV7-133R a couple of weeks ago, and got the Linux drivers installed under RH7.3this weekend. At this point, I am up and running with the nVidia drivers.




All times are GMT -5. The time now is 05:25 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.