nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   6111 not working in Mandrake 10 (http://www.nvnews.net/vbulletin/showthread.php?t=36929)

ashgromnies 09-16-04 11:01 PM

6111 not working in Mandrake 10
 
I compiled with the "--add-this-kernel" option and ran the custom run file... tried other things, nothing seems to work :(
It worked a couple days ago, but then I reformatted and installed THE SAME FREAKIN' VERSION OF MANDRAKE with the SAME NVIDIA DRIVERS but it won't work now!
Code:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sun Aug 26 22:31:19 2001

option status:
  license pre-accepted    : falsehttp://www.mozilla.org/products/firefox/
  update                  : false
  force update            : false
  expert                  : false
  uninstall              : false
  driver info            : false
  no precompiled interface: false
  no ncurses color        : false
  query latest driver ver : false
  OpenGL header files    : false
  no questions            : false
  silent                  : false
  X install prefix        : /usr/X11R6
  OpenGL install prefix  : /usr
  Installer install prefix: /usr
  kernel source path      : (not specified)
  kernel install path    : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /root/tmp
  ftp site                : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> A precompiled kernel interface for kernel 'Mandrake Linux 10.0 kernel
  2.6.3-7mdk i586' has been found here:
  ./usr/src/nv/precompiled/nv-linux.o-1.0-6111.mdk10.0_2.6.3-7mdk.
  executing: 'cd ./usr/src/nv; /usr/bin/ld -d -r -o nvidia.ko precompiled-nv-l
  inux.o nv-kernel.o'...
-> Kernel module linked successfully.
ERROR: Unable to load the kernel module 'nvidia.ko'.  This is most likely
      because the kernel module was built using the wrong kernel source files.
      Please make sure you have installed the kernel source files for your
      kernel; on Red Hat Linux systems, for example, be sure you have the
      'kernel-source' rpm installed.  If you know the correct kernel source
      files are installed, you may specify the kernel source path with the
      '--kernel-source-path' commandline option.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
  -1 No such device
ERROR: Installation has failed.  Please see the file
      '/var/log/nvidia-installer.log' for details.  You may find suggestions
      on fixing installation problems in the README available on the Linux
      driver download page at www.nvidia.com.


Nuke_Bloodaxe 09-16-04 11:13 PM

Re: 6111 not working in Mandrake 10
 
Something tells me you might need to install the Kernel source, as it is not typically insatlled by default in a new Mandrake install.

Regards,
Nuke Bloodaxe.

zander 09-17-04 03:39 AM

Re: 6111 not working in Mandrake 10
 
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko': -1 No such device

Please read log/error messages more carefully, the NVIDIA kernel module clearly linked, but failed to load. The output of dmesg (following the failed installation) might provide additional information.

ashgromnies 09-17-04 07:47 PM

Re: 6111 not working in Mandrake 10
 
nvidia: module license 'NVIDIA' taints kernel. nvidia: probe of 0000:01:00.0 failed with error -1

:(

Kapo 09-17-04 08:48 PM

Re: 6111 not working in Mandrake 10
 
Did u try with NVIDIA..........pkg1-custom.run or NVIDIA..........pkg1.run --add-this-kernel ?!? You have to run --add-this-kernel option again.

momenman 09-18-04 03:29 AM

Re: 6111 not working in Mandrake 10
 
To run the nvidia package make sure that you have the "kernel-source-stripped" package - not the "kernel-source" package om Mandrake 10.0.

I had the same problem. The driver still locks up X on fx5700 - mouse moves though!!

zander 09-18-04 03:42 AM

Re: 6111 not working in Mandrake 10
 
The problem here clearly isn't related to missing kernel sources, the kernel module fails to load because the NVIDIA kernel module's probe routine fails. Please make sure that the rivafb module isn't loaded, that Plug & Play OS is disabled in the system BIOS and Assign IRQ to VGA enabled. Please post the output of lspci -vv -n -s 01:00.0.

mrkaczor 09-18-04 05:22 AM

Re: 6111 not working in Mandrake 10
 
I had the same problem and "--add-this-kernel" helped ... realy


All times are GMT -5. The time now is 09:04 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.