nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Fatal Server Error: caught signal 8 (http://www.nvnews.net/vbulletin/showthread.php?t=37550)

SpikeyKlitske 09-27-04 07:21 AM

Fatal Server Error: caught signal 8
 
1 Attachment(s)
Hi, can someone please help me cuz im stuck.

I am trying to install mandrake 10.1 community on the following setup:
AMD64 +3200 cpu
Asus K8V mobo
1GB Kingston PC3200
Asus FX 5900 128MB
WD sATA 160 GB
LiLo with Windows XP pro in dual boot

I created new partitions for this as follows:
2GB Linux swap
10GB JSF,Ext3 for /
20GB JSF,Ext3 for /usr

The installation seems to run smooth, automatically updated (default) files and rebooted. Then X wont start and produces an error as follows:

(WW) NV(0): failed to set write-combining range (0xe8000000, 0x8000000)
... some additional info as to explaining what WW or EE is
Fatal Server Error: caught signal 8 server aborting
... again some additional info as to check website
XIO: fatal IO error 104 (connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining
...

I checked the http://wiki.X.org website; no useful info there
I tried different display options and modes, and pushed test button, problem remains the same, fatal server error...

I tried to download latest drivers from nVidia but the links dont work anymore ie the files have a html extension and instead of downloading its simply displaying the code!?

So all in all im stuck and cant go anyfurther. I am not that proficient with the console commands so i dont know how to view the error logs either.

Help....? please? :ORDER:

SpikeyKlitske 09-28-04 06:39 AM

Re: Fatal Server Error: caught signal 8
 
Thanks to the help of a member at the mandrakeusers.org forum i managed to overcome this error, ie get the GUI back working. Im still working on getting the nvidia drivers installed. I will post here the progress made.

In priciple this is what i had to do: changing "nv" to "vesa" in the XF86Config file to bring back the gui. For those that might have the same problem here is what i did. Since i am not familiar in changing the config file from the command prompt i had to do it in winblows:
1. From the linux command prompt i typed : cp /etc/X11/XF86Config /mnt/floppy (lol yes i copied it to an old fashioned floppy since i didnt know how else to access the linux directory from windows)
2. Rebooted to windows; opend the file with write; searched and replaced the "nv" into "vesa" (other items as load "glx" already there or removed); saved the file back on the floppy
3. Rebooted to linux; logged in as user; changed to root using the su command and gave the password; on the prompt i typed: cp /mnt/floppy/XF86Config /etc/X11
4. Then i tried to open my KDE desktop by typing: kde and it worked!!! Great stuff

SpikeyKlitske 09-29-04 08:58 AM

Re: Fatal Server Error: caught signal 8
 
1 Attachment(s)
I am still having trouble loading the nvidia drivers properly. I installed the NVIDIA driver NVIDIA-Linux-x86-1.0-6111-pkg1.run, changed the XF86Config file, ie replaced "vesa" with "nvidia" and restarted.

"The installer gives a warning: your kernel was configured to include rivafb support as a loadable kernel module.

The rivafb driver conflicts with nvidia driver; the nvidia kernel will still be built and installed..."

At the next boot the gui wouldnt come up and came with different complaints, see the log files which are attached:

Meanwhile i found a different way to change the video driver:
at the command prompt type su and password for root
type and enter drakconf
navigate to display and activate
select xorg, vesa
save changes
type and enter exit
start X

Also the error "failed to set write-combining range (0xe8000000, 0x8000000)"remains even with the vesa driver loaded.

HELP

mctylr 09-29-04 01:12 PM

Re: Fatal Server Error: caught signal 8
 
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"


(II) LoadModule: "/usr/X11R6/lib/modules/extensions/libglx.a" (glx)
(WW) LoadModule: given non-canonical module name "/usr/X11R6/lib/modules/extensions/libglx.a"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(EE) Unable to open /usr/X11R6/lib/modules/extensions/libglx.a
(II) UnloadModule: "glx"
(EE) Failed to load module "/usr/X11R6/lib/modules/extensions/libglx.a" (open failed, 2)


These are the errors that are causing you problems. First you are not loading the kernel module (try it by hand: /sbin/modprobe nvidia) and fix those errors first, and then you have the wrong location for the NVidia OpenGL module (libglx). In xorg.conf just specify:

LoadModule "glx"
rather than
LoadModules "/usr/X11R6/lib/modules/extensions/libglx.a"

Do you really want the Wacom driver? This is typically for tablets, not mice.

SpikeyKlitske 09-30-04 03:42 AM

Re: Fatal Server Error: caught signal 8
 
I tried to do what u suggested, ie loaded the glx module using the /sbin/modprobe nvidia command entered as root in a terminal and it went ok. Next i edited the XFConfig file (it appearantly doesnt matter which file i pick XF86Config or xorg.conf because changes are reflected in either file) to change the driver back to "nividia"instead of "vesa". Next i noticed the following lines in the XF86Config file:

Load "glx" # 3D layer
Load "/usr/X11R6/lib/modules/extensions/libglx.a"

Going for your comment i assumed that both are the same so i deleted the line ...libglx.a" and rebooted. Now the nvidia driver wouldnt load ie there was no gui. I logged in as root; entered again the /sbin/modprobe nvidia command which ran fine; exited root; logged in as user; started my desktop by entering kde and the nvidia splash screen appeared and desktop loade fine (which is where i am now).

So in the config file is still something missing, but what to do next? Also, your suggestion uses a different format then present in my XF86Config file, i assume i have to use Load instead of LoadModule, correct?

BTW i do have a wacom tablet+pen+mouse and would like to use it, but thats another issue i still have. Thanks anyway

SpikeyKlitske 09-30-04 07:13 AM

Re: Fatal Server Error: caught signal 8
 
OK i tried following another thread:

http://www.nvnews.net/vbulletin/showthread.php?t=37579

which indicated to add a patch to the 6111 nvidia driver. Since I am a simple linux user i couldnt complete the task, ie could even get past the first 1 to xtract the nvidia driver as suggested. But it also manage to add "nvidia" without the quotes to the /etc/modeprobe.preload file and woohoo it works. X server comes up nicely upon boot. sofar so good lets check the erro messages again and see if all is gone.

beer anyone?


All times are GMT -5. The time now is 03:24 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.