nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Very low FPS using nVidia Geforce FX Go 5200 using 6111 drivers (http://www.nvnews.net/vbulletin/showthread.php?t=37732)

krosswindz 09-29-04 03:10 PM

Very low FPS using nVidia Geforce FX Go 5200 using 6111 drivers
 
1 Attachment(s)
I installed the Gentoo patched nvidia drivers version 6111 on my Inspiron laptop. When I run glxgears I get FPS of around 600 FPS only. I run the same drivers on my nvidia GeForce Fx 5200 on my desktop and I get like 2000FPS in glxgears running the same version of the drivers. I am attaching the output of my glxinfo from my laptop. Can anybody please help me to fix this. Thanks in advance

energyman76b 09-29-04 03:41 PM

Re: Very low FPS using nVidia Geforce FX Go 5200 using 6111 drivers
 
*sigh* glxgears is no benchmark. The FPS of glxgears say NOTHING about your system. Which fps you'll get, depends on many factors, and the least significant is your graphic-card.
Get a 'real' 3d app running and see, if everything is ok.
Your glxinfo output looks fine.

LordMorgul 09-29-04 05:32 PM

Re: Very low FPS using nVidia Geforce FX Go 5200 using 6111 drivers
 
The 5200 Go and the 5200 are different video cards with different purposes.. the Go cards are meant for low power consumption and certainly that effects expected performance. I would assume they are clocked at very different speeds as well. You should look for other 5200 Go card user's performance rather than comparing directly to your other machine, even if all else is equal (glxgears is very cpu dependent).

You should check the clock speeds and consider clocking the Go card if its performance is too low, but be careful of course, slow is better than burned up. Install and use nvclock to check the speeds of your cards (and modify if desired).

krosswindz 09-29-04 10:45 PM

Re: Very low FPS using nVidia Geforce FX Go 5200 using 6111 drivers
 
1 Attachment(s)
I ran the GLMatrix screen saver as thats possible one of the few OpenGL apps that I have. The screensaver is extremely choppy. It takes forever. I know for sure that I am having some problems with the GL module. I am attaching my xorg.cong. Hoping that I havent missed out anything in that. Anyhelp on this is really appreciated.

Thanks

krosswindz 09-29-04 10:56 PM

Re: Very low FPS using nVidia Geforce FX Go 5200 using 6111 drivers
 
1 Attachment(s)
I installed nvclock hoping that I would be able to over clock the GPU. Seems like You cant over clock the Mobile GPU's. I see that Fast Write and SBA are both disabled. Looking in /proc/drivers/nvidia/agp I find the Intel 82855PM host bridge doest support Fast Write and SBA. Probably the driver has disabled it. Attaching the output of nvclock -i along with this post.

energyman76b 09-29-04 11:17 PM

Re: Very low FPS using nVidia Geforce FX Go 5200 using 6111 drivers
 
hi,
could you post:
cat /proc/driver/nvidia/agp/status
your xorg.0.log
dmesg
?

From your config: do you really need load int10? If not, remove it.
please remove load record and the dri stuff at the end.

krosswindz 09-30-04 02:41 PM

Re: Very low FPS using nVidia Geforce FX Go 5200 using 6111 drivers
 
3 Attachment(s)
I ran X without removing int10, record modules and DRI section at the end. I named the Xorg.0.log file as Xorg.0.log_with_modules_dri.txt. Then I commented out the load modules for int10, record and commented out the DRI section at the end. I named the Xorg.0.log as Xorg.0.log_without_modules_dri.txt and attaching both the log files and the /proc/drivers/nvidia/agp/status file along with this post.
Even after removing the glxgears gives me an FPS of around 600 and glmatrix is still literally unusable.

energyman76b 09-30-04 04:51 PM

Re: Very low FPS using nVidia Geforce FX Go 5200 using 6111 drivers
 
Hi,

please remove vbe and xtt too. With freetype xtt, xfs&co are not needed anymore.

So, and you are using 1920x1200&RENDER&RANDR&mouseshadow.
Try, without RENDER, RANDR, and mouseshadow. The nvidia README tells you how.

krosswindz 10-01-04 02:41 PM

Re: Very low FPS using nVidia Geforce FX Go 5200 using 6111 drivers
 
1 Attachment(s)
Disabled vbe, xtt, RenderAcceleration and set NoRenderExtensions and disabled cursor shadows. Its still the same. I get like 600 odd FPS in glxgears and GLMatrix shows no improvements at all. Its still the same. Attaching the Xorg.0.log along with this post. Any help appreciated.


All times are GMT -5. The time now is 12:21 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.