nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   XawTV / Sox sound problems (K7N2 w nvsound) (http://www.nvnews.net/vbulletin/showthread.php?t=38258)

conn-fused 10-07-04 06:35 AM

XawTV / Sox sound problems (K7N2 w nvsound)
 
I've just reinstalled Mandrake 9.2 after putting in a new motherboard (MSI K7N2 Delta with NVIDIA nForce2 chipset; on board sound).

My sound worked fine in xmms, etc, using alsa and snd-intel8x0.

Then I set up XawTV. I have an old bttv card and have to pass the sound to /dev/dsp using sox ("sox -r 32000 -w -t ossdsp /dev/dsp -t ossdsp /dev/dsp2"). This setup worked fine on my old board, but now it stuttered seriously. If XawTV was on screen (visible) the sound would lag, stutter and soon become unusable. (BTW, the old board was a K7VMM+, also with onboard sound but using snd-via-82xx).

I thought it was a problem with my sound driver. I got nvsound from the NVIDIA site's .run package. I had to change from alsa to oss for this driver to work in KDE. Once that was done, I found that everything was the same! (ie sound worked fine, except when using sox and xawTV together). Well, one small difference. Sox now declares ("Sox: Sound card appears to only support two channels. Overriding format." and "Sox: Unable to set audio speed to 32000 (set to 48000)").

If the driver wasn't at fault, I'm no longer really sure where to look for the problem. I'd love to hear from someone who's used this board/software combination, but at this point I'm equally happy to entertain guesses as to the problem's source. Thanks!

conn-fused 10-07-04 06:56 AM

Re: XawTV / Sox sound problems (K7N2 w nvsound)
 
**************

A correction to the above.

I think I still had snd-intel8x0 on one line of my /etc/modules.conf (it keeps resetting itself - I guess because there isn't an nvsound option under the driver choices for my soundcard in Harddrake - advice on this also welcome).

Anyway, I made sure only "nvsound" replaced "snd-intel8x0" everywhere, rebooted and got both Nforce and Bttv tabs in KMix. That looked like progress, so I openned XawTV and ran sox in a terminal window. This time, sox said:

"Sox: Can't open output file '/dev/dsp' : Cannot allocate memory"

*****************


All times are GMT -5. The time now is 04:12 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.