nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nvsound not working for doom3 (http://www.nvnews.net/vbulletin/showthread.php?t=38260)

gdh 10-07-04 06:17 AM

nvsound not working for doom3
 
I've got an AMD64 with nforce3 mobo. (suse 9.1 x86_64)
I've installed the 0283 nforce sound drivers.
They work just fine for normal use (mp3 playing, desktop sounds &c)
however when I try to run doom3 I have no sound.

This seems to be caused by doom trying to change the samplerate to 44.1Khz iso 48000 Khz.

Doom3 sais:
during DOOM 3 initialization...
WARNING: ioctl SNDCTL_DSP_SPEED failed to get the requested frequency 44100, got 48000

WARNING: sound subsystem disabled

Kernel sais:
Oct 7 12:13:00 hyperion kernel: Nvsound: Nvidia Audio Init Module, 10:06:21 Sep 6 2004 version 1.0-0
Oct 7 12:13:00 hyperion kernel: Nvsound: NVIDIA Hammer Audio found at IO 0xec00 and 0xe800, IRQ a
Oct 7 12:13:00 hyperion kernel: Nvsound: Aci_device 000001001faa5800 Apu_device 0000000000000000
Oct 7 12:13:00 hyperion kernel: Nvsound: DEV MIXER 0 DEV AUDIO 3
Oct 7 12:20:05 hyperion kernel: Nvsound: Set format as 10
Oct 7 12:20:05 hyperion kernel: Nvsound: Unable to change the Playback SampleRate, set back to 48000


Any help is greatly appreciated
(oh , and anyone willing to donate me a geforce 6800 for etsting is also very welcome ;) )

blueworm 10-08-04 12:34 AM

Re: nvsound not working for doom3
 
http://forums.gentoo.org/viewtopic.php?t=233027


All times are GMT -5. The time now is 07:36 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.