nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVIDIA Drivers installation in Mandrake (http://www.nvnews.net/vbulletin/showthread.php?t=38427)

juolo 10-10-04 06:22 AM

NVIDIA Drivers installation in Mandrake
 
I've just installed driver in Mandrake 10 and getting followin error after installation and X didn't start anymore.

Here is edited XF86Config
Code:

**********************************************************************

 Refer to the XF86Config man page for details about the format of

 this file.

 **********************************************************************

Section "Files"

 Multiple FontPath entries are allowed (they are concatenated
together)

 By default, Mandrake 6.0 and later now use a font server independent
of

 the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the
mouse doesn't work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution
switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "fi"
    Option "XkbOptions" ""
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Panasonic"
    ModelName "Panasonic E70i"
    HorizSync 30.0-70.0
    VertRefresh 50.0-180.0
   

 Sony Vaio C1(X,XS,VE,VN)?

 1024x480 @ 85.6 Hz, 48 kHz hsync
    ModeLine "1024x480"    65.00 1024 1032 1176 1344  480  488  494
563 -hsync -vsync
   

 TV fullscreen mode or DVD fullscreen output.

 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"    50.00  768  832  846 1000  576  590  595
630
   

 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"    63.07  768  800  960 1024  576  578  590
616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "NVidia"
    BoardName "NVIDIA GeForce4 (generic)"
    Driver "nvidia"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
   
    Subsection "Display"
        Depth 8
        Virtual 1024 768
    EndSubsection
   
    Subsection "Display"
        Depth 15
        Virtual 1024 768
    EndSubsection
   
    Subsection "Display"
        Depth 16
        Virtual 1024 768
    EndSubsection
   
    Subsection "Display"
        Depth 24
        Virtual 1024 768
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
EndSection

When I've tried to starts X, getting followin error:

XFree86.0.log:

Code:

  16 512x512 slots
(==) NV(0): Backing store disabled
(==) NV(0): Silken mouse enabled
(**) Option "dpms"
(**) NV(0): DPMS enabled
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(EE) Failed to initialize GLX extension (NVIDIA X driver not found)
(II) Keyboard "Keyboard1" handled by legacy driver
(**) Option "Protocol" "ExplorerPS/2"
(**) Mouse1: Protocol: "ExplorerPS/2"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/mouse"
(**) Mouse1: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "6 7"
(**) Mouse1: ZAxisMapping: buttons 6 and 7
(**) Mouse1: Buttons: 7
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) Mouse1: ps2EnableDataReporting: succeeded

What should i do to get mandrake working properly ?

crac 10-10-04 06:32 AM

Re: NVIDIA Drivers installation in Mandrake
 
how does your /etc/modules.conf look like? does it contain the following line:

alias char-major-195* nvidia

if not add it. then load the module by hand with

$ modprobe nvidia

tux_topo 10-11-04 07:43 PM

Re: NVIDIA Drivers installation in Mandrake
 
I have a very similar problem, but in my case, i should stop the dm, modprobe nvidia, and re-charge the dm..... How i can fix that?? Always is the same.

crac 10-12-04 05:23 AM

Re: NVIDIA Drivers installation in Mandrake
 
1) if you are using mandrake10.0:

add the following line (as root) to /etc/modules.conf:

alias char-major-195* nvidia

2) if you are using 10.1:

add the following line to /etc/modprobe.preload

nvidia


==> this will make your system load the kernel module automatically on startup.

tux_topo 10-12-04 01:09 PM

Re: NVIDIA Drivers installation in Mandrake
 
I'm in MDK 10.1
I added both, and when it should run, flash me the screen, and then it shows me the prompt screen.....
Any other suggestion??

juolo 09-25-11 08:44 AM

Re: NVIDIA Drivers installation in Mandrake
 

juolo 01-12-12 05:08 PM

Re: NVIDIA Drivers installation in Mandrake
 
UP! I want advertise my new website which is: http://www.elisanet.fi/petri.karttunen/. Please visit and feel free to send feedback :).


All times are GMT -5. The time now is 12:13 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.