nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Slow OpenGL on 7.3 (http://www.nvnews.net/vbulletin/showthread.php?t=404)

kl899 08-04-02 06:26 PM

Slow OpenGL on 7.3
 
I installed the Nvidia 2960 drivers for my TNT 1. I read the readme.txt and all the libraries seem to be correctly installed. I can run KDE fine and there is an Nvidia splash screen when I start it now. Unfortunately, my OpenGL screensavers don't work at all and when I run Quake 3, it runs at about 1 frame every 5 seconds. What could be wrong? How do I check to see that q3demo is using the right GL drivers? (when i use "ldd" on q3demo, it says it's not a dynamic executable). Here is a paste of what q3demo says when it is starting up:

----- R_Init -----
...loading libGL.so: Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.1
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 1280x1024
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
Initializing OpenGL extensions
...GL_S3_s3tc not found
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array

GL_VENDOR: NVIDIA Corporation
GL_RENDERER: RIVA TNT/AGP
GL_VERSION: 1.3.1 NVIDIA 29.60
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multitexture GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_abgr GL_EXT_bgra GL_EXT_compiled_vertex_array GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_stencil_wrap GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_vertex_weighting GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_evaluators GL_NV_fog_distance GL_NV_packed_depth_stencil GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_SGIS_multitexture
GL_MAX_TEXTURE_SIZE: 2048
GL_MAX_ACTIVE_TEXTURES_ARB: 2

PIXELFORMAT: color(24-bits) Z(24-bit) stencil(0-bits)
MODE: 3, 640 x 480 fullscreen hz:N/A
GAMMA: software w/ 0 overbright bits

kl899 08-04-02 07:58 PM

I fixed the problem... at least for Quake 3. Basically I had to edit /etc/X11/X11Config to include lower resolutions like 640x480, 800x600, etc. The problem was that since these video modes weren't listed in the X11 config file, Quake 3 used the Mesa OpenGL (software) instead of the Nvidia OpenGL. Now it's running smoothly. I haven't tried other opengl application yet.


All times are GMT -5. The time now is 06:15 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.