nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Quake 2 /dev/dsp error (http://www.nvnews.net/vbulletin/showthread.php?t=4050)

MadDog 11-14-02 11:40 PM

Quake 2 /dev/dsp error
 
Hi There

I am getting a Segmentation Fault (Device in Use /dev/dsp) error when trying to run Quake II on my mandrake 9 system.

I managed to get it running the first time under X with +set vid_ref softx. I then changed the driver to GLX OpenGL under the video options in the menu. the game gave an error, and locked my system. I rebooted and now I get the device in use error whenever I try to run the game. This occurs during the sound initialisation phase.

The other question I have is can I run QuakeII in GLX OpenGL mode with my Nvidia Card ? The HOWTO says that the glx is only for 3DFX cards.

I can still run Quake III and Unreal Tournament 2003 without any problems. Even Tuxracer works fine with sound.

Any help or insight into how to unlock /dev/dsp would be greatly appreciated here.

Kind Regards

MadDog

bammbamm808 11-22-02 12:43 AM

Just a guess
 
Try killing artsd. I think MDK loads it, and buckets of other crap by default. Or I could be miles off here.

MadDog 11-22-02 01:37 AM

/dev/dsp error
 
Hi,

Thanks for the help. I found that just waiting 60 Secs or more after starting MDK, the device is released, and I can play.

Thanks again

Regards

MadDog


All times are GMT -5. The time now is 11:13 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.