nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   TV-out: system hangs on return to console (http://www.nvnews.net/vbulletin/showthread.php?t=41129)

Iskendar 11-20-04 04:36 PM

TV-out: system hangs on return to console
 
Hi all,

Again (I've posted this quite a few times, about each change in driver since the 5*** series):
I've got a Geforce 4 Ti4200, BIOS version nr.04.25.00.30.16, pentium 4, using XFree 4.3.0-r5 on Gentoo, 2.6.7 kernel, framebuffer disabled. When I run the system without tv-out enabled, there's no problem. When I enable tv-out, everything works fine, until log out of X or return to console.Then the system hangs: the screen goes black, there's no response to the keyboard (ctrl-alt-del does nothing), I tried pinging from another machine on the LAN, nothing, zilch, dead as a dodo.

This has been the case since the switch from 4*** to 5*** drivers, and it's still the case with the new 6629 driver. I've posted on this forum, and have sent reports to linux-bugs@nvidia.com for several versions of the driver, to no avail. I've received one response from nvidia, for the 5336 driver, stating that "TV overscan support should be fixed in our next driverrelease (due out shortly)", since then, nothing.

This is seriously getting on my nerves, since I did buy this card partly because of it's tv-out capability, and have enjoyed it working, but not with a driver capable of coexisting with a recent kernel. So what I would like to know is whether the cause of this problem is known, whether someone has solved it already, and if not, whether nvidia is planning to do something about it (or are they hoping we move on to more recent cards)? Also, if other users on this board suffer from this problem, could you please post on this tread? A "me too" will suffice, though something more substantial would be desirable. It seems to be an ignored problem, so any attention it gets is good.

For completeness, here's the offending XF86Config-4 file. When I comment out all references to "Screen TV", the hang on logout problem disappears, but then I obviously can't use the tv-out.

Code:

# Server Layout
# =============
Section "ServerLayout"
        Identifier    "XFree86 Configured"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen TV" leftOf "Screen0"
        InputDevice    "Logitech Mouse"
        InputDevice    "Logitech Keyboard"
EndSection

# Paths
# =====
Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath  "/usr/X11R6/lib/modules"
        FontPath    "/usr/X11R6/lib/X11/fonts/misc/"
        FontPath    "/usr/X11R6/lib/X11/fonts/Speedo/"
        FontPath    "/usr/X11R6/lib/X11/fonts/Type1/"
        FontPath    "/usr/X11R6/lib/X11/fonts/CID/"
        FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/"
        FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

# Modules
# =======
Section "Module"
        Load  "glx"
        Load  "record"
        Load  "extmod"
        Load  "dbe"
#        Load  "dri"
        Load  "xtrap"
        Load  "type1"
        Load  "speedo"
EndSection

# Inputdevices
# ============
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
EndSection


Section "InputDevice"
        Identifier        "Logitech Keyboard"
        Driver                "keyboard"
        Option                "CoreKeyboard"
        Option                "XkbRules"        "xfree86"
        Option                "XkbModel"        "pc104"
        Option                "XkbLayout"        "us"
EndSection


Section "InputDevice"
        Identifier        "Logitech Mouse"
        Driver                "mouse"
        Option                "CorePointer"
        Option                "Device"                "/dev/psaux"
        Option                "Protocol"                "ImPS/2"
        Option                "ZAxisMapping"                "4 5"
        Option                "Buttons"                "6"
EndSection


# Monitors
# ========
Section "Monitor"
        Identifier  "Monitor0"
        VendorName  "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Monitor"
        Identifier        "MyTV"
        HorizSync        30-50
        VertRefresh        60
EndSection

# Graphics Card
# =============
Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        Option            "NvAGP" "1"
        VendorName  "nVidia Corporation"
        BoardName  "NV25 [GeForce4 Ti 4200]"
        BusID      "PCI:1:0:0"
        Screen        0
EndSection

Section "Device"
        Identifier  "Nvidia TV"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName  "NV25 [GeForce4 Ti 4200]"
        BusID      "PCI:1:0:0"
        Screen        1
EndSection


# Screens
# =======
Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        Defaultdepth 24
        SubSection "Display"
                Depth    24
                Modes          "1280x1024"
        EndSubSection
EndSection

Section "Screen"
        Identifier "Screen TV"
        Device    "Nvidia TV"
        Monitor    "MyTV"
        Monitor                "MyTV"
        Option                "TVStandard"        "PAL-B"
        Option                "TVOutFormat"        "COMPOSITE"
        DefaultDepth        24
        Subsection "Display"
                Depth                24
                Modes                "800x600"
                ViewPort        0 0
        EndSubSection
EndSection


mobtek 11-21-04 09:55 AM

Re: TV-out: system hangs on return to console
 
I've had the same probs, 4496 was the last time I had tvout working, it's driving me nuts too :)
NVIDIA, how many bugs reports do we have to send before this prob with the Ti4200's and tvout is fixed?
Is there a better brand of supported video card under linux? If so, I'm buying it and dumping this in the trash. :<

Iskendar 11-22-04 03:10 AM

Re: TV-out: system hangs on return to console
 
Quote:

Originally Posted by mobtek
I've had the same probs, 4496 was the last time I had tvout working, it's driving me nuts too :)

I tried getting 4496 to work with the 2.6.7 kernel, but I got an error message. Does anyone know how to get these two to work together? I haven't tried the open source nv driver yet, maybe that's a solution (at the cost of speedy graphics).

Quote:

Originally Posted by mobtek
NVIDIA, how many bugs reports do we have to send before this prob with the Ti4200's and tvout is fixed?

If they would at least reply to the bug reports and recognize the problem, I wouldn't be so pissed off about it.

Quote:

Originally Posted by mobtek
Is there a better brand of supported video card under linux? If so, I'm buying it and dumping this in the trash. :<

Alas, I hear that ATI linux support is even worse. But if a better competitor arises, the NVIDIA card gets a one way ticket to the trash bin indeed. You know, occasionally I see messages on this board stating that we should be lucky that NVIDIA supports linux at all, and not complain so much. WTF?? They sell the card, claim it's supported for linux, then they'd better make it work! I bought this card specifically because of a) rumoured good linux support and b) tv-out. The fact that it DID work with the 4496 driver pisses me off even worse, this means that there is a solution out there, but they can't be bothered with re-implementing it. I wonder why.

kipper 11-22-04 09:55 AM

Re: TV-out: system hangs on return to console
 
Yeah, I'm experiencing exactly the same problem. Holy hell is it frustrating. Right now I'm using the hacked 4363 driver from http://www.minion.de/ with the 2.6.9 kernel.
I've almost given up on getting any of the the newer "fixed" drivers to work but would really love to see this console restore actually fixed for ALL G4 Ti cards. I tried the 6111 and it doesnt allow me to return to console, just hangs the system.

Iskendar 11-25-04 06:29 AM

Re: TV-out: system hangs on return to console
 
Quote:

Originally Posted by kipper
Yeah, I'm experiencing exactly the same problem. Holy hell is it frustrating. Right now I'm using the hacked 4363 driver from http://www.minion.de/ with the 2.6.9 kernel.
I've almost given up on getting any of the the newer "fixed" drivers to work but would really love to see this console restore actually fixed for ALL G4 Ti cards. I tried the 6111 and it doesnt allow me to return to console, just hangs the system.

*******, you saved me with those patched drivers! Running 4620 now, tv-out works, no crash on logout! Still, keep complaining to nvidia about those new drivers. They should fix this problem. Keep 'em coming people.

I.

mobtek 12-04-04 09:44 PM

Re: TV-out: system hangs on return to console
 
I actually got tvout working on a Ti4200 with 6629
in my XF86Config I commented out some lines
Option "TwinView"
# Option "ConnectedMonitor" "CRT, TV"
# Option "TwinViewOrientation" "Clone"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "MetaModes" "1600x1200, 640x480 +100+100"
Option "TVStandard" "PAL-B"
Option "TVOutFormat" "COMPOSITE"

and all of a sudden I get tvout and my crt working at the same time again (before either both would go black or the CRT would and console would disappear and the machine freeze hard requiring a hardboot), so odd :P
Hope this helps someone else, I be happy again, nvidia dudes, why would this work with these lines commented out?

comag 12-05-04 01:42 PM

Re: TV-out: system hangs on return to console
 
i have the X-shutdown-lockup with enabled TwinView too :(

szczepan 12-12-04 11:46 PM

Re: TV-out: system hangs on return to console
 
i got the same problem somehow there is a way to go around it....not using twin view just....starting new X server and exporting all the movies to the Tv with export DISPLAY=:1 .....the bad thing is that you need to switch them....CTRL+ALT+f7 its the monitor and CTRL+ALT+f8 its the tv.....but console works ...shuting down works....well ....lets hope they will fix this thing someday...

-------------------
gentoo 2.6.9-ck3
geforceti4200

Jimmy Jazz 12-24-04 08:29 AM

Re: TV-out: system hangs on return to console
 
Hello,

I got the same problem when i switched back to the vt console or when i logged out with or without vesafb module activated.

My computer freezed in a strange 31.6Khz, 71Hz black screen mode :( after i switched back (Ctrl+Alt+F1) to one of the vt consoles ... and this happened only with twinview mode or ":0.0 :0.1" display mode. In any case, it never happened during a single screen X11 configuration even with vesafb or APIC activated in the kernel.

I could get a workaround to avoid the problem but only with a two display configuration (the solution doesn't work in a twinview mode :( ).
to stop the xdm server during a current working session please use the command "/etc/init.d/xdm stop" !!! So i could return to a working console and stop manually the station after i logged back to root in order to perform an init 0.

A bit complicated, but my data are safe and the next boot didn't need to perform a "fsck" !

I continue to hope Nvidia developers would be kind enough to investigate and find a correction to that annoying bug!!

I use a Gforce4 Ti4200 video card.

Thx

Jj

ecogt 12-29-04 08:14 AM

Re: TV-out: system hangs on return to console
 
Im thinking about bying a pci graphics card and use it along with my Ti4200...

i would plug the pci card to the tv and my Ti4200 to the CRT and use to screeens (the tv right of the crt in xorg.conf).

do you think this is a good sollution or is it even harder to get to work? in theory it sounds really nice, but ive never used two graphic cards at the same time...

//ecogt


All times are GMT -5. The time now is 04:04 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.