nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   FreeBSD 5.3-Release & Nvidia 6113 (http://www.nvnews.net/vbulletin/showthread.php?t=41133)

tabmow 11-20-04 06:36 PM

FreeBSD 5.3-Release & Nvidia 6113
 
I installed the nvidia-driver port with complete success and went on to change Driver "nvidia" and commented out Load "dri" in my xorg.conf - I find that i had no problems in the xorg log no errors but when i run glxinfo or glxgears i get errors saying that it can't find a rgb buffered visual, i also get messages about agp.ko so i recompiled a new kernel without device agp and i still get the same problem. I had this very same problem when trying to install the nvidia driver's on mandrake 10.1 official as well. Does anyone know why this is happening? I followed the document to the point to no prevail. The card is a GF4 ti4600. Any help will be hugely appreciated.

Thankyou.

erek 11-20-04 07:42 PM

Re: FreeBSD 5.3-Release & Nvidia 6113
 
Quote:

Originally Posted by tabmow
I installed the nvidia-driver port with complete success and went on to change Driver "nvidia" and commented out Load "dri" in my xorg.conf - I find that i had no problems in the xorg log no errors but when i run glxinfo or glxgears i get errors saying that it can't find a rgb buffered visual, i also get messages about agp.ko so i recompiled a new kernel without device agp and i still get the same problem. I had this very same problem when trying to install the nvidia driver's on mandrake 10.1 official as well. Does anyone know why this is happening? I followed the document to the point to no prevail. The card is a GF4 ti4600. Any help will be hugely appreciated.

Thankyou.

make sure you have
Quote:

Load "glx"
you don't need GLcore...
in your video card device section try adding

Quote:

Option "NvAgp" "1"

tabmow 11-21-04 07:05 AM

Re: FreeBSD 5.3-Release & Nvidia 6113
 
2 Attachment(s)
I tried what you said and i still have no luck. I get this message coming up to the console: NVRM: Detecting agp.ko - aborting Nvidia AGP Setup!

I am going to include my xorg.conf and log for troubleshooting, i don't know what else to do though.

Thanks in advance ;oP

zander 11-21-04 07:17 AM

Re: FreeBSD 5.3-Release & Nvidia 6113
 
You're seeing two different problems, both of which are easily solvable. The first is that you're requesting the use of NvAGP, with FreeBSD's AGPGART driver present; the easiest fix for this is to add hint.agp.0.disabled="1" to /boot/device.hints (make sure you reboot). The second problem is that you're running X at depth 8; to address this, add DefaultDepth 24 to the Screen section of your Xorg configuration file.

tabmow 11-21-04 07:36 AM

Re: FreeBSD 5.3-Release & Nvidia 6113
 
Thanks heaps mate.
Your a legend!

24038 frames in 5.0 seconds = 4807.600 FPS

Woohoo!

JJ test 12-01-04 06:11 AM

Re: FreeBSD 5.3-Release & Nvidia 6113
 
Zander's fix for adding the line to device.hints didn't work for me. I rebooted but I still get the same error. This nVidia driver installer DOESN'T WORK for my expensive video card. I can't do my work! I want to disable agp.ko by default from the installer please!

How can I do this? Please help.

zander 12-01-04 07:19 AM

Re: FreeBSD 5.3-Release & Nvidia 6113
 
The device.hints approach to disabling agp.ko only works with recent (past FreeBSD 5.2.1, e.g. FreeBSD 5.3) kernels; on systems using earlier kernels, the kernel needs to be rebuilt w/o agp.ko support (this is beyond the Makefile's capabilities).

JJ test 12-01-04 08:06 AM

Re: FreeBSD 5.3-Release & Nvidia 6113
 
Thanks Zander. Yes I'm using FreeBSD 4.10. I'll look into rebuilding it without agp.ko support.

Again thanks very much for your quick and kind response.


All times are GMT -5. The time now is 01:46 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.