nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   OpenGL Screensavers Won't Work (http://www.nvnews.net/vbulletin/showthread.php?t=413)

kl899 08-04-02 10:23 PM

OpenGL Screensavers Won't Work
 
I installed the 2960 drivers. KDE runs fine and I've even gotten Quake 3 to be accelerated. The problem is that the default OpenGL screensavers that come with KDE(you know.. like the cheesy Pipes screensaver) won't work. They won't even start up. Does anyone have any suggestions of how I might be able to fix this? I know... it's a minor problem but I'm a perfectionist! :)

Kevin 08-05-02 08:12 AM

OpenGL Screensavers
 
Hi:

I just ran into the same problem with the screensavers. When you installed the drivers, there is a possibility that you had installed MESA earlier on, and some of the libs may conflict with calls to the NVIDIA libs, or this is what I had been lead to believe. The fix is to re-install just the GLX portion of the drivers again to fix the problem. Did you use the tarball or the RPM files? The tarball installation method worked for me, but the RPM files did not install properly under MDK8.2. :(

After you reinstall the GLX portion of the drivers, the problem will resolve, as the second installation should finish renaming and installing the files so such a problem should not recur. If the RPM file won't do the trick, you may find the tarball install the best method, as it will overwrite any older version drivers, and replace them. Good luck. BTW, you never did mention which version of Linux you are currently running. :D

kl899 08-05-02 09:14 AM

i'm running redhat 7.3 and i had originally installed GLX with a tar and the kernel with a rpm. i just reinstalled the GLX tar and the screensavers still won't start! is there a way i can remove mesa altogether to make sure it's not conflicting with the nvidia drivers?

kl899 08-05-02 04:03 PM

ok I manually located one of the OpenGL screensaver binaries in /usr/bin/kpipes.kss

when i tried to manually run it from a shell is gave this error:

# kpipes.kss: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory

so now what should i do?

kl899 08-05-02 05:23 PM

I made a symbolic link to the nvidia libGL called libGLU.so.1 to see what the screensavers would do. It actually made one of them work but for the others, they complained they couldn't locate certain GLU functions within libGLU.so.1. This means that those screen savers were hardwired with GLU calls, which is the Mesa opengl implementation and there is no way the Nvidia drivers would run those screensavers.

So what I did was download XFree86-libs-4.2.0-8.i386.rpm which is a package that contains the real libGLU.so.1 from Mesa. I installed that and verified in /usr/lib that the real libGLU.so.1 was installed and that the other Nvidia libraries were untouched. I then tried running kpipes and I was successful! I know the Nvidia libraries are still functional because I was able to run Quake 3 at a decent framerate. The only problem now is that some of the screensavers that use GLU, notably morph3d, run slow. I suppose that might be due to only having a celeron 300 and trying to render a 3d scene at 1280x1024 in softwar driven opengl.

mtrr 08-05-02 09:40 PM

GLU is in _no_ way a Mesa invention nor the Mesa-version of GL.

read here for further information:

http://mesa3d.sourceforge.net/downloads/sgi.html

HTH

kl899 08-05-02 10:25 PM

ok. so why doesn't nvidia include a GLU library? can I not get hardware support for GLU?

here is a link to a brief summary i found for GLU:

http://tc1.chemie.uni-bielefeld.de/d...ilitiesLibrary

thanks for the info!

mtrr 08-05-02 10:36 PM

libGLU is _not_ hardware dependent.

just do "ldd /usr/lib/libGLU.so.1", you'll see all involved libraries.

HTH


All times are GMT -5. The time now is 10:02 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.