nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   "Failed to initialize the NVIDIA graphics device!" with 1.0-6629 for Linux x86-64 (http://www.nvnews.net/vbulletin/showthread.php?t=42007)

vinz 12-07-04 10:19 AM

"Failed to initialize the NVIDIA graphics device!" with 1.0-6629 for Linux x86-64
 
4 Attachment(s)
Hi,

I tried to install 1.0-6629 for Linux x86-64
The details of my configuration (HP xw8200) are :
- 2 x Xeon EMT64
- Gentoo linux distribution (up to date), 2.6.9 kernel with framebuffer
- FX 3400 PCI-express

I get a "Failed to initialize the NVIDIA graphics device!" message after "startx".

I attached the xorg.conf and Xorg.0.log files but also the result of 'lspci' command and the content of /proc/driver/nvidia/cards/0 (even know I could not load X11)

I tried also the 1.0-6111 but the driver could not access the 'config memory'

Any advice is welcome :)

Vinz

zander 12-07-04 07:03 PM

Re: "Failed to initialize the NVIDIA graphics device!" with 1.0-6629 for Linux x86-64
 
This is a known problem that's currently being investigated and should be resolved soon. As a temporary workaround, you could reduce the amount of installed system memory (such that the SWIOTLB is not used).

zander 12-08-04 02:51 PM

Re: "Failed to initialize the NVIDIA graphics device!" with 1.0-6629 for Linux x86-64
 
1 Attachment(s)
I attached a workaround for this problem; to apply it and install the modified driver:

# sh NVIDIA-Linux-x86_64-1.0-6629-pkg0.run --extract-only
# cd NVIDIA-Linux-x86_64-1.0-6629-pkg0
# patch -p0 < /path/to/NVIDIA_kernel-1.0-6629-1175225.diff.txt
# ./nvidia-installer

An alternative solution (a better one, really) is to modify map_single() in swiotlb.c to page-align mapping requests of size greater than or equal to PAGE_SIZE.

gdh 12-24-04 06:50 AM

Re: "Failed to initialize the NVIDIA graphics device!" with 1.0-6629 for Linux x86-64
 
What might also do the trick is booting with
noapm noapic vga=normal

(at least, that worked for me)

zander 12-24-04 07:17 AM

Re: "Failed to initialize the NVIDIA graphics device!" with 1.0-6629 for Linux x86-64
 
@gdh: to avoid confusion: while you're correct in that the noapic kernel parameter can help with rm_init_adapter() failures when the GPU isn't receiving interrupts, that's another problem, unrelated to the one vinz was seeing.

chiefworks 12-30-04 04:21 PM

Re: "Failed to initialize the NVIDIA graphics device!" with 1.0-6629 for Linux x86-64
 
Quote:

I get a "Failed to initialize the NVIDIA graphics device!" message after "startx".
Comment out the NvAgp option in your xorg.conf file.

zander 12-30-04 05:16 PM

Re: "Failed to initialize the NVIDIA graphics device!" with 1.0-6629 for Linux x86-64
 
@chiefworks: that option has no effect on PCI Express systems.


All times are GMT -5. The time now is 10:11 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.