nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problems with twinview and default monitor (http://www.nvnews.net/vbulletin/showthread.php?t=43055)

Talornin 12-27-04 04:15 PM

Problems with twinview and default monitor
 
Hello there!

I have a Geforce 4 Ti 4800SE (Gainward) with a VGA and a DVI head.
I have two CRT monitors connected (one througha DVI -> VGA adapter), TwinView is working perfectly save one thing.

I want the monitor connected to the VGA head to be the primary monitor (0), as far as I can tell TwinView treats the DVI head as primary and VGA as secondary. This creates som problems with games and movies etc. Changing the location of the monitors (either physicaly or just swap the cables) is not an option.

Anyone have any idea on how to do this? I have googled and searched these forums to no avail.

jmcqueen 12-28-04 06:42 PM

Re: Problems with twinview and default monitor
 
try switching your monitors in xorg.conf or simply switch the cables. monitor0 becomes monitor1 AND monitor1 becomes monitor0. you may also have to update the 'rightof' or 'leftof' statement at the beginning of the file.

please post and let us know if this works.

j

jImbEam 12-28-04 09:38 PM

Re: Problems with twinview and default monitor
 
I was never able to get my dual DVI 5700 Ultra to use the DVI connector as the "primary" monitor (the one the X login is displayed on) unless I physically changed the cables going to the monitors. It seems the driver always setup one port on my card before the other, no matter what I did in the config.

I was able to do as jbcqueen says and change the layout of the displays using the rightof or leftof once X was started. I just had to accept that the login was always on my right monitor.

jImbEam

Talornin 12-28-04 09:56 PM

Re: Problems with twinview and default monitor
 
The problem is that I have one good monitor and one bad. I want the good monitor running at 1600x1200 @ as high hz as possible and the bad one at 1024x768 @ 75hz with only irc. Problem is that I can only get 1600x1200 @ 60hz (Which, of course, makes my eyes scream after about 47 seconds) when using the DVI head with a DVI -> VGA adapter and of course I want this good monitor to be the primary monitor. But no matter how much I tinker with the left/rightoff stuff the windows always appear at the monitor connected to the DVI head first and exiting fullscreen in mplayer places the window on the bad monitor so I have to drag it back to the good one. I can live with it but its annoying.

jmcqueen 12-30-04 12:20 AM

Re: Problems with twinview and default monitor
 
WOW! are you able to drag a window back and forth between displays? if so, please post all of your settings in xorg.conf. i can run 'dual head', but so far i have not found a way to be able to move the windows back and forth. nvidia driver notes say this is not possible in linux.

PLEASE POST HOW YOU DO THIS!

thx,
j

Talornin 12-30-04 12:58 AM

Re: Problems with twinview and default monitor
 
I have two monitor sections "as usual" and this Device setup.

Section "Device"
Identifier "GF4"
Driver "nvidia"
Option "RenderAccel" "true"
Option "NvAGP" "1"
Option "TwinView"
Option "TwinViewOrientation" "RightOf"
Option "MetaModes" "1280x1024,1280x1024;"
Option "ConnectedMonitor" "crt,crt"

Edit:
I dont want to post my entire xorg.conf file since its a mess of self made comments and various setups. Its not suited for the public :D


All times are GMT -5. The time now is 07:13 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.