nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Linux 2.4.19 unresolved symbols... (http://www.nvnews.net/vbulletin/showthread.php?t=431)

wallsaroundme 08-05-02 11:48 AM

Linux 2.4.19 unresolved symbols...
 
I have recently upgraded to Linux 2.4.19 and upon attempting to install the nvidia kernel module(from NVIDIA_kernel-1.0-2960.tar.gz) I get:
depmod: *** Unresolved symbols in /lib/modules/2.4.19/kernel/drivers/video/NVdriver
I have tried doing mrproper before compiling the kernel, removing /lib/modules and recompiling the kernel, and just removing NVdriver. I would really appreciate any suggestions. Thanks!

Thunderbird 08-06-02 03:34 AM

You used incorrect kernel headers to compile the kernel module. Make sure you used the 2.4.19 headers and not others.

stone 08-10-02 04:43 PM

so, where did I go wrong?
 
I just got the same kind of error as the above. However, I don't "think" I'm using the wrong headers.

My system is RH 7.2 with an upgraded kernel. I installed one from RH which was tailored to my athlon processor. Later, I installed header files and the source which seemed to be necessary for the compilation:

$ rpm -qa | grep 'kernel'
kernel-2.4.9-34
kernel-source-2.4.9-34
kernel-drm-stub-4.1.0-0.ximian.1
kernel-headers-2.4.9-34

When I use 'make install' as suggested in the installation info, I get an error message when the Makefile does "depmod -a". I chaged it to "depmod -ae" to get a list of the offending symbols:
# make
ld -r -o NVdriver Module-linux Module-nvkernel
size NVdriver
text data bss dec hex filename
824285 52788 52396 929469 e2ebd NVdriver
depmod: *** Unresolved symbols in /lib/modules/2.4.9-34/kernel/drivers/video/NVdriver
depmod: remove_proc_entry_Rba0f71a3
depmod: mem_map_R70f5c94c
depmod: init_mm_R8e9747b2
depmod: irq_stat_R4a2c50a8
depmod: proc_root_R4238f957
depmod: create_proc_entry_Rb5f55c8e
depmod: proc_root_driver_R08def4f8
depmod: __pollwait_Rc6c0823d
depmod: register_chrdev_R5f82798b
make: *** [package-install] Error 1

At this point I have really tried to read the relevant documentation, but I feel that I'm at the end of the road here. I would be really grateful for any tips. For instance, should I perhaps recompile the kernel?

/stone

bkofman 08-10-02 08:24 PM

Not sure if I ran into the same problem, but I was getting the same error. I realized that I didn't have /usr/src/linux pointing to the correct kernel header files. After doing
# ln -s /usr/src/kernel-headers-2.4.18-686 /usr/src/linux
and then
# make clean
and finally
# make
I got it to work.
Good luck!
\ben


All times are GMT -5. The time now is 04:24 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.