nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   GLX module fails to load on FreeBSD 5.3-p2, Xorg6.8.1 (http://www.nvnews.net/vbulletin/showthread.php?t=43147)

imoore 12-29-04 04:51 AM

GLX module fails to load on FreeBSD 5.3-p2, Xorg6.8.1
 
2 Attachment(s)
Hi,
I've been using the 1.0.6113 driver with FreeBSD 5.3-p2 & Xorg 6.7.0 without any trouble. I cvsuped my ports the other day and updated everything. Now I have Xorg 6.8.1 and the Nvidia driver 1.0.6113_2 port installed.
When I start X, the nvidia driver loads (I see the splash screen) but OpenGL apps run *very* slowly.
In the Xorg.0.log log file, it looks like glx fails to load, but 2D acceleration works:
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(**) NVIDIA(0): DPMS enabled
(EE) NVIDIA(0): Failed to load GLX

The card is a GeForce4 Ti 4200. The only change I made to my config files after the upgrade was changing the keyboard driver in xorg.conf from keyboard to kbd. I've attached the xorg.conf file & the Xorg log file.

sysctl -a hw.nvidia gives:
hw.nvidia.agp.card.rates: 8x 4x
hw.nvidia.agp.card.fw: supported
hw.nvidia.agp.card.sba: supported
hw.nvidia.agp.card.registers: 0x1f000e1b:0x1f000302
hw.nvidia.agp.status.status: enabled
hw.nvidia.agp.status.driver: nvidia
hw.nvidia.agp.status.rate: 8x
hw.nvidia.agp.status.fw: disabled
hw.nvidia.agp.status.sba: enabled
hw.nvidia.version: NVIDIA FreeBSD x86 NVIDIA Kernel Module 1.0-6113 Mon Aug 2 16:08:32 PDT 2004
hw.nvidia.registry.EnableVia4x: 0
hw.nvidia.registry.EnableALiAGP: 0
hw.nvidia.registry.NvAGP: 1
hw.nvidia.registry.EnableAGPSBA: 0
hw.nvidia.registry.EnableAGPFW: 0
hw.nvidia.registry.SoftEDIDs: 1
hw.nvidia.registry.Mobile: 4294967295
hw.nvidia.registry.ResmanDebugLevel: 4294967295
hw.nvidia.registry.FlatPanelMode: 0
hw.nvidia.cards.0.model: GeForce4 Ti 4200 with AGP8X
hw.nvidia.cards.0.irq: 11
hw.nvidia.cards.0.vbios: 04.28.20.21.00
hw.nvidia.cards.0.type: AGP

Hope someone can help.

Cheers,
Ian

zander 12-29-04 06:26 AM

Re: GLX module fails to load on FreeBSD 5.3-p2, Xorg6.8.1
 
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="X.Org Foundation"
compiled for 6.8.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="X.Org Foundation"
compiled for 6.8.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="X.Org Foundation"
compiled for 6.8.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/freebsd/libdrm.a
(II) Module drm: vendor="X.Org Foundation"
compiled for 6.8.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension XFree86-DRI


The X server is loading its own GLX extension module; reinstalling the NVIDIA driver should fix that problem. If it doesn't, then try libglx.a out of the way.

imoore 12-29-04 06:50 AM

Re: GLX module fails to load on FreeBSD 5.3-p2, Xorg6.8.1
 
Quote:

Originally Posted by zander
The X server is loading its own GLX extension module; reinstalling the NVIDIA driver should fix that problem. If it doesn't, then try libglx.a out of the way.

Thanks, reinstalling fixed the problem :-)

Cheers,
Ian


All times are GMT -5. The time now is 06:49 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.