nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nvidia sound drivers (http://www.nvnews.net/vbulletin/showthread.php?t=4514)

nano1 11-26-02 01:38 PM

nvidia sound drivers
 
I have a motherboard made by Asus: A7N266-VM
It has video, audio and lan onboard. I was able to make the lan and video work, but audio doesn't.
I tried to load the module :
insmod i810_audio
it tried to load the module and drivers I suppose(I am new to this, Linux):
When I type the command above I got the following:
insmod i810_audio
using /lib/modules/2.4.18-3/kernel/drivers/sound/i810_audio.o
/lib/modules/2.4.18-3/kernel/drivers/sound/i810_audio.o: unresolved symbol ac97_probe_codec_R84601c2b
/lib/modules/2.4.18-3/kernel/drivers/sound/i810_audio.o: unresolved symbol ac97_set_adc_rate_R5307368c
/lib/modules/2.4.18-3/kernel/drivers/sound/i810_audio.o: unresolve symbol ac97_set_dac_rate_R42924aaa
I used the i810, because somebody suggested.
Please help!!!

Cheshiremackat 12-01-02 08:51 PM

I can help
 
Ok man... I have the same setup...and had the same problem... try this... open etc/modules.conf (use vi)

there should be a line
alias sound-slot-1 i810 audio (or similar you will find it)
change the -1 to -0 (zero) and save... restart and you "should" have sound...

I am running RH7.3 .18_3 and have sound, vid and lan all working...

hope this helps

_CMK

tourettes 12-04-02 12:25 PM

All you were missing was the ac97_codec module. If you had issued the command "modprobe i810_audio" rather then "insmod" then it would have automatically installed all the needed modules for the i810_audio module to function correctly. The above post should do that for you.

ReKoRD 12-07-02 05:53 AM

Im having the same problem but im using Debian 3.0 woody with the 2.4.20 kernel and ASUS A7N8X Deluxe motherboard with nvidia Soundstorm on-board soundcard

When i try modprobe i810_audio it cant even find my module... and when i try modprobe nvaudio i get the exact same error as the above...

I used the .tar.gz source for nforce2 from nvidia.. and did a "make" but when i made a "make install" i get the same error as above to, so i think it didnt install the i810_audio module.. or something, havent a clue really... :confused:

tourettes 12-12-02 02:13 PM

Here's the thing. If you're using the nforce package that were provided from NVidia's website, you would have installed a patched version of the i810_audio module . The new name would be "nvaudio". If you have installed this package, then issue the command "modprobe nvaudio". Otherwise, you need to recompile your kernel, and under the sound section, choose "Module" for sound card support and "Module" choose the Intel i810 audio . It's even made easier now because since kernel 2.4.19, they have nforce audio listed next to i810 in menuconfig. Then you could "modprobe i810_audio".


All times are GMT -5. The time now is 06:14 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.