nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Aargghh! nforce audio! Aarrgghh! (http://www.nvnews.net/vbulletin/showthread.php?t=46076)

jeffsmith8 02-17-05 01:42 AM

Aargghh! nforce audio! Aarrgghh!

I am a linux newbie trying to move away from windows entirely. So far linux has been wonderful, I really like it much more and have configured a nice system that doesn't crash. My final and most painful episode with drivers, however, is that of the nforce audio....

I have been searching forums and trying for a couple of months now to get my nforce sound working. By now I am well and truly confused by all the variables- kernel-types, soundstorm, not sound storm, hardware mixing, software mixing, alsa, aRts, OSS, threaded OSS etc. The search terms keep multiplying! Finally I am sick of it all and am going back to the intel 810 driver that initially was working in at least some rudimentary form.

However, in a last ditch effort I am actually going to stop searching and post for the first time on this problem in the simple hope that maybe somebody out there can offer a complete solution to the problem.....I'll try to be as detailed as possible......

Hardware: A7N8X Deluxe mobo, and Hercules 5.1 speakers
Distro & kernel: FC2, KDE (3.2 I think), and kernel 2.6.10
Sound server: Have tried alsa, aRts, OSS, Threaded OSS (enabled from KDE menu)

This is what I've done:

0. I installed nvmixer (can't remember how, it was so long ago) and the utility works well with the intel audio albeit with very limited functionality.

1. Next, I ran "sh NFORCE-Linux-x86-1.0-0292-pkg1.run"

2. It didn't install so I manually edited the two nearly created files in accordance with this thread;

3. Now it installs properly I edit my modprobe.conf file in accordance with the Nforce release notes, so it now looks like this

alias eth0 3c59x
#alias eth1 forcedeth
alias eth1 nvnet
alias scsi_hostadapter sata_sil
#alias snd-card-0 snd-intel8x0
alias snd-card-0 snd-intel8x0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias char-major-195* nvidia

4. With great excitement (because I hadn't gotten this far before) I reboot, only to be met with this message:

Sound Server Fatal Error
AudioSubSystem::handleI0:write failed
len=-1, can_write=1024, errno=11 (Resource temporarily unavailable)
This might be a sound hardware/driver specific problem (see aRts FAQ))

5. Another window also comes up and asks if I want to deactivate the aRts sound server.

I click yes.

6. Still no sound. I play around with OSS, Threaded OSS, and alsa and various applications from the KDE menu but still receive no sound.

Many, many people appear to be having similiar problems, and some people appear to have resolved them (mostly on 2.4 series kernels) but EVERYONE seems to be having trouble just piecing together a complete solution.

Similiarly I've been trying suggestion after suggestion for ages and very little of it is coming together.

Has anyone had success with this problem and, if so, can you please give a run-down of how you did it?

Fingers crossed......... :(

P.S. that sticky on A7N8X I can't find anywhere- even on that other forum.

All times are GMT -5. The time now is 11:40 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.