nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   two problems with Nvidia_kernel-1.0-3123 (http://www.nvnews.net/vbulletin/showthread.php?t=4697)

adrin 12-02-02 08:52 PM

two problems with Nvidia_kernel-1.0-3123
 
I have two potentially related problems, which I hope gurus on this list will be able to resolve:

I have an AMD Athlon MP-based linux box with a Quadro 4 XGL 700 installed.

With Red Hat 7.3, kernel version 2.4.18-3 and Nvidia_kernel-1.0-2960 and its corresponding GLX files everything works ok.

I've upgraded the kernel to version 2.4.18-18.7.x; and I've downloaded Nvidia_kernel-1.0-3123 for Athlon and the corresponding GLX files. I had difficulty with the rpm approach, so I've used the tar files to install.

Everything compiles (and installs?) without error messages; however:

(1) The NVdriver does not load automatically at boot time, and yes "alias char-major-195 NVdriver" exists in /etc/modules.conf

(2) For some reason the driver does not recognize the monitor and when I use startx, the monitor signals "No Sync" and the linux box reboots itself!

GLcore and dri modules are deleted in XF86Config-4; glx is loaded, and "vesa" is replaced with "nvidia" in the same config file. The monitor I use is Viewsonic VX800, 18" digital flat screen, so as with the previous kernel version that worked perfectly well, I have assigned the horizontal and vertical frequency ranges as well as the resolution in XF86Config-4. However, for some reason startx just won't start properly.

I have checked ALL the files for their existence in the correct directories and with the correct links, as outlined in the NVLinuxR25Notes_3123 notes and have exhausted all tests.

I'd really appreciate any help I can get

adrin

bwkaz 12-03-02 09:32 AM

For the automatic loading, you can try changing alias char-major-195 NVdriver to be alias /dev/nvidia* NVdriver instead. Run /sbin/depmod -a afterward.

Then, the easiest way to test is probably to just reboot and try to start X up.

Not sure about the other one, but maybe an Option "ConnectedMonitor" "DFP" in your XF86Config(-4) file?

adrin 12-03-02 05:15 PM

I tried "alias /dev/nvidia* NVdriver" + "/sbin/depmod -a" + "reboot" and the NVdriver module still did not load automatically!

Also tried Option "ConnectedMonitor" "DFP" with no luck with X!

Thanks

adrin

bwkaz 12-03-02 05:49 PM

Does the module load when you "modprobe NVdriver"?

Are you sure the /dev/nvidia[0123] device files exist?

adrin 12-20-02 08:21 PM

Does the module load when you "modprobe NVdriver"?

Yes

Are you sure the /dev/nvidia[0123] device files exist?

/dev/nvidia[0..9 & ctl] device files exist

Andy Mecham 12-21-02 02:51 AM

Have you tried 1.0-4191?

--andy

adrin 12-22-02 01:31 AM

Right after I submitted my previous post I tried 1.0-4191!

Unfortunately, _exactly_ the same problem(s) again.

I have compiled the source codes (no rpms were used) and there were no errors whatsoever. I have used the correct(?) XF86Config-4; well it's the same as the one that works fine with version 2960 and the earlier linux kernel.

I have checked all the required files and links as per the nvidia document. I have also read the FAQ's etc. I don't see any error messages in the XFree86.0.log file (perhaps I'm not looking at all the files? - I've used verbose 5) My modules.conf has "alias char-major-195 nvidia". The /dev/nvidia* files are there, etc. etc. etc.

I have upgraded my Red Hat 7.3 kernel to 2.4.18-19.7.x and all the required files have higher versions than those required in the nvidia manual.

The problems are, again:

(1) The nvidia module will not load automatically at boot time and I have tried all the recommendations on this thread

(2) subsequent to loading the module manually I run startx but rather than the program crashing and printing a message on the screen (short of doing the right thing, of course!) it automatically reboots the system!

I have tried the process using ViewSonic P95f+ CRT and ViewSonic VX800 DFP, both give the same headache.

I have tried everything I know for well over 2 weeks now and I'm REALLY VERY frustrated.

BTW, I've checked the thread on 1.0-4191 and it seems that others have had sort of similar problems

I would appreciate it if someone would "babysit" me through checking the proper files for possible errors to finally take care of this issue. If there is a particular file that might help resolve this issue please let me know and I'll include it here

Thanks

adrin


All times are GMT -5. The time now is 08:59 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.