nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   6800U PCIe Issues - Summary (http://www.nvnews.net/vbulletin/showthread.php?t=47053)

scourge 03-05-05 10:10 AM

[SOLVED] 6800U PCIe Issues - Summary
 
After reading various threads here, I realized that most people are having the same problems I do. But it seems, nobody has been able to find a solution for the major issues yet.

My System:

Asus A8N-SLI (latest BIOS)
Gainward 6800U PCIe (BIOS v. 05.40.02.36.05)
Athlon64 3500+
2GB Kingston HyperX DDR400
CPU, GPU, Chipset watercooled
550W PSU
Driver v. 6629 (all patches applied; tried older releases as well)
Linux Kernel 2.6.9/10/11 (doesn't seem to make a difference)


Issue 1 - Freezing
------------------------

This happens under Windows as well, games just freeze for about 10 sec. Tried setting 3D/2D clock speeds to 425 MHz via CoolBits which seemed to help a bit, but the freezes remain after all and occour randomly.
Stock settings were 400 MHz 2D, 425 MHz 3D. Unfortunally this is impossible under Linux. because there's no tool to do it (nvclock doesn't work).

Unfortunally, NiBiTor (2.0a) doesn't read 6800U PCIe BIOSes correctly. I tried my own backuped BIOS as well as others from mvktech.net, but every time either 2D oder 3D speed isn't read correctly (65344MHz for example)
I upped my BIOS here in case anyone is interested


Issue 2 - Lockups (Linux specific)
---------------------------------------------

Resolutions up to 800x600 work very well. Wen I try to run 3D Apps with higher resolutions (SPECviewperf, Doom3, ... ), 3 things may happen:

1) It works. Once it runs, it runs. Rock solid.

2) Lockup. Machine sometimes reboots after 30-60 sec.

3) Crash to Desktop + display corruption (see here)

And of course, lots of "Xid" in the kernel log:
Code:

log-2005-03-04-15:19:40:Mar  3 18:09:50 [kernel] NVRM: Xid: 23,  L1 -> L0
log-2005-03-04-15:19:40:Mar  3 18:09:51 [kernel] NVRM: Xid: 23,  L0 -> L0
log-2005-03-04-15:19:40:Mar  3 18:09:52 [kernel] NVRM: Xid: 23,  L1 -> L0
log-2005-03-05-15:55:02:Mar  4 16:24:03 [kernel] NVRM: Xid: 23,  L1 -> L0
log-2005-03-05-15:55:02:Mar  4 18:50:59 [kernel] NVRM: Xid: 23,  L1 -> L0

Now that I can't do more than wait for a new driver, I'd like to have a few questions answered:

- Is NVIDIA aware of these issues? Do they know what causes these problems?
- When will the next driver be released? Will it address these issues?
- What does "Xid" mean?
- Is there a newer PCIe BIOS than 05.40.02.36.05 available? Can't find any.

b_kuhn 03-06-05 09:50 PM

Re: 6800U PCIe Issues - Summary
 
Hi!

I also had in-game freezes in UT2004, but these have been below one
second and disapeared after setting "VARSize" in UT2004.ini to "0"
(this defines the size of AGP cache in main memory which doesn't
make sence on PCIe).

My system (A8N-SLI, Athlon64 3500+, Galaxy 6800GT, 470W PSU, Fedora
Core3) works rock stable - never crashed.

From my ten years of linux experience, sudden reboots are typically
hardware issues. I suggest trying out if using another PSU or graphic
card makes a difference. Maybe the CPU heat sink is not perfectly
mounted - does the machine also crash during compilation or other
CPU demanding processes?

regards

Bernhard

scourge 03-07-05 01:10 AM

Re: 6800U PCIe Issues - Summary
 
Hi,

the funny part is, it only crashes during initialization. I had SPECviewperf running for 24h at 1280x1024 without problems, I'm able to play Cedega emulated WoW for hours without problems. I just cant't tell if it will load up or not.

The freezes have almost disappeared, but that seems to be a 6800 specific issue (see http://www.nvnews.net/vbulletin/showthread.php?t=32759 )

zander 03-07-05 02:46 AM

Re: 6800U PCIe Issues - Summary
 
@scourge: does the problem reproduce if you start a simple application like `gxlgears` first, then close it and start Viewperf right after that?

ZicoTheTux 03-07-05 03:56 AM

Re: 6800U PCIe Issues - Summary
 
Exactly the sam prob here.
After VGA-BIOS Update it was gone. I flashed it with NVFlash via DOS_Boot Disk.

scourge 03-07-05 04:01 AM

Re: 6800U PCIe Issues - Summary
 
Quote:

Originally Posted by zander
@scourge: does the problem reproduce if you start a simple application like `gxlgears` first, then close it and start Viewperf right after that?


From my experience, there are 2 things that increase the chance of a crash:

1) Resolution. The higher the resolution, the higher the chance of a crash. 640x480 runs completely stable. 800x600 is ok, almost no crashes. 1024x768 is ok too, chance is 1:10. 1280x1024 is unuseable.

2) Uptime. The longer the machine runs, the bigger the chance of the crash. I can reproduce it almost every time by playing some vids/mp3s, surfing the web for a while etc. The next 3D app I start is very likely to crash the machine. After a reboot, I usually don't have any problems. (maybe some messed up registers)

These problems are Linux specific btw, Windows is completely stable. (Kernel 2.6.11, X.org 6.8.0)

scourge 03-07-05 04:27 AM

Re: 6800U PCIe Issues - Summary
 
Quote:

Originally Posted by ZicoTheTux
Exactly the sam prob here.
After VGA-BIOS Update it was gone. I flashed it with NVFlash via DOS_Boot Disk.

Which BIOS did you use? I didn't find a newer version than mine. (Gainward PowerPack! 2600PCX, 05.40.02.36.05)

ZicoTheTux 03-07-05 06:21 AM

Re: 6800U PCIe Issues - Summary
 
Quote:

Originally Posted by scourge
Which BIOS did you use? I didn't find a newer version than mine. (Gainward PowerPack! 2600PCX, 05.40.02.36.05)

Currently i use 5.40.02.36.00. Before i had 5.40.02.10.14.
I had these Xid Messages and scrambles pixels all over the screen, too. The System was only stable if i set the Res to 800x600 or lower. If it was higher i could use X for 3 or 5 Minutes. When a 3D Screensaver started after this period of time the problems began.
It seems, that you expire the same, too. For me its only the BIOS 5.40.02.36.00.
Sine this Update the sys runs rocksolid for WEEKS.

scourge 03-07-05 06:33 AM

Re: 6800U PCIe Issues - Summary
 
Quote:

Originally Posted by ZicoTheTux
Currently i use 5.40.02.36.00. Before i had 5.40.02.10.14.
I had these Xid Messages and scrambles pixels all over the screen, too. The System was only stable if i set the Res to 800x600 or lower. If it was higher i could use X for 3 or 5 Minutes. When a 3D Screensaver started after this period of time the problems began.
It seems, that you expire the same, too. For me its only the BIOS 5.40.02.36.00.
Sine this Update the sys runs rocksolid for WEEKS.


Where did you get the BIOS from? On Gainward's ftp there're just 6600 PCIe-BIOSes :(

ZicoTheTux 03-07-05 07:07 AM

Re: 6800U PCIe Issues - Summary
 
I got it from mvktech.net. But you said, you tried this versions already. Perhaps you should google around a little bit or ask Gainward directly per Mail or Phone.

scourge 03-07-05 07:23 AM

Re: 6800U PCIe Issues - Summary
 
Quote:

Originally Posted by ZicoTheTux
I got it from mvktech.net. But you said, you tried this versions already. Perhaps you should google around a little bit or ask Gainward directly per Mail or Phone.

I looked there for a newer BIOS, but 05.40.02.36.00 is older than 05.40.02.36.05, so I didn't try it at all ;)

Do you remember which one you flashed exactly?

ZicoTheTux 03-07-05 08:09 AM

Re: 6800U PCIe Issues - Summary
 
Hmm i took this Version right of the Point of View (Manuf. of my Card) Section of the Page. If you find this Version (see above) for your card or a generic BIOS (in the NVIDIA FIrmaware Section) you could try one of them.


All times are GMT -5. The time now is 01:58 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.