nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   NForce Audio & Quake 3 (Urban Terror) (http://www.nvnews.net/vbulletin/showthread.php?t=4752)

tourettes 12-04-02 01:33 PM

NForce Audio & Quake 3 (Urban Terror)
 
I have an Asus A7N-266E mother board with onboard nforce audio 5.1 dolby, 8139 network and a geforce 2 mx (i have an add-in card now instead). The problem I am having is that when I enter a game, the screen freezes and the sound loops as soon as I "teleport" in (you can still see the ripples of the teleporter). As well, whenever I play the Quake 3 mod Urban Terror, the game locks up when it plays the theme music (which plays on the front screen and since version 2.6, between each map). I know this is a sound problem because with the audio turned off, it works fine.

First off, I used the i810_audio driver that comes with the kernel....that didn't work. So I used nvidia's patched i810_audio module, and that didn't work. I installed Alsa following it's Nforce page word-for-word, and that didn't work. All other sounds work in the game, for example, off of startup, i can hear everything fine, just as soon as I enter a game in Quake 3 it locks. For Urban Terror, I can connect directly to an online game and play with full sound, but as soon as the map ends and the theme music (is suppose to) plays, it locks and I have to restart my Xserver.

I have tried this under several distributions. Ones that come to mind are Debian 3.0 (as well as Sarge and Sid), Mandrake 9, SuSE 8.1 (currently installed) and Redhat 7.3. I have tried the latest kernel modules, the latest nvidia modules and the cvs version of Alsa.

Is there any way to track the output to the audio device to see where it is freezing to? Obviously there must be something different about those sound files that causes it to freeze like that. I have incresed my com_soundmegs to a larger number to no avail as well. When I check the console, there is no verbose errors, just regular output.

Any help or suggestions with this would be greatly appreciated....thank you.

Chalnoth 12-04-02 06:58 PM

Well, nVidia fairly recently released the 0248 version nForce drivers. Have you tried them (using the nvaudio module)?

tourettes 12-05-02 12:01 AM

Yeah, I keep a close eye on the NVidia release hoping that one of these releases might fix my problem. The latest update was basically for Nforce2. No real changes to the nvaudio module.

Chalnoth 12-05-02 12:35 AM

Actually, it seems to work better overall on my machine. ALAudio in UT didn't work before these drivers...but I suppose that has nothing to do with your problem.

tourettes 12-12-02 03:15 PM

I'm starting to think that it's something wrong with my specific hardware, because I've searched the net high and low for any simlar problems, and it seems that no one else has experienced it before. I have tried several different distributions of linux, but all have the same problem. In windows, it works fine. It must be just one of those strange things that happens.

tourettes 08-26-03 12:40 AM

*bump*

in the hopes that someone new might be able to help.

blueworm 08-27-03 07:38 AM

I have an asus a7n8x
and sound works perfectly in urban terror.
But I did not use nvidia drivers use the alsa drivers u can find them at www.alsa-project.org
the module You need to compile is intel8x0
Follow the instructions to the T and it WILL work for you.

tourettes 10-03-03 07:12 PM

I followed all the instructions on that page to install Alsa, and I experience the EXACT same problem as using any other driver. I don't know if i have a hardware issue or not.



Anyways, I was poking around with the i810_audio module that comes with the linux kernel, and I noticed in the source code that you can set the clocking manually on the modprobe line, so I went ahead and inserted the module with the following:

Quote:

bash$ modprobe -v i810_audio clocking=44100
Fired up quake3, and it works!! So, i go back out, check xmms, and of course, something else breaks. All sounds are "faster". If i play a regular mpg (or ogg) they play faster then normal, and it's enough to be annoying.

Any suggestions on what to do from here?

blueworm 10-04-03 11:39 AM

Get yourself a SB Live it is probably the best supported soundcard under linux.
Even if you do get nvaudio to work there is no hardware mixing which means no Teamspeak no xmms&quake3 at same time no quake2(unless u use oss drivers)etc....
By the way quake3 will run perfectly with oss drivers have u tried them?

tourettes 10-04-03 12:17 PM

Isn't that what the i810_audio modules are? OSS Drivers? I could be wrong tho....

blueworm 10-04-03 03:45 PM

No the oss drivers are in the kernel they do not support full duplex.
In fact nor do nvaudio.
The Good drivers are the alsa drivers which do support full-duplex. but do not support hardware mixing.


All times are GMT -5. The time now is 03:34 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.