nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   WineX hangs with 2960 drivers (http://www.nvnews.net/vbulletin/showthread.php?t=477)

Noclaf 08-06-02 05:26 PM

WineX hangs with 2960 drivers
 
I tried wineX with standard "nv" driver it works ok. With GLX it hangs immediately

Thunderbird 08-06-02 05:46 PM

Submit a bug report then. Likely (I hope atleast) you are a subscriber and then you have the right for tech support. Visit the transgaming page.

Noclaf 08-07-02 01:37 PM

Too many people use NV2960 drivers with winex perfectly and I don't think that it is winex trouble. It's is something wrong with driver config

Thunderbird 08-07-02 05:33 PM

If opengl works fine in other opengl apps (quake3 ... and so on) then it is a driver problem or a winex bug. If other games don't work it is something wrong in the config part. The fault can then only be in XF86Config-4 since there are no other config parts related to video stuff. (for winex you don't need to setup video stuff somehow)

Noclaf 08-08-02 06:45 AM

OpenGL works perfectly in TuxRacer. But wine hangs when I run any graphic app. eg. Diablo II, though Diablo II Video test (simple dialog based app) works fine. I think that it hangs when it tries to render any texture, or show bitmap. Heroes 4 setup (a dialog app but with true-color bitmap) also hangs.

r0gu3 08-08-02 01:45 PM

Try recompiling wine, There is an off chance that something new in the wine tree tries to call a mesa specific function, If this is the case, then re configuring and recompiling wine would be in order, and SHOULD fix your problem.

- r0gu3

Thunderbird 08-08-02 02:15 PM

There's one single thing that can be the problem and that is that there is some stuff of mesa left. For example libGL.a can cause problems if it was there during compile time. If that file exist you need to recompile whole winex and remove the file ofcourse. (on the other side the winex configure script will warn for that ..)

Noclaf 08-08-02 03:46 PM

libGL.a
 
There's no libGL.a file in my system at all. But there are libGL.so and libGLcore.so, but the've come with 2960 drivers. It seems to me that the problem is in mesa, cause winex worked with "nv" driver BEFORE i had recompiled with "nvidia" drivers installed. Now it doesn't work an any video driver


All times are GMT -5. The time now is 12:58 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.