nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   2.6.10 Kernel "Invalid module format" error (http://www.nvnews.net/vbulletin/showthread.php?t=48299)

JoeJaz2 03-26-05 04:46 PM

2.6.10 Kernel "Invalid module format" error
 
1 Attachment(s)
HI,
I am running Gentoo Linux and am using a GeForce 4600 TI. Recently I upgraded to xorg 6.8.2-r1 on a working install of X and the Nvidia driver. (because of package blocking problems, this required me to unmerge X entirely and remerge it). However, durring the upgrade, something broke. Now, whenever I try to run X, I get the error:
Quote:

FATAL: Error inserting nvidia (/lib/modules/2.6.10-3/video/nvidia.ko): Invalid module format
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
...
If I try to load the modprobe the nvidia module with the command "modprobe nvidia"
I also get:
Quote:

FATAL: Error inserting nvidia (/lib/modules/2.6.10-3/video/nvidia.ko): Invalid module format
I have tried re-installing both the "nvidia-glx" and "nvidia-kernel" Gentoo packages. I have also tried using the normal Nvidia package after the gentoo packages failed. I have even gone as far as to analyzing the Makefile and the "locate" command logs and removing every occurances of any file that my have been installed by the packages, and then tried to re-install (to be sure that I had a clean system). I have deleted any occurances of the old nvidia.ko module file in the /lib/modules/2.6.10-3/ directory tree. I have tried running "ldconfig" (and get the mysterious but probably unrelated message "ldconfig: /lib/ld-linux.so.1 is not a symbolic link") I have tried running "opengl-update nvidia". I have tried running the Nvidia installer with the "--kernel-source-path=/usr/src/linux" command line option (and /usr/src/linux is a valid symlink to my kernel source directory). Still, however, I recieve the same error. I'm not sure what else to try other than to rebuild my kernel entirely and try re-installing the module then (I don't know why this would solve the problem since the driver was working before with that kernel, but I running out of ideas). If anyone has had a similar problem or has any ideas as to why I recieve that error, I would be very appreciative. Thank you for taking the time to read this. Attached is the output from the "nvidia-bug-report.sh"

zander 03-27-05 02:19 AM

Re: 2.6.10 Kernel "Invalid module format" error
 
From the nvidia-bug-report.log file:

nvidia: version magic '2.6.10-3 preempt K7 4KSTACKS gcc-3.3' should be '2.6.10-3 preempt PENTIUM4 4KSTACKS gcc-3.3'

It looks like the configuration of the kernel source tree you're building against doesn't match that of the running kernel (i.e. K7 vs. PENTIUM4).

JoeJaz2 03-27-05 03:58 AM

Re: 2.6.10 Kernel "Invalid module format" error
 
Hi,
Thanks for your reply. Apparently I must have selected the wrong kernel arch type and then corrected it later (so that it would be correct next time I built the kernel). I did resolve this problem by running "make mrproper," rebuilding the kernel, and then reinstalling the nvidia driver. Thanks to your help, I not only have a properly running X/nvidia build, but my kernel is optimized for my architecture.


All times are GMT -5. The time now is 01:50 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.