nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   1.0-7174 freezes whole system after 30 seconds running any tv capture program (http://www.nvnews.net/vbulletin/showthread.php?t=48567)

zwierzak 04-01-05 03:00 PM

1.0-7174 freezes whole system after 30 seconds running any tv capture program
 
1 Attachment(s)
Hello,

I have this problem since any driver after vewrsion 5336 (this is last one that is working correctly with video4linux layer). I have TV tuner, and compiled all modules into kernel (2.4.28 at the moment). When I try to run any aplication to watch TV (such xawtv, motv etc.) system is responsible for about 30 seconds and then freezes to death. I can still watch the tv output on screen, but rest is totaly dead. It even lead to data corruption (even if I am using jurnalig fs - reiserfs here). Maybe it is some bug with video4linux and xfree X11 and nvidia. I coudn't yet try 2.4.29 linux kernel nor Xorg X11 but I hope I try it in some time when I can. Now attaching the log file, hope it will help to solve problems. If any questions or test needed, please send me a massegae and I will answer/do tests.

Zwierz

P.S. Just forgot to mention. I use bttv drivers from kernel.

chunkey 04-01-05 04:02 PM

Re: 1.0-7174 freezes whole system after 30 seconds running any tv capture program
 
Well, there isn't anything I can do... but... try:
motv -noxv -remote (atleast this shouldn't crash)

P.S -noxv -remote works also for xawtv!

zwierzak 04-01-05 05:54 PM

Re: 1.0-7174 freezes whole system after 30 seconds running any tv capture program
 
Well... propably will be working but all the advantages of overlay are lost :(
I will check it maybe today when I do all the rest and post results here.

Silax 04-09-05 08:01 PM

Re: 1.0-7174 freezes whole system after 30 seconds running any tv capture program
 
Same problem here.
Some seconds after I launch xawtv X freezes. I can still see the TV image running on the screen, but keyboard and mouse stop responding.

I've tried switching to the "nv" driver and everything worked OK. Same files, just changed in the XF86Config-4:

- commented the line: load "glx"
- changed the line: Driver "Nvidia" to Driver "nv"

and the freeze did no appear. It seems to be related to the NVidia driver.

Kernel 2.6.11.5 (freezes with earlier versions too)
Nvidia driver 7167 (freezes with earlier versions too)
Graphics card: Nvidia GEForce2 MX-400
MotherBoard: Asus A7V

orlo11 04-17-05 03:35 PM

Re: 1.0-7174 freezes whole system after 30 seconds running any tv capture program
 
The same problem occurs on older hardware.
If I let xawtv run _without_any_ furter actions (moving the mouse or so)
the longest time to the freeze was about 8 minutes (then the eatch in the gnome-panel stuck).
I have: Elsa Erazor III (TNT2 with 32MB)
Mainboard with VIA Apollo 133
Pentium III/800
7174
Debian Sarge
CU
Thomas.

ugh 04-20-05 10:17 AM

Re: 1.0-7174 freezes whole system after 30 seconds running any tv capture program
 
same problem here, but only when i use bigger graphical applications AND xawtv running. with xterm or so is not a problem then, but if i start firefox, it freezes very very fast.
sometimes a freeze also apperars when i resize the tv window.
if i try fullscreen mode, it also freezes.

(freeze means, no more mouse or keyboard events are handled, tv motion goes on and sound is still working)

my system:
Debian Testing, kernel 2.6.11.6, XFree 4.3, Nvidia Driver 7174, XFX GF 6600 GT AGP using agpgart on a via kt400 chipset.

sippe 08-25-05 10:43 AM

Re: 1.0-7174 freezes whole system after 30 seconds running any tv capture program
 
this problem still exists, even in 7676!
only way to get xawtv (bttv, overlay) working is to switch back to 5336.


All times are GMT -5. The time now is 04:37 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.