nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia 7XXX linux drivers and OpenGL applications (http://www.nvnews.net/vbulletin/showthread.php?t=48695)

ezu3d 04-04-05 01:22 PM

Nvidia 7XXX linux drivers and OpenGL applications
 
All 7XXX linux drivers using 5700/5900/6600 GPUS are OpenGL applications killers (aka Maya 6.5, shake 3.5 ...). Using linux 2.6* kernel. Poor performance or hang XWindows.

dimitri 04-05-05 05:14 AM

Re: Nvidia 7XXX linux drivers and OpenGL applications
 
How does this help?

It would help if you could post error logs or a precise description of the problem so that it can be reproduced.

ugh 04-05-05 01:17 PM

Re: Nvidia 7XXX linux drivers and OpenGL applications
 
I have similar problems here:
running glxgears works mostly for 15 seconds. then the xserver freezes or the screens go blank. 99%cpu time then for the xserver-process. Sometimes i can kill it from another machine, sometimes not. its really annoying.
another problem with xawtv. there it freezes sometimes when i resize the tv window - or when xawtv runs and i try to start any other application (mostly firefox)

My System Info:
XFree 4.3.0 on debian testing,
Kernel 2.6.11,
Nvidia driver 7174
i use the nividia AGP module, not agpgart.
Motherboard chipset VIA KT400
Card: XFX GF6600 GT

I use a dualhead Setup with two TFT-Screens. No TwinView, No Xinerama.
Configured as described in the Nvidia-README. ( Appendix R, multiple X Screens on one Card).

jds7717 04-05-05 02:33 PM

Re: Nvidia 7XXX linux drivers and OpenGL applications
 
I also have this problem with any of the 7xxx series drivers that have been released thus far. I had to revert back to 6629.

how 04-05-05 06:03 PM

Re: Nvidia 7XXX linux drivers and OpenGL applications
 
Quote:

Originally Posted by ezu3d
All 7XXX linux drivers using 5700/5900/6600 GPUS are OpenGL applications killers (aka Maya 6.5, shake 3.5 ...). Using linux 2.6* kernel. Poor performance or hang XWindows.

same here. happens with any opengl that utilizes AGP. turn down the AGP speed is a workaround.

APwrs 04-06-05 12:30 AM

Re: Nvidia 7XXX linux drivers and OpenGL applications
 
I have something similar going on too. About half the time, when I load a full screen OpenGL program, my system crashes and reboots. The other half of the time, it works fine. I'm using a 5700 card.

ugh 04-06-05 07:21 AM

Re: Nvidia 7XXX linux drivers and OpenGL applications
 
My tries today:

- flashed motherboard bios.
- compiled the driver with forced AGP down to 2 or 1.
The compiling results in a disabling of the driver, because it seems that my board doesnt support AGP Rates beyond 4. quite strange.

Finally, disabling AGP changed nothing on my problems, but glxgears runs longer than before... roundabout 35-40 seconds before the screen goes blank.

ugh:/# cat /proc/driver/nvidia/agp/card
Fast Writes: Supported
SBA: Supported
AGP Rates: 8x 4x
Registers: 0xff000e1b:0x00000000

ugh:/# cat /proc/driver/nvidia/agp/status
Status: Disabled

ugh:/# cat /proc/driver/nvidia/agp/host-bridge
Host Bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 8x 4x
Registers: 0x1f000a0b:0x1f000000

ugh:/# cat /proc/driver/nvidia/cards/0
Model: GeForce 6600 GT
IRQ: 11
Video BIOS: ??.??.??.??.??
Card Type: AGP

its strange that the video bios version isnt displayed....

SuLinUX 04-06-05 08:55 AM

Re: Nvidia 7XXX linux drivers and OpenGL applications
 
Quote:

Originally Posted by ugh
I have similar problems here:
running glxgears works mostly for 15 seconds. then the xserver freezes or the screens go blank. 99%cpu time then for the xserver-process. Sometimes i can kill it from another machine, sometimes not. its really annoying.
another problem with xawtv. there it freezes sometimes when i resize the tv window - or when xawtv runs and i try to start any other application (mostly firefox)

My System Info:
XFree 4.3.0 on debian testing,
Kernel 2.6.11,
Nvidia driver 7174
i use the nividia AGP module, not agpgart.
Motherboard chipset VIA KT400
Card: XFX GF6600 GT

I use a dualhead Setup with two TFT-Screens. No TwinView, No Xinerama.
Configured as described in the Nvidia-README. ( Appendix R, multiple X Screens on one Card).


Use agpgart not the internal nvidia agp as it's known to be unstable.

ugh 04-06-05 10:26 AM

Re: Nvidia 7XXX linux drivers and OpenGL applications
 
before i disabled agpgart i used it with the same problems.
compiled Kernel v. 2.6.11.6 with agpgart and support for my chipset.
Changes nothing :(

i sent a bug report to nvidia and hope the next release will be better for my box....

how 04-06-05 08:27 PM

Re: Nvidia 7XXX linux drivers and OpenGL applications
 
I have captured Nvidia dmesg while opengl applications hang:
This is how you can do it.

tail -f /var/log/messages > output
then run any opengl apps that causes to crash

agpgart give same unstable problem.

Apr 7 11:07:23 localhost kernel: NVRM: Xid: 13, 0002 beef3901 00000039 00000324 00040101 00000002
Apr 7 11:07:23 localhost kernel: NVRM: Xid: 6, PE0000 08e0 9ff9c304 00000000 9ff9c304 00000000
Apr 7 11:07:29 localhost kernel: NVRM: Xid: 6, PE0002 0000 bd890000 00000000 bd890000 00000000
Apr 7 11:07:29 localhost kernel: NVRM: Xid: 6, PE0002 0000 beef0000 00000000 beef0000 00000000
Apr 7 11:07:29 localhost last message repeated 4 times
Apr 7 11:07:30 localhost kernel: NVRM: Xid: 6, PE0002 0000 beef0000 00000030 beef0000 00000000
Apr 7 11:07:30 localhost kernel: NVRM: Xid: 6, PE0002 0000 beef0000 00000000 beef0000 00000000

APwrs 04-06-05 10:24 PM

Re: Nvidia 7XXX linux drivers and OpenGL applications
 
I went back to the old drivers and experienced the same crash issue, especially with Doom 3, which crashes every single time once the you begin to actually enter the game... after choosing your dificulty and it loads all the resources.

That lead me to believe that perhaps it was sound related, because while the screen is still blank, the sound starts and stutters, and then the computer crashes. This happens sometimes with other OpenGL games too.

I changed from ALSA drivers to OSS drivers, and Doom 3 didn't recognize the audio output and disabled the sound, and then the game loaded and ran fine... just without the sound. So, it would appear that at least on my system, there's some conflict between ALSA drivers (or perhaps when a program tries to use ALSA's OSS compatability drivers?) and OpenGL that causes the whole system to crash.

gilboa 04-07-05 07:52 AM

Re: Nvidia 7XXX linux drivers and OpenGL applications
 
Quote:

Originally Posted by APwrs
I went back to the old drivers and experienced the same crash issue, especially with Doom 3, which crashes every single time once the you begin to actually enter the game... after choosing your dificulty and it loads all the resources.

That lead me to believe that perhaps it was sound related, because while the screen is still blank, the sound starts and stutters, and then the computer crashes. This happens sometimes with other OpenGL games too.

The sound begins to shutter because, presumably, (at least by my experience) your nVidia driver crashed and the X process is eating 100% CPU time.
Try connecting to the downed machine using ssh after it had crashed and report back with your findings.


All times are GMT -5. The time now is 01:00 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.