nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Boot problem (http://www.nvnews.net/vbulletin/showthread.php?t=4907)

Walt Dizzy 12-09-02 07:17 AM

Boot problem
 
After installing SuSE 8.1 on my nForce system, I get all the way to the end of the install, and a screen pops up that tells me to reboot the system. I press enter to reboot, and the initial screen pops up for boot. The bars on the left turn white one by one until the process stops with this error message:

kernel (hd 0,1)/boot/vmlinuz root=/dev/hda2 hdc=ide-scsi vga 791 3

[Linux-bzImage, setup=0x1400, size=0x10aab8]

Error 28: Selected item cannot fit into memory.

Grub version 0.92 (512K lower/523184K upper memory)

My system has an ASUS A77N266-C motherboard, a Leadtek Geforce 3 Ti 200 videocard, Maxtor 60 GB disk, Escalade 6200 RAID controller, and Siemans NIC.

Things I've tried so far:

Reinstalled SuSE without RAID and modem.
Reinstalled SuSE on RAID.
Used Manual install option in order to leave out drivers for a smaller kernel. No change in kernel size.
Reinstalled with APIC.
Tried booting from a tested floppy rescue disk set. Locks up with caps and numlock light flashing. Can't check boot log!

This set of SuSE install disks has been used successfully on another machine.

My next idea is to try Red Hat. Any other ideas?

Mandarb1 12-09-02 11:38 AM

Are you sure root is on the right partition? My root is on hda7, but Im also dual booting...

Walt Dizzy 12-09-02 01:24 PM

I think so. The error message is the same whether I install to a single disk with nothing else on it but Linux, or if I set up a dual boot system with Win2K. If I recall correctly, the root partition was on hda(1) before my last install attempt to the RAID array.

Thanks anyway.

I think that the error message is misleading. It indicates the kernel is just over 1 MB in size, and is too big for the system memory. There is 500 MB of memory in this computer, and if I recall correctly, Linux is not limited to low 20 bit-first 1MB?) memory. Can anyone confirm this?

Walt

Chalnoth 12-10-02 12:02 AM

I had this problem too, but selecting LILO as the boot manager seems to work great. Haven't bothered to further troubleshoot the problem...

Walt Dizzy 12-11-02 03:35 PM

Thanks, I will give this a try as soon as I can figure out how to do so.

algida 12-12-02 03:34 AM

:-(
 
I have same problem,
I try to install RH 8.0 and there was same error.
I cant use LILO, because i linux on disk where are Win on first partiton. :-(
I'm instaling it two weeks.
Can you help me?
Ales

Chalnoth 12-12-02 03:41 AM

Well, all I did was placed a 32MB boot partition at the front of the drive so I could use LILO just fine with my Linux partition after the first 8GB of space.

But, I had heard that that 8GB limitation was fixed in more recent versions. Have you tried it with RH 8.0, or did it just fail on previous versions?

algida 12-12-02 03:53 AM

Suse 8.1 and Redhat 8.0
 
I tied to install Redhat 8.0 and Suse 8.1.
I cant do anything with firs partition, because there are Win Xp with many programs and data:-(.
Sorry for my English
Ales

Chalnoth 12-12-02 03:57 AM

See if you can get your hands on Partition Magic. You should be able to do just about anything you want with that.

Barring that, if you really want Linux, you can just backup your essential data on a second partition, then wipe the Windows partition and put that little boot partition at the front of the drive. It's a big hassle, and not something I'd be willing to do right now, but it is an option.

algida 12-12-02 04:01 AM

:-(
 
There are no other ways?
Only to use Lilo??
Sorry for stupid question.
ales

Chalnoth 12-12-02 10:57 AM

Well, there probably is. I don't know it, though.

Klaus-P 12-16-02 09:52 AM

" There are no other ways?
Only to use Lilo??"

Install the linux package "loadlin" under win or dos from your linux CD.
and do also copy a linux standard kernel image in the appropriate
windows directory
Then modify your "config.sys" file and the loadlin config file "linux.par"
and you will get a windows-linux startmenu whenever your computer boots.
Later you can also copy other linux kernels to the same place.


All times are GMT -5. The time now is 01:23 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.