nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   problem with cedega - segmentation fault line 348... (http://www.nvnews.net/vbulletin/showthread.php?t=49602)

jechkaar 04-23-05 03:56 PM

problem with cedega - segmentation fault line 348...
This a really long post so bare with me, i already did a lot of research.....

ok this is what happened,

first off, i quite new to linux (yes another one)
I recently installer Mandrake Powerpack 10.1, on my PC.

i managed to install some program i needed, and after a while i felt like i was starting to get around...

So i decided to install cedega, to try to play Diablo 2 in linux, instead of continually switching back from linux to windows.

Everything went fine, and before i knew it i was playing diablo2 on my lan....


My problem is that after a while i decided to try out Suse an got rid of my "temporary" Mandrake Install.

But i ended up not liking Suse as much as Mandrake (had issues after my installtion so i formatted and reinstalled Mandrake)

so mandrake is reinstalled, i reinstall my programs, like before, and reinstall cedega, but when i try to start anything a get this error message :

[toxic@localhost toxic]$ cedega "/mnt/win_e/Diablo II/Diablo II.exe"
/usr/bin/cedega: line 348: 4691 Segmentation fault $SHELL -c "$RUNWINE $WINVER -debugmsg $DEBUGMSG -use-dos-cwd $WORKDIR $EJECT $DT -- $COMMAND_LINE"

this is with diablo2 but i tested with any *.exe file and nothing happen except the error.

now i googled a lot in the past weeek aboiut this problem but i didnt find anything (except this maybe related to nvidia drviers ???) The only website talking about something resembling my problem, where in some obscure and unknown language (be me atleast).

So now i have a clean install of mandrake , as before and i cannot play anygame (through cedega)

Does anyone as any clue what can be the source of my problem...

as basic info, i'm running on a geforcefx 5900xt with nvidia 6111 driver, on dual screen with xinerama (as before, when it was working), i got an nforce2 ultra chipsetr on asus a7n8x mobo... 1gig ram, so definetly enough.... same files, same install...

mandrake 10.1, kernel : - (base kernel in this distro) as nvidia 6111, preinstalled drivers... (as before)

i tryed running cedega in my session and in root, with no success. Tryed reinstalling it in different seesion, as root, anything....

oh and i also tried editing the cedega binary to see what is on line 348 (in my error msg), but line 348 is the endoffile.

i also tried
as suggested elsewhere

The first time it was working (before i formatted) , the only difference ...

before : "/" is ext2 fs, 6 gig...
after : "/" is reiserfs, 30 gig, with 600mg swap file (same program installed, only difference is that i installed samba server, should really not matter)

still have the same video driver and everything else...

(all config files are standard, not modified, as i didnt modify them the first time y installed....)

well gonna continu looking on the net for those to error (line 348 and line 87 (error line 87 happens with cvscedega)), unfortunatly most of the webpage discussing them are in some unknow language...


i tried with a lot of .exe, including notepad.exe and calc.exe, but the problem is not the exe because it gives me the same error no matter what...

my driver are installed properly, currently version 6111 (wich are preinstalled in mandrake 10.1 powerpack)

i did every test in ppoint2play, and passed them all.

direct rendering is on


well, back at my place, i redid the --debugmsg

cedega --debugmsg +all "/mnt/win_c/windws/system32/calc.exe"

it gives me something like this :

a lot of debugmsg
from 001-
to 244-

244 - 0002:trace:reg:NtEnumerateValueKey (0x20,40,1,0xbfffea3c,256)
Setting the debug level to 1
0002:: boot_done() = 0
244 - 0002:trace:heap:RtlAllocateHeap (40370000,00000002,0000004c): returning 40370d50
244 - 0002:trace:reg:NtOpenKey (0x80000002,L"Software\\Wine\\Wine\\Config\\AppDef aults",f003f,0xbfffeae0)
0002:: open_key( parent=-2147483646, access=000f003f, name=L"Software\\Wine\\Wine\\Config\\AppDefaults" )
0002:: open_key() = 0 { hkey=32 }
245 - 0002:trace:reg:NtOpenKey <- 0x0020
245 - 0002:trace:heap:RtlFreeHeap (40370000,00000002,40370d50): returning TRUE
245 - 0002:trace:heap:RtlAllocateHeap (40370000,00000002,0000002c): returning 40370d50
245 - 0002:trace:reg:NtOpenKey (0x20,L"calc.exe\\TransGaming",f003f,0xbfffeadc)
0002:: open_key( parent=32, access=000f003f, name=L"calc.exe\\TransGaming" )
0002:: open_key() = OBJECT_NAME_NOT_FOUND { hkey=0 }
245 - 0002:trace:reg:NtOpenKey <- 0x0000
245 - 0002:trace:heap:RtlFreeHeap (40370000,00000002,40370d50): returning TRUE
0002:: close_handle( handle=32 )
0002:: close_handle() = 0 { fd=-1 }
246 - 0002:trace:heap:RtlAllocateHeap (40370000,00000002,00000024): returning 40370d50
246 - 0002:trace:dosfs:DOSFS_GetFullName /mnt/win_c/windws/system32/calc.exe (last=1)
246 - 0002:trace:dosfs:DRIVE_FindDriveRoot /mnt/win_c/windws -> drive G:, root='/', name='/mnt/win_c/windws/system32/calc.exe'
246 - 0002:trace:string:lstrcpynA (0xbfffe864, "/", 1024)
246 - 0002:trace:dosfs:DOSFS_FindUnixName /,mnt/win_c/windws/system32/calc.exe
246 - 0002:trace:heap:RtlAllocateHeap (40370000,00000002,0000022c): returning 40370094
246 - 0002:trace:dosfs:DOSFS_FindUnixName (/mnt,mnt/win_c/windws/system32/calc.exe) -> mnt (MNT)
246 - 0002:trace:heap:RtlFreeHeap (40370000,00000002,40370094): returning TRUE
247 - 0002:trace:dosfs:DOSFS_FindUnixName /mnt,win_c/windws/system32/calc.exe
247 - 0002:trace:heap:RtlAllocateHeap (40370000,00000002,0000022c): returning 40370094
247 - 0002:trace:dosfs:DOSFS_FindUnixName (/mnt,win_c/windws/system32/calc.exe) -> win_c (WIN_C)
247 - 0002:trace:heap:RtlFreeHeap (40370000,00000002,40370094): returning TRUE
247 - 0002:trace:dosfs:DOSFS_FindUnixName /mnt/win_c,windws/system32/calc.exe
247 - 0002:trace:heap:RtlAllocateHeap (40370000,00000002,0000022c): returning 40370094
fd server: Closing fd server[1] 9
/usr/bin/cedega: line 348: 12785 Segmentation fault $SHELL -c "$RUNWINE $WINVER -debugmsg $DEBUGMSG -use-dos-cwd $WORKDIR $EJECT $DT -- $COMMAND_LINE"
[toxic@localhost toxic]$ 0002:: *killed* exit_code=0/(nil)
fd server: exiting on revent 16
fd server: thread stopping
wineserver: Error on distributed command: 10
Server: exiting (pid=12788)
atexit destroy of semaphore

this is the debug it gives me...
i didnt post it all, because it was like 10 pages long....
but it goes all the ways to 001

ex: 247 - 0002:trace:heap:RtlAllocateHeap
where 247 downs to 001.....

hope this help you to help me :)

EDIT, and so you know i did try wine (pure) and got it "working", but it is just not an option for me rigth now...


well thats it for now, hope someone will have a clue!

joltcola 04-27-05 11:24 AM

Re: problem with cedega - segmentation fault line 348...
I too am new to linux (and have no clue what i'm doing).

I don't have an answer to your question. Not sure where to start. But, I noticed you haven't gotten a response on this, I thought I'd suggest something. Maybe it help, it may not. Check out this forum here, and post your question. They seem quite helpfull there and obviously the whole forum is geared towards linux and the various distros. They even have a newbie section that i've been reading for the last few days to answer my own questions about linux. There is another forum you should check out, but I'm still trying to find the link for as I am currently at work.

Good luck!

-- jolt

jechkaar 04-27-05 07:08 PM

Re: problem with cedega - segmentation fault line 348...
thanks a lot - joltcola - , i didn't know of this forum (wow now i realise i'm more of a noob than i though first)

but at least it is a new way for me to get information, i'll post my question there as there seems to be a lot of people going on the forum.

well at least i'll have 1 more place where to search.

jechkaar 05-10-05 02:57 PM

Re: problem with cedega - segmentation fault line 348...
EDIT : WELL problem fixed by repartitionning, reformatting and installing Mandriva 2005 le and the last nvidia 7174 driver...

as of now everything is working #1.

Thanks anyways, but this problem doesn't exit anymore in my computer.

************************************************** ******

All times are GMT -5. The time now is 09:31 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.