nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   2.4.29 module build fails - (HIMEM) (http://www.nvnews.net/vbulletin/showthread.php?t=49720)

uname-a 04-25-05 08:06 PM

2.4.29 module build fails - (HIMEM)
 
1 Attachment(s)
This box unfortunately can't be upgraded to 2.6.x, as it does all of the builds for the 2.4.x and glibc 2.2.4 stuff we support.

My apologies as well, this should have been posted in the NVIDIA Linux forum, but landed here amidst the redirects from creating an account.

(edit - This is the 7174 driver)

Kernel module build completes, but module load dies on unresolved symbols after enabling himem support (4G and 64G, tried both). Works fine on a kernel without himem support compiled in.

Though this box was 'redhat' at some point, the first thing I do with redhat boxes is get rid of their kernel rpms, and get the real source from kernel.org, fix broken links, etc.. so that section in the README doesn't seem particularly relevant.

Attached is the installer log, though the relevant lines are:

--cut--

-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.o'. This is most likely
because the kernel module was built using the wrong kernel source files.
Please make sure you have installed the kernel source files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel source
files are installed, you may specify the kernel source path with the
'--kernel-source-path' commandline option.
-> Kernel module load error: ./usr/src/nv/nvidia.o: unresolved symbol
kunmap_high
./usr/src/nv/nvidia.o: unresolved symbol highmem_start_page
./usr/src/nv/nvidia.o: unresolved symbol kmap_high
./usr/src/nv/nvidia.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. The module may be trying to access
GPLONLY symbols but the problem is more likely to be a coding or
user error. Contact the module supplier for assistance, only they
can help you.

--cut--

Building with gcc 3.3.1, glibc 2.2.4.
built with the usual `make dep clean bzImage modules && make modules_install`

One additional note: I use ccache. (not that it's ever failed, building hundreds of other packages..)

Any help would be appreciated.

uname-a 04-26-05 08:16 AM

Re: 2.4.29 module build fails - (HIMEM) FIXED
 
Duh.. it's probably been a half dozen kernel versions since i bothered to do a 'make mrproper' (Turns out the README was relevant after all)

Fix was as simple as this:

make xconfig
(without himem support) and save config as NO_HIMEM
make mrproper
cp NO_HIMEM .config
make oldconfig
make xconfig (and enable himem stuff)
make dep clean bzImage modules && make modules_install

Probably would have worked just as well if i'd just enabled himem stuff, saved the config as a file.. done mrproper, restored the .config and then make oldconfig.

Anyways, thanks for the reads. Hope this helps somebody.


All times are GMT -5. The time now is 09:56 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.