nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   mandrake 9 Nvidia driver Install (http://www.nvnews.net/vbulletin/showthread.php?t=4977)

=Super_n00b= 12-10-02 09:56 PM

mandrake 9 Nvidia driver Install
 
Can i please get some HELP ? :confused:

Im very new to mandrake/Linux. Im using Mandrake 9, Can someone please help me to install nvidia Drivers onto my system i have an AMD 2000+XP, 512 meg DDR, Abit Kg-7 mobo and GeForce 4 Ti4600. i have read Tons of Tech Forum posts but i need a Learners guide "10 years of windows use" if anyone would be kind enough to help :confused:

When i tried to install the tar.gz i get this error

"You appear to be compiling the NVdriver kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1"

Thanks

Super.

bwkaz 12-11-02 07:38 AM

What do cat /proc/version, echo $CC, $CC -v, and cc -v tell you?

You probably need to install a compiler (in which case this is not a very good error message -- but it is possible that that's what happened anyway), but seeing what these print (if anything -- the echo $CC one might not do anything, in which case the $CC -v isn't useful) will confirm or deny that.

=Super_n00b= 12-11-02 09:03 AM

Only thing i get is this ....


"[root@LinuXTesT craig]# cat /proc/version
Linux version 2.4.19-16mdk (quintela@bi.mandrakesoft.com) (gcc version 3.2 (Mandrake Linux 9.0 3.2-1mdk)) #1 Fri Sep 20 18:15:05 CEST 2002 ?

bwkaz 12-11-02 12:42 PM

What about cc -v? Something about command not found?

Something will be printed -- what?

=Super_n00b= 12-11-02 08:21 PM

yep cc -v command not found

=Super_n00b= 12-11-02 08:39 PM

i have also tried the new nvidia drivers this morning and i still get the same error :( :confused:

Andy Mecham 12-11-02 09:01 PM

'cc -v: command not found' indicates that you don't have 'cc' (a compiler) installed. To rebuild the drivers, you'll need to have development tools (compiler, linker, etc) installed.

If you're using a stock install of Mandrake 9.0, you shouldn't need to use the SRPM or source tarball packages - you should be able to use the binary RPMs. Please visit http://www.nvidia.com/view.asp?IO=li..._ia32_1.0-4191 and download NVchooser.sh (see STEP 3). It will tell you which files to download and install. Also, make sure you have a copy of the README available for reference.

--andy

bwkaz 12-11-02 10:32 PM

Yeah, what Andy has posted would be the first thing to do.

If for some reason you want 3123, or if you want to compile from source for some other reason, then you can put in your Mandrake CD 1, reboot to the Mandrake installer, go through it but make sure you select upgrade instead of install when asked, select "development" on the first package selection screen, and let it continue on through where it copies files, and then exit it, you should get a compiler installed. After that's done, make sure CD 1 isn't in the drive, and reboot back to Linux. Then retry the cc -v, and you should get "gcc version 3.2" printed.

If you do, then restart the nVidia drivers. However, as I said earlier, the binary RPMs for 4191 should work if you would rather go that route.

=Super_n00b= 12-11-02 11:02 PM

ok ill give the RPM's a try..Just that last time i used the RPM it died :(
OK i have now loaded the New Nvidis RPM's and edited the XF86Config-4 like the Destructions said time to reboot X
Stay tuned and thank you eveyone for being so helpfull.

Cheers.

=Super_n00b= 12-12-02 12:05 AM

:D WOOOOOOHOOOOOOOOOO:D

5338 FPS in GLXGEARS You guys ROCK.. Thank you Sooo much for all the help!
It didnt all go super smooth but i figured the last bit out.. I ran the NVIDIA_GLX-1.0-4191.src.rpm the first time :( oops but i just updated it to the i386 and X booted and its going tops.. Again THANK YOU SO MUCH !

Cheers

P.S. -- now where is a good place to Download Good 3D Games ?????

=Super_n00b= 12-15-02 06:56 AM

Ok Guys .. More bad news.. After the last week of play'n with everuthing in Mandrake i decided to start from scratch now i have a better understanding and re-install so i could setup just how i wanted to ..
OOPS bad move i say .. Now when im installing the 4191 Nvidia Drivers(Same ones as i used Last time) im getting this "error: failed dependencies: kernel = 2.4.8-26mdk is needed" But in my Control Center i have 2.4.19-16mdk Ummm Any ideas ?

Thanks

Super

Exner 12-15-02 07:26 AM

Quote:

Originally posted by =Super_n00b=
OOPS bad move i say .. Now when im installing the 4191 Nvidia Drivers(Same ones as i used Last time) im getting this "error: failed dependencies: kernel = 2.4.8-26mdk is needed" But in my Control Center i have 2.4.19-16mdk Ummm Any ideas ?
Sounds like you've installed Mandrake 8.2 instead of Mandrake 9.0. Try the NVIDIA_kernel RPM for Mandrake 8.2.


All times are GMT -5. The time now is 05:48 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.