nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Okay, I'm completely lost (http://www.nvnews.net/vbulletin/showthread.php?t=5025)

dave 12-11-02 10:33 PM

Okay, I'm completely lost
 
I have no idea how to get my new GeForce 2 MX400 VTO card to work under XFree86 4.2.1. I've replaced a RIVA TNT PCI card, which was working fine, with this AGP card. I'm running Mandrake 9.0 (stock kernel) on a Via Apollo Pro chipset MB with a max 2x AGP slot.

I've tried pretty much anything I could think of, including upgrading from 3123 to 4191. I've tried setting NvAGP to 0, 1, 2 and 3, each in turn, in /etc/X11/XF86Config-4. I've set an option of NVreg_ReqAGPRate in /etc/modules.conf, having tried both 2 and 1.

Everything looks fine in /var/log/XFree86.0.log with not so much as a warning let alone an error. The card is identified and the correct resources appear to be ascribed.

Okay, here's the symptom. X starts fine and runs fine (glxgears turns at about 150 fps) but, after anywhere from 30 s to 3 m, it (almost) locks the entire computer. The cursor will move, like, once every 2 minutes and, if I hit Ctrl-Alt-Bksp at the exact second that it moves I can kill the server, else I have to power down.

I'm tearing my hair out so any advice would be appreciated. BTW, this machine dual boots Win 98SE and the card is working fine in there.

dave

brblueser 12-12-02 12:34 PM

Hi Dave,

Yikes! :( This looks pretty nasty...

I happen to have the same graphics card (not VTO, though), although on top of a different chipset (VIA KT266). It always worked just fine for me.

Have you tried VIA forums? They have one dedicated to Linux here. Also, make sure you check /var/log/messages as well, some probls might only appear there.

When you first start X (before computer goes crazy), what does 'cat /proc/driver/nvidia/agp/status' say? What about other files there?

dave 12-12-02 09:12 PM

Thanks, friend, for that link. I was able to identify my trouble because of it. It was originally called the NV Loop error but, now, most people call it the Infinite Loop error. It was originally identified with nVIDIA GeForce cards on VIA motherboards running Windows XP but it's now known that it can be seen on any hardware with any operating system. There's a synopsis here. Unfortunately, a solution doesn't appear to be forthcoming. If you have any info on this error, please let me know as I'm dying having to use this Windows box!!!

dave

brblueser 12-13-02 12:40 PM

My pleasure, Dave :)

I am sorry to hear you found no solution there. Another thing that has just crossed my mind: have you tried playing with AGP drive strength on BIOS? Appendix F of the Linux driver README says:

Many Via based mainboards allow adjusting the AGP drive strength in
the system BIOS. The setting of this option largely affects system
stability, the range between 0xEA and 0xEE seems to work best for
NVIDIA hardware. Setting either nibble to 0xF generally restults in
severe stability problems.
If you decide to experiment with this, you need to be aware of
the fact that you are doing so at your own risk and that you may
render your system unbootable with improper settings until you
reset the setting to a working value (w/ a PCI graphics card or
by resetting the BIOS to its default values).


(kinda scary, but since things are not working anyway... worst thing that could happen is forcing you to reset BIOS directly on the mobo's jumper if things go really bad).

Also, I would suggest trying out latest kernel (2.4.20), which is the one I am using right now with 4191 driver (although 2.4.19 worked just fine with 3123).

HTH

brblueser 12-13-02 01:00 PM

Just found this other forum when Googling for "nvidia tv-out freezes", maybe you will find some answers there...

(actually, Google originally suggested me the "old" GeForce2/3/4 forum)

dave 12-17-02 08:06 AM

Resignation
 
Well, I give up. After many days lost to this error and after many false hopes dashed I've thrown in the towel. I've pulled the GeForce card and gone back to the RIVA TNT. The RIVA works flawlessly with the new drivers, I might add. Very nice... :)

For the record, these are things that didn't work for me either singly or in any imaginable combinations:

1. Selectively disabling software that seemed to hang.

2. Changing the value of NvAGP to anything at all

3. Changing the value of NVreg_RegAGPRate to any reasonable number

4. Reseating the card multiple times

5. Changing to a power supply with 28A on the 3.3V rail.

6. Altering any setting in the BIOS that has to do with AGP or video or memory or whatever

BTW, I was getting glxgears to turn at over 350 fps at AGP 2x with this card before it would lock up! The RIVA gives me about 160.

Google searches yield literally thousands of people who are experiencing this error under various configurations so I would imagine it will become more of a concern to the community at large as time goes on.

Well, thanks for your help, brblueser. I really appreciate your help and concern...

brblueser 12-17-02 11:43 AM

Hi Dave,

I am sorry to hear that things haven't gone well for you. It's strange, maybe the Apollo Pro + GF2 is a dreadful combination... as I said, I am running 4191 with a GF2 MX 400 and things are fine most of the time (I only say that because I've already experienced some nasty lock up once when I tried to run Quake3 -- even though Quake3 does usually run fine here).

Are you running GNOME? There have been many posts on the official Linux driver forum about people experiencing probls with GNOME (mostly slowdowns), and these probls going away if they try something else. I am running AfterStep here, even though I run many apps which use GTK2.

It did seem you've done all you could, I can't think of anything else I could suggest. Sorry :( Guess we'll have to wait for the next drivers to come out...

Best,

Andre

dave 12-21-02 10:24 AM

Update
 
A friend gave me a GeForce 2 MX 200 card this week and I tried that. Surprisingly, the display quality was better with the MX 200 than with the MX 400. Stability was no better, though with constant lockups.

Again, I went back to the TNT card and it works perfectly. I'm going to try a Radeon card after the holiday.

rnf 12-21-02 02:23 PM

Before you go for a Radeon XFree86 4.2 still doesn't support very well.

We have had some problems at my office with a GeForce2 on a KT133 motherboard (not exactly what you have but ...) . Two things you might verify:
  • in the BIOS, try 0xDA for the AGP driving value;
  • ensure your refresh rate isn't below 75Hz, with value lower than that we observed periodic freezes of the machine (this threshold value might well change from machine to machine).

dave 12-22-02 08:32 PM

Thanks for the advice. Unfortunately, the (Award v 1.16) BIOS I'm running does not permit me to set the window for AGP. In fact, the only choice I have is AGP on or off. The refresh rate was, in fact, 85 Hz. I ramped it down as low as 75 Hz only at 1600 x 1200. It would lock even at 640 x 480 which, IIRC, was running at 120 Hz.

What's that about the Radeon not being well supported by XF86 4.2? I was under the impression that the Radeon 8500 and up were fully supported and that the 7500 is fully supported with the DRI driver?

rnf 12-23-02 01:37 PM

One thing I forgot to mention: we also had to disable PCI delayed transactions from the BIOS configuration screen.
Quote:

What's that about the Radeon not being well supported by XF86 4.2? I was under the impression that the Radeon 8500 and up were fully supported and that the 7500 is fully supported with the DRI driver?
We have a notebook with a Readeon 7500 and sometimes, when the xserver (4.2.1) starts, it just displays agitated nuts and we have to stop and restart it. But maybe it only happens on the notebook version of the chip? We did not try any OpenGL program with the DRI though, so I cannot tell how it behaves.

dave 01-07-03 07:31 AM

Final? update
 
Well, I got the Radeon card (Radeon 7500 64 MB DDR with v/D/O) as a replacement for the GeForce. When I received it, I was dismayed to find that it was "Powered by ATi" rather than "Built by ATi". Apparently, support for the "Powered by" cards is inconsistent. The card manufacturer is Sapphire. As it turns out, the card installed with minimal difficulty and works flawlessly. I'm getting glxgears at its default screen size over a 1280x1024 24 bpp desktop to put out about 880 fps.

I've had the card up for about 72 h, now, and it appears to work flawlessly without lockup at 1x AGP (2x is still a bit of a problem.) The only difficulty I had in getting the card to run was resolved by removing the nVIDIA GLX stuff and replacing it with stock GLX.

Thanks to everyone for your consideration and for your help.

dave


All times are GMT -5. The time now is 07:01 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.