nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Need help for A7N266-VM/AA and RedHad 7.2 (http://www.nvnews.net/vbulletin/showthread.php?t=5056)

jxu 12-12-02 10:50 AM

Need help for A7N266-VM/AA and RedHad 7.2
 
When I was installing RedHat 7.2 on A7N266-VM/AA, the system got "graphics unprobed" problem and suspended. It looks like the 7.2 can't detected and configured the onboard graphics. What should I do to get 7.2 installed and running?

Thanks,

Jim

bwkaz 12-12-02 11:33 AM

I assume that even though the only hardware that you listed was an Asus motherboard, you have an nVidia video card, right?

You can manually select the VESA drivers until you get RedHat running, then change over to the nVidia ones once it's up...

jxu 12-12-02 12:27 PM

This motherboard has integrated gForce2 MX core with 32MB shared memory. I was doing a fresh Linux installation. The issue I have with RH7.2 is that it doesn't tell you to config the graphics until the selected packages have been installed on the hard drive. Then came the error message and system suspense. I tried to select gForce or gForce2 or gForce2 MX. They all fail.

bwkaz 12-12-02 02:04 PM

What chipset is that motherboard? There might be AGP issues with it and RH 7.2...

Does selecting VESA-compatible (or whatever RH calls it) help anyway? So that AGP gets disabled until you can get a kernel (or chipset drivers) that support(s) whatever that chipset is? Do you know which kernel RH 7.2 installs, offhand?

jxu 12-12-02 02:19 PM

North Bridge
Chipset Name:
nForce 220D
Manufacturer: nVidia
AGP FSB: 4X (Build-In)
CPU Type: AMD Athlon XP and Duron
CPU FSB: 200/266
Memory Type: DDR
Memory FSB: DDR 200/266
Max Memory: N/A

Sourth Bridge
Chipset Name:
nForce MCP-D
Manufacturer:
nVidia
Number Of USB: 6
Version Of USB: 1.1
Support IDE Data: ATA 33/66/100
AMR/CNR/ACR* : CNR/ACR


The kernel is 2.4.7-10.

bwkaz 12-12-02 04:40 PM

Yep, that's the problem. 2.4.7 doesn't have a clue how an nForce motherboard works. You might be able to use VESA video, then install the nForce drivers from nVidia, but I don't know for sure whether those include an AGP driver or not. They may not.

If they don't, then the first order of business would be to find a kernel (if there is one) that works with nForce AGP. I'm not convinced that there is one, actually... which might be bad.

If you can at least get a system up, then you might be able to get the nVidia video drivers to work with NvAgp set to "0" -- AGP disabled.

jxu 12-12-02 04:46 PM

bwkaz,

Thanks much for your help. I'll probably try one of followings:

1. Try RH 8.0, or
2. Put a PCI video card to get the system installed and running. Then go back to install the nForce Linux driver package(s).

Regards,

Jim

comstar 12-13-02 06:18 PM

All you have to do is install differently . . .
 
Your best bet with any RH that doesn't have direct support for the video card -- indicative by failing to initialize during install, is at boot time (during install) choose the option to install via text mode -- usually by typing the word 'text' at the boot prompt.

After installation is complete, you can install the nvidia RPMs for your graphics card or other chipset.

Hope this helps.

Cheshiremackat 12-14-02 03:57 AM

NO NO NO NO NO
 
Hey... I have the same Mobo... here is what you do

1) There is a great instruction set for this mobo and redhat 7.3 success story , by RTZ , search for "nforce redhat success"

for this Mobo you need 3 files...
1) nvidia nforce driver (install this first)
2) Glx file
3) nvidia kernel
download NVchooser to see what files you need

basically you will need to do this...

install redhat as per usual, 'cept do not select ANY video options... IIRC there is a choice to not configure Xwindows... THEN
restart and boot your linux install when you see the Lilo (GRUb wont work) hit ctrl-x and type "linux 3"

you will then boot and get a command line... install the nforce driver first, then restart (linux 3 again)... then install nvidia glx and nv kernel... then restart and configure XF86 file...

then restart and it *should* work...

NOw I know this sounds like alot of pain... BUT I did it and it is easy... if you have a zip drive it ames it easy b/c you can put all the files on one disk... or burn a cd, that is easy too...

MAKE SURE YOU CHECK OUT THE INSTRUCTIONS BY RTZ... makes it really easy.... come back if you need help...

IO have RH 7.3 running on my system right now, same MoBo so it will work... just read the RTZ forum...

_CMK

jxu 12-17-02 09:30 PM

Thanks all. I am typing this message on my A7N266-VM running RH8.0. Some notes,

shall use LILO;
shall use text mode before any video working;
for video, make sure device driver names match;
for sound, may need to add "modprobe nvaudio" in /etc/rc.d/rc.local;
for nvnet, it worked for me first time;
went with tarballs.

Happy NV Linux!

Jim


All times are GMT -5. The time now is 02:35 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.