nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Games on Linux (http://www.nvnews.net/vbulletin/showthread.php?t=5106)

=Super_n00b= 12-13-02 07:12 AM

Games on Linux
Im after MOHAA and/or SOFII for linux..I have RTCW and Q3A Windows versions running without winex or win4lin But i need more...Is there anything out there ?? Or am i dreaming ?


tuxfriend 12-13-02 01:54 PM

Yes,there is a lot stuff out there:

www.linuxgames.com for information

www.tuxgames.com where to buy games

www.icculus.org more stuff like Serious Sam Port Quake2 and many more.

SOF2 runs under winex for MOHAA I dont know.

Look for UT and UT2003 they are avaiable inder Linux to.

Have a lot of fun


=Super_n00b= 12-13-02 05:27 PM

Xlent.. Thanks for the links.I have UT2003 i bought it for Winpoos :)
How well does WineX work ?

tuxfriend 12-14-02 05:20 AM

Winex works well with some games but its a little tricky to install.
Search for FAQs and visit www.transgaming.com before you start
messing around with it.
http://www.frankscorner.org/wine/ has FAQs-very helpfull.
By the way you dont need Winex for UT2003 the linux_installer is
on the 3rd cd.
Games I run with Winex:
I got the .rpms now and I will try other games over the holiday season.


Mandarb1 12-14-02 12:57 PM

Where did you get the rpms for those games tuxracer? You didnt have to mess around with Wine or WineX for those games you listed in your last post?

tuxfriend 12-14-02 01:48 PM


There are no rpms for the games,what I get is the rpm for Winex.You must

register for min 3 month for 15$.The issue is here that rpms are a lot

easier to install,you can use Wine and Winex,the rpm takes care of some

install and copyprotection probelms and at frankscorner there is even

a gameinstaller for winex.rpm only.

Installing from cvs is not easy at all but it worked for me.

Same with the games,SOF2 as an example I could not install with the

installer(there is a workaround now on transgaming) so I did a Win-install

and copied the game over the network on the linux-gamingPC.

Winex has a fake_win and also a registry the same I learnd to hate in those win-days.So if you copy a game from a win-installation you cant

patch it without hacking the registry.

Sometime you need a no-cdcrack to run a game.Stronghold as an


So I really like real linux-ports like Q3 or RTCW.

But if you want some extragames wine and winex is the solution

and you will learn a little about your linux-believe it.

Just try it out.


=Super_n00b= 12-14-02 05:10 PM

Ok First i have to say This is the BEST Linux forum i have EVER registerd with you guys are EXELENT i have not seen a single "Pissoff n00b" or "you dumb Bastard" here at all. Thanks so much to everyone here for being so helpfull..2nd I got the WineX CVS and followd the destructions to the letter and It workes great.. Without you guy's i think id still be fumbeling round lost in linux..Oh and i tried to install my UT2003 but for some reason at the "please insert your Game Disk" It cant find Disk 1, I used the Install.SH from Disk3 both from the CD3 and copy'd it to HDD both ways gave me the same problem..

Big Thanks To All


=Super_n00b= 12-14-02 06:02 PM

Ok .. i have just tried to install JKII with winex ..Umm has anyone seen this ?

"The installshield Enjine (iKernel.exe) Could not be installed, The folder 'C:\Program Files\Common FilesREE8' Could not be created. (0x5)"

tuxfriend 12-15-02 04:32 AM

Q: I've just bought Unreal Tournament 2003, and i can't get it to install. The installer on the third disk asks me to install the "PLAY" disk, but no matter which disk i try, they all fail. What's wrong?
A: The Linux installer asks for the wrong disc names. This was the
results of an unfortunate miscommunication right before the disc went
gold. The installer will ask for "play disc", "disc 1", "disc 2". What
it should ask for is "disc 1", "disc 2", "disc 3". This is
obnoxious, but it is not fatal, as the text is just used in the
user interface, and is not used in detecting the disc. Just put
in the disc it wants, not the one it asks for. :)
A: Note that, perhaps most importantly, the other questions about the original Unreal Tournament apply. Especially with regard to joilet support. When you mount disc 3 to look for the installer, you should see linux_installer.sh, not linux_in.sh. The option you want (as far as my 2.4.19-based system is concerned) in the kernel configuration is under "Filesystems". Enable "ISO 9660 CDROM file system support" and then "Microsoft Joliet CDROM extensions". If there is a "Rock Ridge extensions" option, enable that too.
A: Do not sit on the mount point, or you won't be able to switch discs. So if
you do this (or something like it):
mount -t iso9660 -r /dev/cdrom /mnt
cd /mnt
You won't be able to unmout the disc when the installer asks for the next disc
in the series, since your shell is still sitting in the mountpoint. It will
work better if you do something more like this:
mount -t iso9660 -r /dev/cdrom /mnt
cd /somewhere/else
The installer copies itself to $TMPDIR before running, so it shouldn't
be sitting on the mountpoint. If this still isn't working, copy the installer
yourself, to make sure it is not blocking your unmount:
mount -t iso9660 -r /dev/cdrom /mnt
cp /mnt/linux_installer.sh $HOME
umount /mnt (this is making sure the disc is unmountable)
A: Are you using Mandrake? If so, you will probably need to disable supermount for your CDROM/DVDROM drive, since it appears to be interfering with the installer's ability to detect the CDROM properly. To turn it off, run drakconf, go to "Mount Points" -> DVD (or CDROM) -> Options -> uncheck supermount.
Save your changes, make sure the CDs are completely unmounted, and then try the installer again. you'll need to manually mount the cdroms, insert disk 3, run the installer, and it should work fine now.
Other distributions will need to use their way of turning off supermount, although we don't know of any others that use it by default.
A: If you get a bunch of errors to the console for each file installed, talking
about different devices in your /etc/fstab, they can (usually) be ignored. If
they are causing trouble, temporarily comment those lines out of fstab.
(If that makes you nervous, the SETUP_CDROM environment variable described
below accomplishes this better.)
A: If you have multiple CD drives, and the installer is continuously
grinding the one you're not currently installing off, then tells you
"mount: no media" or similar, just stuff one of the other ut2k3 CDs into
that drive. The installer will even pick up on that and save you a disk
change later.
A: If you are SURE you've got the correct disc mounted and the installer seems
to disagree, export the environment SETUP_CDROM before running the installer,
and you might be able to fool it (this is untested):
export SETUP_CDROM=/where/i/mounted/the/cdrom
The installer doesn't care if it's really a CD, so if you get really desperate,
you can copy it to your harddrive or mount an ISO on a loopback device, etc.
The installer just looks for files in a directory tree to decide if the CD-ROM
is mounted. If you've got multiple CD-ROM or DVD-ROM drives, mount a disc
in each and export SETUP_CDROM_CD1, SETUP_CDROM_CD2, and SETUP_CDROM_CD3, and the installer will go directly to those locations for the needed files.
A: The installer will seem to install some stuff very fast, and then really
REALLY slow down, taking a long time for individual files. THIS IS NORMAL.
Files that are compressed into Epic's "uz2" format take a long time to
uncompress. This is the bulk of the installer's work. This game takes a LONG
time to install (you are, after all, uncompressing about 2.5 gigs worth of
A: Read this: https://bugzilla.icculus.org/show_bug.cgi?id=147,
and this: https://bugzilla.icculus.org/show_bug.cgi?id=147.
A: If none of the above works, consider e-mailing our mailing list after
subscribing as described above.
from http://www.icculus.org/lgfaq/
hope this helps

tuxfriend 12-15-02 04:41 AM

for JK2 its the problem with the intrashield installer I mentioned above.
You can copy a win-installation or use this script
Sorry the site is in german.
This one is in english and should solve your problem.


=Super_n00b= 12-15-02 05:05 AM

Maaaannnnn All was going so well to :(
ok hears the deal guys.. I thought id just do a quick reinstall of mandrake as i had play'd around and i was now ready to set it up how i wanted so i thought id start from scratch..

What a mistake that was :( Now wile installing the 4191 Nvidia Drivers i get this "error: failed dependencies: kernel = 2.4.8-26mdk is needed by NVIDIA_kernel-1.0-4191.mdk81up" WTF is that all about ??? if i go into the control Center it tells me i have 2.4.19-16mdk ?? H-E-L-P M-E :( Please :confused:

lunix 12-15-02 06:23 AM

Umm Im not runnign Mandrake but Im pretty sure you have to have the haeders intalled and stuff: linux-2.4.x-devel.rpm?
It is generally accepted that installing from the .tar.gz's works better. There is goldmine of knowledge in the linux & nvidia forum here why not try having a look. TIP: If you are having trouble installing a rpm and its complaining of dependancies that you know are satisfied try adding --nodeps as a option, and or --force for that matter.
BTW for a "noob" you did the right thing by stating what you tried to do and the error resulting from it. It helps the volunteer helpdesk guys imensly.

All times are GMT -5. The time now is 08:05 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.