nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Solaris (http://www.nvnews.net/vbulletin/forumdisplay.php?f=45)
-   -   How to determine proper modeline? (http://www.nvnews.net/vbulletin/showthread.php?t=51994)

Cheetos 06-14-05 03:06 PM

How to determine proper modeline?
 
Prior to switching to switching to the nvidia driver, I was using Xorg's nv driver. I have a Dell 2005FPW which is an LCD monitor with a native resolution of 1680x1050.

When using the nv driver, I was able to specify the ModeLine for that resolution. E.g., the xorg.conf entry was:

Code:

ModeLine    "1680x1050" 188.1 1680 1800 1984 2288 1050 1051 1054 1096
I've been unable to run at 1680x1050 when using the nvidia driver as it complains about the modeline entry. The specific error message is:

Code:

(II) NVIDIA(0): Not using mode "1680x1050" (bad mode clock/interlace/doublescan)
How do I go about determining a proper modeline entry?

eugrus 06-15-05 07:54 AM

Re: How to determine proper modeline?
 
You can set your resolution in Modes line: Section "Screen" -> SubSection "Display" -> Modes

For.Ex.:
Code:

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth    24
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    24
                Modes    "1280x1024"
        EndSubSection
EndSection

There could be several SubSections "Display" for differnet depths, DefaultDepth line is used to switch them.

Cheetos 06-15-05 08:40 AM

Re: How to determine proper modeline?
 
Thanks, for the reply. The problem, unfortunately, is the ModeLine entry. My Screen section does have a Mode entry, referring to the 1680x1050 mode.

Code:

SubSection "Display"
                Viewport  0 0
                Depth    24
                Modes    "1680x1050"
EndSubSection

But the nvidia driver cannot honor that mode request because it thinks the 1680x1050 mode is invalid. Presumably since Xorg's nv driver can support a 1670x1050 resolution, NVidia's nvidia driver can, too. I just don't know how to determine how to construct a proper ModeLine entry.

Cheetos 06-17-05 01:02 PM

Re: How to determine proper modeline?
 
Answer to my own question: use Windows :( ...

The ModeLine entered while working for Xorg's nv did not for NVidia's nvidia. A post on another nvnews forum (here ) identfied a working Modeline entry as reported by some Windows utility.

The working ModeLine entry is:

Code:

ModeLine    "1680x1050" 119.0 1680 1728 1760 1840 1050 1053 1059 1080
and for the record, the entire xorg.conf is:

Code:

Section "ServerLayout"
        Identifier    "default"
        Screen      0  "OfficeScreen" 0 0
        InputDevice    "Mice" "CorePointer"
        InputDevice    "Keyboard" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/X11/lib/X11/rgb"
        ModulePath  "/usr/X11/lib/modules"
        FontPath    "/usr/X11/lib/X11/fonts/TrueType/"
        FontPath    "/usr/X11/lib/X11/fonts/Type1/"
        FontPath    "/usr/X11/lib/X11/fonts/Type1/sun/"
        FontPath    "/usr/X11/lib/X11/fonts/F3bitmaps/"
        FontPath    "/usr/X11/lib/X11/fonts/misc/"
        FontPath    "/usr/X11/lib/X11/fonts/100dpi/"
        FontPath    "/usr/X11/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
        Load  "IA"
        Load  "Xst"
        Load  "dbe"
        Load  "extmod"
        Load  "record"
        Load  "xtrap"
        Load  "bitstream"
        Load  "type1"
        Load  "glx"
EndSection

Section "InputDevice"
        Identifier  "Keyboard"
        Driver      "keyboard"
EndSection

Section "InputDevice"
        Identifier  "Mice"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/mouse"
EndSection

Section "Monitor"
        Identifier  "OfficeHead"
        VendorName  "Dell"
        ModelName    "Dell 2005FPW"
        Option            "DPMS"
        ModeLine    "1680x1050" 119.0 1680 1728 1760 1840 1050 1053 1059 1080
EndSection

Section "Device"
        Identifier  "Quadro4"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName  "NV18GL [Quadro4 NVS AGP 8x]"
        BusID      "PCI:9:0:0"
        Option      "CursorShadow" "true"
EndSection

Section "Screen"
        Identifier "OfficeScreen"
        Device    "Quadro4"
        Monitor    "OfficeHead"
        DefaultDepth 24
        SubSection "Display"
                Viewport  0 0
                Depth    24
                Modes    "1680x1050"
        EndSubSection
EndSection


jordantech 04-26-11 10:44 AM

Re: How to determine proper modeline?
 
Quote:

Originally Posted by Cheetos (Post 632451)
Answer to my own question: use Windows :( ...

The ModeLine entered while working for Xorg's nv did not for NVidia's nvidia. A post on another nvnews forum (here ) identfied a working Modeline entry as reported by some Windows utility.

The working ModeLine entry is:

Code:

ModeLine    "1680x1050" 119.0 1680 1728 1760 1840 1050 1053 1059 1080
and for the record, the entire xorg.conf is:

Code:

Section "ServerLayout"
        Identifier    "default"
        Screen      0  "OfficeScreen" 0 0
        InputDevice    "Mice" "CorePointer"
        InputDevice    "Keyboard" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/X11/lib/X11/rgb"
        ModulePath  "/usr/X11/lib/modules"
        FontPath    "/usr/X11/lib/X11/fonts/TrueType/"
        FontPath    "/usr/X11/lib/X11/fonts/Type1/"
        FontPath    "/usr/X11/lib/X11/fonts/Type1/sun/"
        FontPath    "/usr/X11/lib/X11/fonts/F3bitmaps/"
        FontPath    "/usr/X11/lib/X11/fonts/misc/"
        FontPath    "/usr/X11/lib/X11/fonts/100dpi/"
        FontPath    "/usr/X11/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
        Load  "IA"
        Load  "Xst"
        Load  "dbe"
        Load  "extmod"
        Load  "record"
        Load  "xtrap"
        Load  "bitstream"
        Load  "type1"
        Load  "glx"
EndSection

Section "InputDevice"
        Identifier  "Keyboard"
        Driver      "keyboard"
EndSection

Section "InputDevice"
        Identifier  "Mice"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/mouse"
EndSection

Section "Monitor"
        Identifier  "OfficeHead"
        VendorName  "Dell"
        ModelName    "Dell 2005FPW"
        Option            "DPMS"
        ModeLine    "1680x1050" 119.0 1680 1728 1760 1840 1050 1053 1059 1080
EndSection

Section "Device"
        Identifier  "Quadro4"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName  "NV18GL [Quadro4 NVS AGP 8x]"
        BusID      "PCI:9:0:0"
        Option      "CursorShadow" "true"
EndSection

Section "Screen"
        Identifier "OfficeScreen"
        Device    "Quadro4"
        Monitor    "OfficeHead"
        DefaultDepth 24
        SubSection "Display"
                Viewport  0 0
                Depth    24
                Modes    "1680x1050"
        EndSubSection
EndSection


I'm assuming you were in Linux previously, I am hoping nothing Mac related because that would definitely be an issue. If you want to get this worked out in Ubuntu hit me up, graphics are my specialty along with cloud computing, which reminds me. I have had a lot of success working here through a vCloud. It has been a positive influence on my performance and user experience, so if anybody needs help setting up a vCloud hit me up please.


All times are GMT -5. The time now is 01:48 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.